RT-AX88U / FTP Server not working after FW 3.0.0.4.386_44266-g7f6b0df upgrade

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

nico_ar

Occasional Visitor
Hi
After F/W upgrade from
3.0.0.4.384_9579-g5362374
to
3.0.0.4.386_44266-g7f6b0df
the FTP server is not working anymore on my RT-AX88U Router.
The FTP server worked perfectly before the update and no changes were made to the router's configuration.
So, there is no reason the FTP Server should not work...The FTP server was accessed using the admin credentials stored on my machines.
Meanwhile the Samba Server is working, using the same drive and the same admin credentials.That means the drive is recognized.
Accesing the ftp server on my local network, using Windows Explorer, I get an FTP Folder Error, please see att. files.
Accessing it with another client (Total Commander, https://www.ghisler.com/) I receive the error "Non anonymous sessions must use encryption..." See also att. files. Please note that "Enable TLS support" box is checked. Anybody has any idea what is all about? Is the new F/W screwed up?
 

Attachments

  • FTP connection Total Commander error.jpg.png
    FTP connection Total Commander error.jpg.png
    15.7 KB · Views: 52
  • FTP folder error.png
    FTP folder error.png
    11.7 KB · Views: 52
  • Router Asus FTP Server.png
    Router Asus FTP Server.png
    548.7 KB · Views: 52

ColinTaylor

Part of the Furniture
Please note that "Enable TLS support" box is checked.
Are you sure you're using an FTPS client now and not FTP. It looks like you're still using FTP (hence the error messages).

IIRC the option for TLS (aka FTPS) didn't exist in the 384 firmwares, only plain FTP. If you want to continue using plain FTP you must disable TLS.
 
Last edited:

L&LD

Part of the Furniture
Did you perform a full reset after flashing to the much newer version of the firmware? Without importing a saved backup config file? And without 'blindly' inputting settings, enabling features, or running scripts that worked 'once upon a time'?
 

nico_ar

Occasional Visitor
Are you sure you're using an FTPS client now and not FTP. It looks like you're still using FTP (hence to error messages).

IIRC the option for TLS (aka FTPS) didn't exist in the 384 firmwares, only plain FTP. If you want to continue using plain FTP you must disable TLS.
Thank you very, very much Colin! Yes, the problem was the TLS! Unchecking it solved my issue, as my client was a simple FTP one. I didn't know TLS was not used by the previous firmware. I am very grateful for your help!
 
Last edited:

nico_ar

Occasional Visitor
Did you perform a full reset after flashing to the much newer version of the firmware? Without importing a saved backup config file? And without 'blindly' inputting settings, enabling features, or running scripts that worked 'once upon a time'?
Thank you very much for your answer! I din't perform any reset at all. Meanwhile, with the help from Colin, I solved the issue. The problem was TLS was checked and I was accessing the server with a simple FTP client. Simply unchecking the TLS solved the problem
 

L&LD

Part of the Furniture
Consider yourself lucky then with no reset needed until now. But remember, your router is living 'stable' on borrowed time. :)
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top