Solved RT-AX88U Hang when enabling SSH (Merlin 384.19)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

CSchwang

New Around Here
Hi everyone,

I recently got a new RT-AX88U (aka AX6000) router and flashed Merlin 384.19 on it. While setting it up, I ran into troubles. After enabling SSH and rebooting the router, the wifi networks did not come back up. I reset the router and tried again. This time only setting up SSH --> same result. The router hung after enabling SSH.

Any ideas how I might troubleshoot that?
 

ColinTaylor

Part of the Furniture
Did you do a factory reset after installing Merlin's firmware?
 

CSchwang

New Around Here
Yep. I also did a factory reset every time i managed to lock up the router. (Holding the WPS button while powering on). After the reset I tried a few times to enable ssh.
a) Go through the first boot wizard, reboot, then enable ssh
b) Don't change anything, just enable ssh.

Both times with the same result
 

cooloutac

Senior Member
aaaaaa
Yep. I also did a factory reset every time i managed to lock up the router. (Holding the WPS button while powering on). After the reset I tried a few times to enable ssh.
a) Go through the first boot wizard, reboot, then enable ssh
b) Don't change anything, just enable ssh.

Both times with the same result
reflash, factory reset and after reset try selecting delete /jfss partition option in merlin firmware then reboot. then try to enable ssh.
 

ColinTaylor

Part of the Furniture
If I were you I'd reinstall stock firmware as a baseline and see if that does the same.
 

CSchwang

New Around Here
Thanks Colin and cooloutac. It's working now. I've tried many things and therefore I'm not 100% sure what worked. I have the feeling that a working internet connection was what made the difference. Previously I set up the router without any Network cables connected. Then yesterday night I thought maybe missing time sync or similar might be the culprit. Lo and behold: after connecting the router to my network I was able to successfully enable SSH.

That said, I did try quite a few things and any of those might have fixed the underlying issue. For anyone wit similar issues, this is the sequence of steps that finally caused successful activation of SSH:
  1. Reflash Firmware
  2. Factory Reset
  3. Give router an internet connection (verify that time was synchronized)
  4. Go to Administration -> Format JFFS -> Reboot
  5. Go to Administration -> Enable JFFS -> Reboot
  6. Enable ssh for lan only
  7. Connect to router via SSH
  8. Reboot
  9. --> Success!

All in all, I remember that I a couple of years ago I had the same issue with my RT-AC68U. Back then I thought that I somehow messed up the authorized_keys synthax which caused a boot failure. Back then I just reconfigured everything from scratch and it worked. But thinking about it now, I guess it was it might have also been a missing internet connection. At least this time with my AX88U it was definitely not due to authorized_keys (I made a few tries with just password auth and empty authorized_keys and it still did not work).
 

Jcquantum

Occasional Visitor
Hi all!

I recently got an AX88U as well. Once I uploaded the FW 384.19, I noticed a exclamation notice on status stating my JFSS is about full, but I haven't really set much except the WiFi basic settings, is this normal? Or should I be formatting the JFSS?

Thanks
 

cooloutac

Senior Member
Hi all!

I recently got an AX88U as well. Once I uploaded the FW 384.19, I noticed a exclamation notice on status stating my JFSS is about full, but I haven't really set much except the WiFi basic settings, is this normal? Or should I be formatting the JFSS?

Thanks
definitely not normal. is it enabled? if you don't even use it couldn't hurt to disable it and format on boot. might have to reconfigure your vpn afterwards if using one.
 

Jcquantum

Occasional Visitor
Hi @cooloutac, thanks. The JFGG is disabled as is by default. I have not had a chance to enable it yet. But I am asking to make sure that if I format the JFSS, am I going to remove the atam or other wrist programs?

Thanks.
 

cooloutac

Senior Member
I don't know what wrist programs are. amtm is built into the latest firmwares so it won't be removed. if you don't even have jfss enabled chances are nothing will change except the vpn config. if you want to install scripts through amtm enable jfss first. it says it enables it automatically when you use it, but it didn't for me and I had to enable it manually and reinstall the script.
 

Jcquantum

Occasional Visitor
Hi @cooloutac, thanks. After letting it sit on the side while I did something else, the warning went away when I turned the router back on. I dont know what that was all about..but thanks for the amtm clarification.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top