1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[RT-AX88U] Help setting up routed IPTV

Discussion in 'ASUS AX Routers & Adapters' started by wpte, Nov 21, 2019.

Tags:
  1. wpte

    wpte Occasional Visitor

    Joined:
    Dec 12, 2014
    Messages:
    33
    Location:
    Eindhoven, The Netherlands
    I'm facing a problem with a recent setting my provider KPN (from the Netherlands) changed for their interactive IPTV boxes.

    Right now the setup is in bridged IPTV mode, where I simply just pass VLAN4 untagged to the IPTV box. (see attachment)

    But, what they changed recently is that you'd need bridged IPTV, meaning: the box also requires internet (VLAN1). If not, any interactive options are disabled.

    Fortunately someone created scripts to do just this on Asus routers: https://forum.kpn.com/interactieve-tv-11/routed-iptv-over-eigen-asus-router-rt-ac3200-434951 (it's Dutch but the scripts are commented in English). I do have a better source for these scripts including a manual, but this is the easiest way to show kinda what needs to happen.
    Something like that seems to work just fine on a TY-AC87U for example, except routing performance is incredibly slow. So I don't want to use that one anymore, in fact I gave it away. I'm left with my RT-AX88U and unfortunately the RT-AX88U doesn't have robocfg anymore, but vlanctl.

    I tried, very simply and quickly putting both VLAN1 (LAN) and VLAN4 (TV) both tagged on the port of the TV box, but unfortunately it's not able to get an IP. I suppose it's getting confused.
    Can I make it work with a managed switch at all, do I need a different router? What to do. Can anyone give me a suggestion? It would be very appriciated. :)
     

    Attached Files:

  2. Flooded

    Flooded Occasional Visitor

    Joined:
    Nov 29, 2017
    Messages:
    17
    I don't know if you have tried the basic settings that allow this to work with Asus Routers and BT IPTV here in the UK.

    On the LAN-IPTV tab in LAN settings, try the following:

    Select ISP Profile: None
    Choose IPTV STB Port: None
    Use DHCP routes: Microsoft
    Enable multicast routing (IGMP Proxy): Enable

    If that doesn't work try choosing Manual Setting from the ISP Profile list and play with the various options.
     
  3. wpte

    wpte Occasional Visitor

    Joined:
    Dec 12, 2014
    Messages:
    33
    Location:
    Eindhoven, The Netherlands
    That's the part that doesn't work on an RT-AX88U. You can't assign a switch port to a VLAN and also enable IGMP proxy at the same time.
    Maybe it looks like that when doing something custom, but after saving and applying the settings, it will show that message