RT-AX88U samba shares access

Radek

New Around Here
Hello

I just switch from netgear r7000 and freshtomato to RT-AX88U and merlin. I have a issue with access to smb share from Windows computers. It worked previously on freshtomato. It is working on merlin only when i checked anonymous access. I login to the shares with pattern \username and password, i tried also [email protected] but also got access denied. I added the username access R/W to the catalogs on the share. How can i fix it?

rt.png


issue.png
 

johndoe85

Regular Contributor
Hello

I just switch from netgear r7000 and freshtomato to RT-AX88U and merlin. I have a issue with access to smb share from Windows computers. It worked previously on freshtomato. It is working on merlin only when i checked anonymous access. I login to the shares with pattern \username and password, i tried also [email protected] but also got access denied. I added the username access R/W to the catalogs on the share. How can i fix it?

View attachment 40888

View attachment 40889
After you have clicked saved. Have you clicked apply?
 

bbunge

Part of the Furniture
It is a WIndows problem not a router problem. Likely your Windows PC is remembering the user and password used on your prior router. I surmise you tried to keep your network the same when you switched routers by using the same router IP address and maybe the same router name?
One fix is to set the router to a different IP address. You can also forget the Windows share credentials (Google is your friend here).
I would recommend using Simple Share Naming.
Also set user's and passwords in Network Place in addition to the router user and password.
A better option is to get a NAS. Routers do not make good file sharing appliances.
 

Radek

New Around Here
The IP of the router and network is the same. Name of the router is different. I turned on the Simple Share Naming, after that i'm still accessing the data in the way \\10.20.30.1\data\somefolder or in other way?
Network Place you mean in Windows or some menu in router?
I build new VM to have clear OS and still got access denied error so it looks like it's not credentials cache.
 

johndoe85

Regular Contributor
The IP of the router and network is the same. Name of the router is different. I turned on the Simple Share Naming, after that i'm still accessing the data in the way \\10.20.30.1\data\somefolder or in other way?
Network Place you mean in Windows or some menu in router?
I build new VM to have clear OS and still got access denied error so it looks like it's not credentials cache.
[global]
netbios name = RT-AX86U-3FD8
server string = RT-AX86U
workgroup = WORKGROUP
username level = 20
unix charset = UTF8
display charset = UTF8
load printers = no
printing = bsd
printcap name = /dev/null
log file = /var/log/samba.log
log level = 0
max log size = 5
security = USER
guest ok = no
map to guest = Bad User
encrypt passwords = yes
pam password change = no
null passwords = yes
force directory mode = 0777
force create mode = 0777
max connections = 5
socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
obey pam restrictions = no
use spnego = yes
client use spnego = no
disable spoolss = yes
host msdfs = no
strict allocate = no
wide links = no
bind interfaces only = yes
interfaces = lo br0 192.168.50.1/255.255.255.0
use sendfile = yes
map archive = no
map hidden = no
map read only = no
map system = no
store dos attributes = no
dos filemode = yes
oplocks = yes
level2 oplocks = yes
kernel oplocks = no
enable core files = no
deadtime = 30
load printers = no
printable = no
max protocol = SMB2
min protocol = SMB2
smb encrypt = disabled
min receivefile size = 16384
passdb backend = smbpasswd
smb passwd file = /etc/samba/smbpasswd
[Download2 (at RT-AX86U)]
comment = RT-AX86U's Download2 in KIOXIA TransMemory
path = /tmp/mnt/RT-AX86U/Download2
dos filetimes = yes
fake directory create times = yes
valid users = admin, Lama
invalid users = Lama
read list = admin
write list = admin
[share (at RT-AX86U)]
comment = RT-AX86U's share in KIOXIA TransMemory
path = /tmp/mnt/RT-AX86U/share
dos filetimes = yes
fake directory create times = yes
valid users = admin, Lama
invalid users =
read list = admin, Lama
write list = admin, Lama
[skynet (at RT-AX86U)]
comment = RT-AX86U's skynet in KIOXIA TransMemory
path = /tmp/mnt/RT-AX86U/skynet
dos filetimes = yes
fake directory create times = yes
valid users = admin, Lama
invalid users = Lama
read list = admin
write list = admin
[nsru (at RT-AX86U)]
comment = RT-AX86U's nsru in KIOXIA TransMemory
path = /tmp/mnt/RT-AX86U/nsru
dos filetimes = yes
fake directory create times = yes
valid users = admin, Lama
invalid users = Lama
read list = admin
write list = admin
[entware (at RT-AX86U)]
comment = RT-AX86U's entware in KIOXIA TransMemory
path = /tmp/mnt/RT-AX86U/entware
dos filetimes = yes
fake directory create times = yes
valid users = admin, Lama
invalid users = Lama
read list = admin
write list = admin


This is my /etc/smb.conf file
 

Radek

New Around Here
My

[global]
netbios name = MYMR
server string = RT-AX88U
workgroup = WORKGROUP
username level = 20
unix charset = UTF8
display charset = UTF8
load printers = no
printing = bsd
printcap name = /dev/null
log file = /var/log/samba.log
log level = 0
max log size = 5
security = USER
guest ok = no
map to guest = Bad User
encrypt passwords = yes
pam password change = no
null passwords = yes
force directory mode = 0777
force create mode = 0777
max connections = 5
socket options = IPTOS_LOWDELAY TCP_NODELAY SO_KEEPALIVE
obey pam restrictions = no
use spnego = yes
client use spnego = no
disable spoolss = yes
host msdfs = no
strict allocate = no
wide links = no
bind interfaces only = yes
interfaces = lo br0 10.20.30.1/255.255.255.0
use sendfile = yes
map archive = no
map hidden = no
map read only = no
map system = no
store dos attributes = no
dos filemode = yes
oplocks = yes
level2 oplocks = yes
kernel oplocks = no
enable core files = no
deadtime = 30
load printers = no
printable = no
max protocol = SMB2
min protocol = SMB2
smb encrypt = disabled
min receivefile size = 16384
passdb backend = smbpasswd
smb passwd file = /etc/samba/smbpasswd

and one of the folders

[!!!AUDIO]
comment = data's !!!AUDIO in Seagate Expansion
path = /tmp/mnt/data/!!!AUDIO
dos filetimes = yes
fake directory create times = yes
valid users = radek, samshare, user
invalid users =
read list = radek, samshare, user
write list = radek, samshare, user

is the correct way i got connect to it \\10.20.30.1\data\!!!AUDIO ?
 

ColinTaylor

Part of the Furniture
It working, thank you. I was wondering how can i access to the higher directory level i mean \\10.20.30.1\data with users credentials. It works only on guest login enabled.
You can't (unless you create a custom config file). That's just the way the GUI is designed.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top