What's new

RT-AX88U Slow Wifi signal/speed - Activate Aimesh

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Hello everyone,
I'm hoping to get some advice on how to improve the quality and speed of my home WiFi network. I currently have two routers - an RT-AC86U and RT-AX88U both on merlin+last firmware
And I'm having trouble getting AI Mesh to work properly to combine them. When I want to add an aimesh node nothing is found.
My routers are connected via ethernet this way :
ISP modem -> RT-AX88U -> RT-AC86U

RT-AX88U covers the bottom floor .
RT-AC86U covers the top floor.

Except that the signal is sometimes weak. how to combine the two to have better reception and speed? The wifi channel is better in auto?

Thank you in advance for your help
Did you do a reset on the 86? To add a node to AiMesh, the router needs to be totally at defaults. Use paper clip to hold down reset in back about 10 seconds. After that, the 88 should be able to find it & create the AiMesh.
It is best to use Asus firmware on the AiMesh node as there is no advantage to using Merlin. After flashing Asus firmware in the AC86U bring it within three meters of the Ax88U. Make sure you do a hard factory reset on the AC86U and let it boot up with no Ethernet connection. On the AX88U add a mesh node and let the AC86U connect over WIFI. Once that is dome move it back upstairs and connect the Ethernet cable from the router LAN port to the node WAN port and power up the node. Do not have a managed switch between the two. Better off to have no switch at all. It will work. But if it doesn't be prepared to use the Asus firmware on the AX88U.
RT-AX88U covers the bottom floor .
RT-AC86U covers the top floor.

The routers have omnidirectional antennas. If both routers are placed one on top of the other you'll see no extended coverage and poor AiMesh performance. The one on top floor has to be on one side of the house, the one on ground floor on the other. This diagonal placement will provide better coverage and eventually better roaming. AiMesh has very limited control over the node and you have to play with its placement.
Place the router and the AP on different floors (diagonally as Tech9 suggests) and connect them with an ethernet cable as backhaul.

Skip AImesh and use the AC86U as an AP instead. That way you will get better control of what bands you use. Use different SSIDs for the 2.4 and 5 GHz bands.

Disable SmartConnect.
Set Protected Management Frames as enabled.
Set Roaming Assistant, Airtime Fairness and Universal Beam forming as Disabled (I found this in other threads in this forum).

I don't know if the AC86U supports 802.11k and v (this will speed up the roaming process).

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!