What's new

[RT-AX88U] Wifi is acting up on certain devices

Jellybean

New Around Here
After taking a hiatus from Asus, I'm back with Asus and Merlin!

I have the AX88U, but the wifi connection has been somewhat spotty. In the adjacent room to the router (maybe 15 feet away (2 walls in-between)), my sister's MacBook Pro (2010) is extremely slow on wifi. It takes forever to load wifi pages (ex: YouTube takes a good 6 or so seconds (and occasionally may lag intensely, I can't pull up dslreports' speed test), whereas her iPhone 11 XS will load it instantly. I would have conceded that to network card (2010 MBP being able to connected to a/b/n) but my 2019 gaming laptop has a similar, though slightly better experience.

Enabling QoS seemed to force everyone on 2.4 Ghz, so I disabled that. I had Smart Connect turned on, but have since turned that off. I'm tempted to separate the networks like I did previously and have all the important stuff on 5GHz.

Hardwired is great. I've got a gigabit subscription and I'm seeing 800+ on hardwire. I used a Wifi analyzer app to check channels and range, and changed my channels.

I don't know what stock firmware would be like, tbh. I opened the box, connected the router, set up the router, and flashed Merlin. I don't think I need to factory reset because it's a new set up, but it doesn't sound like the issue.

I have another AX88U coming in tomorrow that I plan on setting up in AI Mesh. So I'll report back if that changes anything. But any advice would be appreciated.

Wireless Gen; 5Ghz, 2.4 Ghz
CleanShot 2020-07-06 at 22.01.57.png CleanShot 2020-07-06 at 22.02.18.png

Wireless Professional; 5 Ghz, 2.4 Ghz
CleanShot 2020-07-06 at 22.02.50.png CleanShot 2020-07-06 at 22.03.13.png

Connected Devices
CleanShot 2020-07-06 at 22.05.02.png
 

FTC

Senior Member
Hi, I would begin by :
- Disable airtime fairness in both bands. This has proven to cause slowlyness with some devices.
- Disable all kinds of beanforming in 2.4 and just leave explicit beanforming in 5 ghz. Also proven some compatibility problems.
- I personally also found problems with 160mhz channel widths w/some devices so my suggestion is to set 80Mhz max to begin with.. once you stabilize the enviroment, try the 160 again..

.. and go from there.
 

coxhaus

Part of the Furniture
I can't believe you guys are spending so much money on routers that are going to be outdated in a year. You should wait for Wi-Fi 6e.
 

tekrich

Regular Contributor
When you flashed Merlin, you need to reset the settings to Factory Default settings, its a tick box nest to the restore. Then set the router up again.

Don't use 160Mhz and manually set your 2,4Ghz and 5Ghz bands.

Don't use smart connect.
 

charlie2alpha

Senior Member
I had major Wi-Fi 5GHz problems with my AC86U until I disabled Multi-User MiMo. Another thing to try.
 

L&LD

Part of the Furniture
I can't believe you guys are spending so much money on routers that are going to be outdated in a year. You should wait for Wi-Fi 6e.
Nothing gets outdated by a new model becoming available. Enjoy what you have as long as possible and upgrade if there is a good reason too at any time that a better option becomes available (rinse, repeat). :)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top