RT-AX89X Beta Firmware?

HFB Zulu

New Around Here
Is there a Beta firmware newer than the last official release (which i believe was the 25th of January) that might have fixes for TP-Link KASA devices?

I really like my router other than the fact that it appears (at least from Kasa Reddit community) to absolutely does not work correctly with KASA devices in particular and smart devices in general in some ways.

For me, KASA devices will NOT stay connected to the network reliably. Its not a specific device, and there's no rhyme or reason, but at any given time, 2-3 of my devices are not on the network and not available in KASA (and therefore, Google Home). Ive tried almost every firmware since release, and none of them seem to fix it.

In addition, after the router has been active for a few hours, it will not accept new smart devices no matter what - they simply refuse to connect (i ran into this when trying to add new Nest Home devices after upgrading the kitchen device to a Hub and the bathroom device to an Audio). If i reset the router, they will connect immediately.

In addition, on older firmware (this seems fixed on newer firmware, but that firmware is even WORSE with KASA devices - 2-3 devices will go missing immediately even after a reboot), the devices would dissappear from the Cast list in Google Home.

Theyd still be working Nest/Home devices (you could talk to them, give them commands, etc) but they would not show up on any list of Cast devices.

Im... really sorta dissappointed with this router given how much it costs and how excellent the hardware seems to be, and how good performance is with "regular" devices like phones, tablets, computers, etc.
 

Yakkosmurf

Occasional Visitor
I wonder if there's a setting in the router wireless settings that is making some of those devices unhappy? I suspect you've spent a lot of time trying to figure that out. I've had an 89X for about 6 months, and I only had one issue with a Nest camera. One of the indoor cameras would drop off line and need a router reboot to recover. But, I think it was a camera issue, as Nest replaced it under warranty, and the new one has performed flawlessly.

While, I don't have any CASA devices, I have a lost of Google Cast capable devices (Chromecast audio, Google smart TV, Soundbar, Nest Hub, Nest speaker, Lenovo smart clock), and I've never had any of them not show up on a cast list as expected. Once is a blue moon, a Chromecast audio will need to be rebooted, but it's rare, so I assume it's the device, not the router.

I have about 7 smart plugs and smart appliances, and I have those setup on a 2.4GHz guest network on the 89X. None of these every seem to have an issue.

I did setup my wireless Professional settings after doing some research on what folks recommended. Sorry, i don't have any great ideas, but my setup seems to have similarities to yours (minus KASA ones), and I've not had any of the issues.
 

HFB Zulu

New Around Here
Oh, its definitely KASA specific.

My doorbell (eufy), thermostat (ecobee), interior camera (for checking on my dog when im out - Yi), and most of my Google/Nest Home devices work fine. The newer firmwares seem to have fixed the "devices not appearing as castable" issue (though like i said those devices still function as a Home device, its just the casting thing), but it makes the KASA problem even worse.

So far the suggestions ive garnered elsewhere seem to be to use a mesh unit that doesn't have these issues and manually bind the KASA devices to that unit (though i have no idea how i'd do that. Im relatively tech savvy by higher end networking is not in my wheelhouse).
 

oldguy

Regular Contributor
I have 12 Wemo devices, Nest Camera’s, multiple Nest Thermostats, multiple nest protects.
I have two RT AX89X in an AI mesh connected through a 10Gb hardwired link
I found that I had disconnect issue’s, which seemed to be linked signal threshold for switching
I fixed these disconnects by
disabling 802.11AC beam forming​
Universal BeamForming was also enabled​
setting the roaming disconnect threshold level -70dbm​
Disable 802.11AX support (I am looking to try enabling this again with the new firmware when i get time)​

I have had 36 days of up time since a power outage, with no issues
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top