RT AX89X DFS Debug Message

oldguy

Regular Contributor
My Setup
  • 2 * RT AX89X Mesh network
  • connected with 10G wired Ethernet Back haul
  • Wireless smart connect enabled
  • Both units running 3.0.0.4.386.47191 firmware

I have been seeing some strange disconnects with Wifi devices connected to 5G band, I have seen disconnects in the system log for a couple of devices due to a weak signal, one indicating an RSSI of -58dbm.
I have been changing the 5G disconnect from the default of -70dbm through settings of -55dbm in 5dbm increments back to -70dbm, when I came across this entry in the system log below.

I have sent feedback to ASUS, and will share any feedback

In the mean time any idea what this and if this might be a cause of the disconnects I have been experiencing.

I will look to disable DFS and see if I can disable and monitor the log files

Thanks in advance for any feedback

System Log

May 20 10:53:35 kernel: [52352.805623] wlan: [0:I:dfs] WLAN_DEBUG_DFS_ALWAYS : dfs_process_cac_completion: 136: cac expired, chan 5500 cur time 52052
May 20 10:53:35 kernel: [52352.805783] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
May 20 10:53:35 kernel: [52352.805783] FD Interval should be a factor of BI.
May 20 10:53:35 kernel: [52352.805783] Disabling FD
May 20 10:53:35 kernel: [52352.815704] wlan: [0:E:FILS discovery] wlan_fd_set_valid_fd_period: 607: Invalid FD Interval : 0. Valid range is 20 - 100ms.
May 20 10:53:35 kernel: [52352.815704] FD Interval should be a factor of BI.
May 20 10:53:35 kernel: [52352.815704] Disabling FD
May 20 10:53:35 kernel: [52352.833935] wlan: [0:I:ANY] vdev[1]: Mgt Rate:6000(kbps)
May 20 10:53:35 kernel: [52352.852289] wlan: [0:I:ANY] ol_ath_vap_set_param: 1334: Now supported MCAST RATE is 6000(kbps) and rate code: 0x10000003
May 20 10:53:35 kernel: [52352.857870] wlan: [0:I:ANY] ieee80211_dfs_deliver_event: dfs CAC_COMPLETED event delivered on chan freq 5500.
May 20 10:53:35 kernel: [52352.868697] wlan: [0:I:ANY] ieee80211_dfs_deliver_event: dfs CAC_COMPLETED event delivered on chan freq 5520.
May 20 10:53:35 kernel: [52352.878503] wlan: [0:I:ANY] ieee80211_dfs_deliver_event: dfs CAC_COMPLETED event delivered on chan freq 5540.
May 20 10:53:35 kernel: [52352.888401] wlan: [0:I:ANY] ieee80211_dfs_deliver_event: dfs CAC_COMPLETED event delivered on chan freq 5560.
 

danceedance

Occasional Visitor
I have those logs which are standard DFS logs. I do not have disconnect problems with an uptime of almost a month since updating the last firmware.
Can you disable the use of smart connect and set the bands manually?
 

Tech Junky

Very Senior Member
Well when it comes to signals the lower the number = better

DFS can't be disabled but, you can pick non-DFS channels manually.

Normally your drop off point for wireless clients to change AP's / SSID's would be int he -90 territory and it works fine. Of course s stronger signal usually means you get better speeds as well.

Screenshot_20201123-203208.jpg
 

oldguy

Regular Contributor
Well when it comes to signals the lower the number = better

DFS can't be disabled but, you can pick non-DFS channels manually.

Normally your drop off point for wireless clients to change AP's / SSID's would be int he -90 territory and it works fine. Of course s stronger signal usually means you get better speeds as well.

View attachment 41340
With Smartconnect enabled all of the channels are auto selected, with no option to fix the channels
the issue may be the devices switching between the two mesh nodes as I have seen that in the logs, hence the experiment to change the RSSI levels.
I have used a similar app that you are showing on my Shield Tablet to figure out where the weak spots in my WiFi coverage are.
I did wonder if some of my issues might be heat related, so I will be tracking ambient temperatures around each mesh node
 

oldguy

Regular Contributor
I have those logs which are standard DFS logs. I do not have disconnect problems with an uptime of almost a month since updating the last firmware.
Can you disable the use of smart connect and set the bands manually?
This has just started to happen after the last firmware upgrade, I did not reset each unit to its factory default and reconfigure the units.
In the past I have seen uptimes of 40 to 50 days, at which point I see issues with my Wemo smart switches and apple home which show as not connected, there are however no issues with the tablets or phones.
I have also seen a strange issues with my Mac, which just didn’t stay connected after an software upgrade, which seems to be related to the software, as Wifi seems to be a real issue on Apple laptops
One other thing to note is that I have also disabled WiFi 6 as there some strange things happening with devices that cleared up when it was disabled.

next actions for me are to set to factory default, and rebuild the mesh system. I also plan to disable smart switch connect to see if that is causing any issues given that I do see some devices that should be on 5G connected on 2G bands as noted by @Tech Junky in his response

The other element in the mix is my ISP, Spectrum which seems to be a little flaky at the minute given we have had a number of minor outages. However this should not affect my connection to the access points just no connection to the external web sites
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top