RT-AX92U 5GHZ-2 slow (SOLVED!)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Albert Ma

New Around Here
I've got a RT-AX92U in single wireless router mode.
smart connect off. Channels manually set.

The 5GHZ-2 band is incredibly slow. I get download rates of 1-10Mb/s instead of 300Mb/s I get on the 5GHz-1 band. I'm just testing a single device right by the router. Great signal strength. Ping times are normal.

I've tried two of the routers, both exhibit the same behavior.

Does anybody have the 5GHz-2 working well, and what did you do?

 

Attachments

  • pic1.png
    pic1.png
    319.3 KB · Views: 535
  • pic2.png
    pic2.png
    347.1 KB · Views: 593

Albert Ma

New Around Here
thanks, we have no AX devices, so I have AX disabled. Plus I'm just testing 1 device at a time on the 5GHz-2 band. Could that really bring me from 1Mb/s to 300Mb/s?
 

catch36

New Around Here
thanks, we have no AX devices, so I have AX disabled. Plus I'm just testing 1 device at a time on the 5GHz-2 band. Could that really bring me from 1Mb/s to 300Mb/s?

Not sure if this will help. I replaced a AC88U with a AX88U and was experiencing similar download speed slow downs on a with a desktop with an Broadcom A/C adapter. Disabling " but enabling "WMM APSD" on the 5GHz channel fixed my download speed problems. WMM APSD was putting the adapter into power save mode. Also I have better download speeds on the lower channels in my area.
 

armelwani

New Around Here
I had the exact same problem. Found the issue was I had QoS turned off. Turned it on and all issues went away. Because I don't actually need QoS, I switched it to the option of Bandwidth Limiter and didn't put any devices into it. Everything works fine now. Attached is a screenshot of my QoS settings. Hope that helps!
 

Attachments

  • Capture.PNG
    Capture.PNG
    256.3 KB · Views: 1,108
Last edited:

Albert Ma

New Around Here
I had the exact same problem. Found the issue was I had QoS was turned off. Turned it on and all issues went away. Because I don't actually need QoS, I switched it to the option of Bandwidth Limiter and didn't put any devices into it. Everything works fine now. Attached is a screenshot of my QoS settings. Hope that helps!
Wow, that works. That's crazy. This needs to be a FAQ
 

K-2SO

Very Senior Member
Wow, that works. That's crazy. This needs to be a FAQ

This is not a solution. On many routers Bandwidth Limiter disables HW acceleration. Unrelated to WiFi performance. Not what you describe as a problem. With no HW acceleration this is not a Gigabit router anymore.
 

Albert Ma

New Around Here
This is not a solution. On many routers Bandwidth Limiter disables HW acceleration. Unrelated to WiFi performance. Not what you describe as a problem. With no HW acceleration this is not a Gigabit router anymore.

well, with bandwidth limiter I'm still able to saturate my 300Mb/s link on the 5GHz-1 channel. The 5GHz-2 channel is only getting 200Mb/s (on a two antenna device), so still some tweaking to do. A vast improvement over 300Mb/s and 1Mb/s I was getting before. CPU load is still minimal.

certainly I agree this setting shouldn't help, but it does. Hopefully ASUS will have a firmware fix at some point.
 

armelwani

New Around Here
well, with bandwidth limiter I'm still able to saturate my 300Mb/s link on the 5GHz-1 channel. The 5GHz-2 channel is only getting 200Mb/s (on a two antenna device), so still some tweaking to do. A vast improvement over 300Mb/s and 1Mb/s I was getting before. CPU load is still minimal.

certainly I agree this setting shouldn't help, but it does. Hopefully ASUS will have a firmware fix at some point.

Yup, couldn't agree more. I was dumbfounded when I came across changing that setting to fix the issue. I have a 150Mb/s Internet connection so for me I'm getting the max on all three bands once I turned on QoS and set it like I showed in my screenshot.

Until ASUS releases a firmware fix, this is the only setting I've found that gets the 5GHz-2 usable at all.
 

AndreiV

Very Senior Member
I see @AndreiV uses RT-AX92U twin pack. He may be able to share with you some tricks.

Nope , the only change I made was to turn off AX as I don't use it, that fixed the 5G2 WiFi speed being halved.

Cannot see how QOS can have any bearing on WiFi speed , especially on only one band.

I checked real download speeds against a site with test files of specific sizes and timed them against my actual ISP connection speed , WiFi and ethernet devices give the same, correct throughput rate for my connection.
 

Albert Ma

New Around Here
Nope , the only change I made was to turn off AX as I don't use it, that fixed the 5G2 WiFi speed being halved.

Cannot see how QOS can have any bearing on WiFi speed , especially on only one band.

I checked real download speeds against a site with test files of specific sizes and timed them against my actual ISP connection speed , WiFi and ethernet devices give the same, correct throughput rate for my connection.
What is your configuration? Mine is single router.
 

armelwani

New Around Here
I am a single router, too. I hear what everyone is saying about how QoS should have no bearing on this issue, but it really does, and is easily reproduceable. If I turn QoS off, my 5GHz-2 band drops to about 1Mbps for Internet traffic. Accessing my local LAN stays at full speed. All other bands work fine as well. I turn QoS on, in any mode, and like magic I get full speed access to the Internet on 5GHz-2.
 

deluxeg

Occasional Visitor
I have the same exact issue with a ZenWiFi AX but turning on QoS did not help. 5Ghz-2 is about 6 Mbps and 5Ghz-1 I can get over 500Mbps.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top