RT-AX92U Struggling with 2.4ghz IoT devices... Firmware or something else?

DrFrankenscript

Occasional Visitor
Hi folks,

I've got three RT-AX92Us as the backbone of my home network. The first one I bought has been my primary router since purchasing it (maybe a year ago?) and it seemed to work fine, working with two older routers acting in access point mode. When one of those older routers died, I got a two-pack of AX92U so all would be the same.

But lately I'm having a lot of problems with my wifi sump alarm (which operates on my 2.4 ghz only guest network). It used to connect stably, but lately it drops several times a week, or several times a day, and I get all manner of alerts about it. I also was unable to get a new weather station to connect reliably to the 2.4 Ghz guest network... I wound up replacing that with a different brand but then the NEW one was tweaky on connecting. Finally got it connected to a dedicated second guest network.

I've read the 92U got a crappy firmware update early this year and perhaps that is the root of the evil. But, my older 92U has this firmware:

Firmware Version:3.0.0.4.386_46061

The two newer ones have this one:

Firmware Version:9.0.0.4.386_41994

Oddly the older one doesn't see any new updates that it could take, nor do the newer ones. Same router model, different actual firmware, all think they have the latest. WTH?

The error I get in the log when trying to connect my IOT devices on the 2.4 ghz tends to look like this:

Aug 23 13:06:14 wlceventd: wlceventd_proc_event(527): wl0.2: Auth CC:50:E3:C2:A7:8D, status: Successful (0), rssi:0
Aug 23 13:06:14 wlceventd: wlceventd_proc_event(556): wl0.2: Assoc CC:50:E3:C2:A7:8D, status: Successful (0), rssi:-52
Aug 23 13:09:27 kernel: wl0: random key value: DD1ABBF5BD151FB419D1013856375FCC0F1EF6116A0505F4F87FD54E9CCF8147
Aug 23 13:09:27 wlceventd: wlceventd_proc_event(527): wl0.1: Auth CC:50:E3:C2:A7:8D, status: Successful (0), rssi:-52
Aug 23 13:09:27 wlceventd: wlceventd_proc_event(491): wl0.2: Deauth_ind CC:50:E3:C2:A7:8D, status: 0, reason: Unspecified reason (1), rssi:0
Aug 23 13:09:27 wlceventd: wlceventd_proc_event(556): wl0.1: Assoc CC:50:E3:C2:A7:8D, status: Successful (0), rssi:-52
Aug 23 13:09:29 kernel: wl0: random key value: 6159638B3DF1D90D43AB028D203B57EB42D284CEC166006723B1A10EBD872E8A
Aug 23 13:09:29 wlceventd: wlceventd_proc_event(508): wl0.1: Disassoc CC:50:E3:C2:A7:8D, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Aug 23 13:09:29 wlceventd: wlceventd_proc_event(508): wl0.1: Disassoc CC:50:E3:C2:A7:8D, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0

They connect, then immediately disconnect.

Any advice on getting past this ? I'm half tempted to buy a small travel router just for my sump pump (which is 2.4ghz wireless only, no wired connection).

Thanks in advance for any help.

Frankenscript
 

DrFrankenscript

Occasional Visitor
So far I've done the following troubleshooting:

Turned off Tri-band smart connect. No difference.
Went into 2.4 Ghz settings and set connect mode to N/AC. Now awaiting to see if it becomes more stable. Can always configure it to "legacy" as well for a test.

Meanwhile I reconfigured my three routers to be an AiMesh system. Got some disconnects after doing that so this one change didn't actually impact the issue.

I have to see if there is a way to change the 2.4 GHz connect mode independently for main network / guest networks.
 

sfx2000

Part of the Furniture
There was an issue with AirTime Fairness that would cause issues with some 2.4GHz devices.

Not sure if that was ever fixed, but it's worth a try to toggle that feature
 

DrFrankenscript

Occasional Visitor
There was an issue with AirTime Fairness that would cause issues with some 2.4GHz devices.

Not sure if that was ever fixed, but it's worth a try to toggle that feature
Thanks. I checked, disabled by default (since I wasn't even aware of it, until you mentioned, so I assume the disabled is a default).

I had things stable for a day, then my sump alarm dropped a few minutes ago. I went in to check something and noticed that when I changed Wireless Mode yesterday (to N/AC) I had actually changed the 5Ghz-1 band to that, not the 2.4. So, I changed that back to auto, and applied, and my sump alarm reconnected as a consequence of essentially the wifi rebooting. Then I went into 2.4 GHz settings and set it to N only (instead of Auto, the other option would be Legacy). Let's see if it is more stable now.

What I don't know, is how to change some of these settings on 2.4 PER SSID. So, currently I have three 2.4 SSIDs running: the main one that is part of the main house wifi SSID along with a 5 GHz channel, then my main guest network SSID which is 2.4GHz only, then a secondary 2.4 GHz SSID that is just for IoT things. I'd like to be able to monkey with detailed settings just on that IoT SSID guest network without screwing with the main guest network. Maybe I need to start a thread on this aspect.
 

L&LD

Part of the Furniture
Not possible. Those settings apply to each radio, not each SSID on the same radio.

If you really want that, get a 2.4GHz dedicated router. It'll be faster (to do) and more bulletproof.
 

DrFrankenscript

Occasional Visitor
Not possible. Those settings apply to each radio, not each SSID on the same radio.

If you really want that, get a 2.4GHz dedicated router. It'll be faster (to do) and more bulletproof.
Thanks! That makes sense. I have considered getting an "IOT Only" router configured just for my quirky IoT devices on just 2.4. It just irks me that my $600+ worth of high tech Asus equipment is struggling to keep my circa 2018 tech online... :)
 

L&LD

Part of the Furniture
I would see it as the quirky circa 2018 tech bringing down the current routers running current ('approved') specs. :)
 

DrFrankenscript

Occasional Visitor
Thanks. Interestingly some of the settings described don't show up for me. Here's the instruction set:

Go to [Wireless] > [General] page. Turn off [Enable Smart Connect] and select the [Band] for your network devices. [Did this some days ago]


4. Disable [802.11ax / WiFi 6 mode] [I'm assuming this is Auto/N Only, Legacy... I'm currently trying N Only and legacy will be next]


5. Disable [Wi-Fi Agile Multiband] [Don't see this]


6. Disable [Target Wake Time] [Don't see this]


7. Disable [Protected Management Frames] [Don't see this]

I've checked the General page as well as the Professional page.

1661604500097.png


1661604568798.png


Is there any other place to look for those additional settings?
 

Tech9

Part of the Furniture
Your routers are older model and may not have all the settings, but I would set 2.4GHz band this way:

Wireless Mode: Auto
Channel Bandwidth: 20MHz
Channel: Fixed (the channel used more often by the router on Auto)
Extension Channel: It will disappear when 20MHz bandwidth is selected
WPA2 Key: simpler and shorter letters/numbers only

Roaming Assistant: I see you have APs, but try with Disabled
TX Bursting: Disabled
WMM APSD: Disabled
Modulation: Up to MCS 7 802.11n
Explicit Beamforming: Disabled
Universal Beamforming: Disabled

This will prevent channel hunting and will make your 2.4GHz radio compatible to wider range of clients.

With IoT using the band I would also try changing Group Key Rotation Interval to higher value or directly 0.
 

Tech9

Part of the Furniture
There are more tricks to try in Professional settings, but in my experience home routers (including Asus) may not respond to fine tuning the same way as more expensive dedicated access points. My suggestions above are more standard without messing things up too much in Asuswrt. Your dedicated IoT AP idea is not bad, but better look at actual business class AP and not just another home router.
 

DrFrankenscript

Occasional Visitor
Your routers are older model and may not have all the settings, but I would set 2.4GHz band this way:

Wireless Mode: Auto
Channel Bandwidth: 20MHz
Channel: Fixed (the channel used more often by the router on Auto)
Extension Channel: It will disappear when 20MHz bandwidth is selected
WPA2 Key: simpler and shorter letters/numbers only

Roaming Assistant: I see you have APs, but try with Disabled
TX Bursting: Disabled
WMM APSD: Disabled
Modulation: Up to MCS 7 802.11n
Explicit Beamforming: Disabled
Universal Beamforming: Disabled

This will prevent channel hunting and will make your 2.4GHz radio compatible to wider range of clients.

With IoT using the band I would also try changing Group Key Rotation Interval to higher value or directly 0.
My sump alarm continues to go offline periodically for no understandable reason, so I made a few changes consistent with your notes and a few other threads just now.

For 2.4, I set the wireless mode to Legacy (with the b/g protection enabled... I've read some places IoT devices like this) instead of Auto
Channel bandwidth set to 20MHz instead of previous 20/40
WPA2 Key is short and letters/numbers only (always was...)
Roaming Assistant: Set to Disabled (Was enabled)
Disabled TX bursting (was enabled)
Disabled WMM APSD (Was enabled)
Disabled Universal Beamforming (was enabled)

Didn't see the Explicit Beamforming or the Modulation thing this time I went in; presumably prior changes caused those to be hidden this time around.

I will try this for a while and see. If that doesn't fix it, I need to consider is there actually a signal issue down near the sump alarm? I can try an older router I have on hand down there as an extension. However, the place in question is just 20 feet (and through a floor and some furniture) away from my router, but it is up against a cement wall.
 

DrFrankenscript

Occasional Visitor
I'm probably jinxing myself by saying anything, but after making the edits shown above three weeks ago, my connectivity has been great with no losses. In case anyone is having similar issues, try the changes as detailed above and culminating on September 4.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top