Samba Issue - AsusWRT Official and AsusWRT Merlin - RT-AX88U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

shauno100

Occasional Visitor
For the life of me i don't know what is wrong here but i cannot get samba working on my RT-AX88U with both the latest Merlin release (386.3_2) and latest official stock firmware. I have done completely factory resets (WPS method etc). My setup is as follows:

USB HDD (Toshiba 1tb disk) connected as USB3.0 and formatted with NTFS FS.

Router detects the USB HDD successfully and shows the mounts (Folders) via USB Application>Server Center>Network Place (Samba) Share / Cloud Disk with my user account having RW permissions.

When i attempt to connect to the samba share on WIndows 11 PC it will not connect and i cannot map a network drive either. I have disabled my Windows Firewall to rule that out and also have SMB1.0/CIFS enabled. Also tried Test-NetConnection -ComputerName ROUTERLANIPADDRESS -Port 445 and -Port 139 and both PowerShell commands come back as failed on that port yet i can ping the LAN IP of router successfully.

I have run SSH commands like netstat -tulpn | grep LISTEN which shows there are no 139 or 445 listening ports on router but ps w shows the Samba service as running. netstat -nlp | grep smbd shows no results.

I apologize if i don't have enough info as i'm an amateur when it comes to Linux SSH commands but i am at a loss as the AsusWRT GUI detected the disk successfully and shows my mount but it appears the samba service is not properly running as it's not listening on the 139/445 ports on router.

I should mention that NFS (Merlin) and FTP work fine with this USB HDD but the Samba server is not working whatsoever.

Any feedback as to what else i can try to definitively isolate the issue would be much appreciated.
 
Last edited:

ColinTaylor

Part of the Furniture
Post a screenshot of your Samba settings page. Also, look in the router's System Log for the messages showing the Samba server starting up.

Side note: Does Windows 11 support SMBv1 anymore?
 

shauno100

Occasional Visitor
Hi, attached are the screenshots. The last entry in syslog is that the smbd daemon is apparently started.
 

Attachments

  • Asuswrt2.jpg
    Asuswrt2.jpg
    29.2 KB · Views: 32
  • Asuswrt1.jpg
    Asuswrt1.jpg
    92.9 KB · Views: 33

ColinTaylor

Part of the Furniture
Unless something has changed the stock Asus firmware only supports SMBv1 so you'll need to enable SMBv1 client support in Windows.

Can you SSH into the router and post the output of these commands.
Code:
netstat -nlp | grep mbd
cat /var/log/samba.log
cat /var/log/log.smbd
cat /var/log/log.nmbd
 

shauno100

Occasional Visitor
Unless something has changed the stock Asus firmware only supports SMBv1 so you'll need to enable SMBv1 client support in Windows.

Can you SSH into the router and post the output of these commands.
Code:
netstat -nlp | grep mbd
cat /var/log/samba.log
cat /var/log/log.smbd
cat /var/log/log.nmbd
I do have SMBv1/CIFS client enabled on my Windows 11 desktop as mentioned. Attached is the output of first command, second command returns nothing, 3rd command also (attached) and last command also attached.

Probably completely unrelated but i did get a mild electric shock when i went to adjust the cables in the LAN ports at the back of router, got a zap. It only happened the one time. I then plugged power adaptor directly into socket to ensure it was earthed, not sure if there isn't something quite right hardware wise after this or not or just coincidence. I guess that because FTP server works this rules out a hardware issue.
 

Attachments

  • Asuswrt5.jpg
    Asuswrt5.jpg
    59.3 KB · Views: 22
  • Asuswrt4.jpg
    Asuswrt4.jpg
    67.2 KB · Views: 21
  • Asuswrt3.jpg
    Asuswrt3.jpg
    44.5 KB · Views: 20

ColinTaylor

Part of the Furniture
Thanks. So that confirms that nmbd is running OK but smbd isn't. My guess is that there's a non-alphanumeric character in the config file that Samba is choking on. Can you post the complete output of cat /etc/smb.conf, preferably as a text file rather than a screen shot.
 

shauno100

Occasional Visitor
here it is below, thanks for your assistance by the way :)

[global]
netbios name = MORRISSEYROUTER
server string = RT-AX88U
workgroup = WORKGROUP
max protocol = SMB2
passdb backend = smbpasswd
username level = 20
unix charset = UTF8
display charset = UTF8
load printers = no
printing = bsd
printcap name = /dev/null
log file = /var/log/samba.log
log level = 0
max log size = 5
security = USER
guest ok = no
map to guest = Bad User
encrypt passwords = yes
pam password change = no
null passwords = yes
force directory mode = 0777
force create mode = 0777
max connections = 5
obey pam restrictions = no
use spnego = yes
client use spnego = no
disable spoolss = yes
host msdfs = no
strict allocate = no
wide links = no
bind interfaces only = yes
interfaces = lo br0 192.168.225.1/255.255.255.0
hosts allow = 127.0.0.1 192.168.225.1/255.255.255.0
hosts deny = 0.0.0.0/0
use sendfile = yes
map archive = no
map hidden = no
map read only = no
map system = no
store dos attributes = no
dos filemode = yes
oplocks = yes
level2 oplocks = yes
kernel oplocks = no
[A]
comment = sda1's A in TOSHIBA External USB 3.0
path = /tmp/mnt/sda1/A
dos filetimes = yes
fake directory create times = yes
valid users = shaun-morrissey
invalid users =
read list = shaun-morrissey
write list = shaun-morrissey
 

ColinTaylor

Part of the Furniture
Strange. Your config file works fine on my router, once I adjust the IP addresses accordingly.

Can you confirm that your router is using a non-default subnet, i.e 192.168.225.x
 

shauno100

Occasional Visitor
The strange thing is that SMB worked fine initially and i'm pretty sure it was prior to the "electric shock" i mentioned. I highly doubt this could be related considering USB HDD is still accessible via FTP if i enable it but it's got me absolutely stumped why it's not working with Samba. When i ran the netstat commands i could not see the samba service listening on 139 or 445 either so it's like it's half running. Maybe i need to arrange for an RMA
 

ColinTaylor

Part of the Furniture
My last idea is to look for smbd errors in the syslog files:
Code:
grep smbd /tmp/syslog.log*

You could also try turning on Allow guest login and seeing if that makes any difference.

EDIT: The USB drive might be corrupted. Try removing it and setting up a different USB device.
 

shauno100

Occasional Visitor
[email protected]:/tmp/home/root# grep smbd /tmp/syslog.log*
Oct 17 23:07:40 rc_service: service 3271:notify_rc start_smbd


Not sure but as mentioned the USB HDD is accessible no issues if i use it with FTP but using it with Samba no longer works. It's like the Samba service is not running properly and isn't listening on ports 139/445 as netstat doesn't show those ports as listening.

EDIT: Don't know what i just did if it was just running "service start_smdb" but now i can see smdb daemon listening on port 139 and i can now access samba shares from Windows PC :) I wonder why the daemon is not starting properly when it's enabled in the GUI. Weird.
 
Last edited:

shauno100

Occasional Visitor
And now it's not working again after a reboot and i can't start the smdb service either. I am going to RMA the router as the electric shock i got shouldn't happen and these strange issues seem to have occurred ever since. Thanks for the help anyway.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top