What's new

Says Internet Connected but no internet, but HTTP traffic redirects to modem setup page

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
So it's not actually the modem but that best simplifies the Title as that's essentially what the scenario is.

My setup
I have an Asus RT-68U that serves my household. We connect to the landlord's very unsecured Netgear Nighthawk R6900 that also serves the landlord's mom who lives in what is essential the other half of a sort of duplex.

When the internet is down my Asus Router, with Merlin firmware, says the internet is [Connected].

I'm pretty sure the reason for this is because all HTTP traffic gets redirected to the settings page for the Nighthawk router.

I have access to the settings (not officially, but I guessed the password which is the same as the SSID password, the address of the house) & I see no way to turn off this horrible feature. I found a few guides, but they did not work on this router.

Is there a way to specify the address Merlin checks to say there is internet? Or a setting to have it check HTTPS not HTTP? I have tried pinging https addresses from CLI but they don't seem to work, I've tried setting it to `DNS Query` in `[Administration]`. > `[System]` but that didn't seem to work, though I was using only the default settings.

I'm fairly certain this is the problem, as a ping from any http would be returned by the Nighthawk. I've tested this when there was no internet & even random keyboard jarble like ghjfhegdsebnku.bng return replies from

Edit: shortly after posting this, & about an hour after changing `Network Monitoring` to `DNS Query` that seems to have resolved the issue. I would still appreciate any suggestions, but what I thought didn't work seems to have just taken time to work
Last edited:
Yes, you either have patience, or, you reboot your entire network, if you're in a hurry (and doing so is easier/faster than waiting in 'test' mode).
Yes, you either have patience, or, you reboot your entire network, if you're in a hurry (and doing so is easier/faster than waiting in 'test' mode).
It didn't seem like it was something that should have required a wait, as if the internet is unplug it shows it practically instantly, I assumed changing how it detects that should be updated within a couple minutes not an hour. Whatever the case it worked, & I'll leave it here for anyone else who might be looking for the same in the future since I wasn't able to find anything to help me when I was looking.

Now I really want to figure out how to stop the Nighthawk from redirecting at all, but unfortunately that doesn't seem to be possible as it stands. & at least it just go to that page, not redirects to it (the URL will stay as `http://neverssl.com` not change to ``) so open tabs don't get lost & work properly when the internet is back, unlike what happens when you connect to a lot of networks like McDonalds, Most Libraries, & the like. That's been a problem more than once, connecting a laptop that has open tabs to aa public WiFi & it has a TOS, Click to Continue page so any http tabs all get redirected to that & hitting [Back] goes to the page you were on before you went to that one, not that page. I'm sure that would likely happen if I was using the Nighthawks DNS, but at least in this case that isn't an issue.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!