Skynet Skynet + webUI not accessible, Skynet settings lost after reboot

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


Occasional Visitor

yesterday I’ve encountered strange router behaviour, which was hard to point out (nothing obvious in the log), but probably involved Skynet @Adamm .

I’m using RT-AC88U with Merlin’s 384.18 firmware. I have an USB 2.0 8GB thumb drive plugged in, formatted with ext4 with Journalling / 2GB swap file and used for nothing else but few amtm installed and regularly updated / Entware addons (Skynet, connmon, spdMerlin). Skynet is latest v7.2.3.

- I tried to access webUI which displayed nothing but blank grey page (so it did connect, just didn’t load any pages)
- I tried SSH access which worked, but when I tried to load Skynet’s settings via firewall command, only the top graphics logo part loaded, but nothing else below and it got stuck, I couldn’t exit the script in any other way than closing the SSH connection.
- Both problems were happening on repeated attempts
- top didn’t display any obvious problems, leaks or high CPU usage
- I’ve tried to restart httpd which didn’t help the above
- Eventually I’ve decided to reboot the router. I couldn’t do it by software, so I’ve switched it OFF/minute/ON.

- After successful restart, the Skynet didn’t load any settings which I’ve only noticed later (stupid me) from the hourly statistics - they were showing 0 IPs - 0 Ranges Banned - 0 Inbound - 0 Outbound
- Option Update Skynet didn’t help, It only again started working as before after I’ve selected options Malware Blacklist / Update and it loaded up the lists and stored them on the USB. This kept working correctly after subsequent software reboots.
- While it didn’t load the Malware blacklist settings, it still loaded my other settings from skynet.cfg, like my list of banned countries.

Is it normal behaviour and I should carefully check after each reboot Skynet works correctly, or was it some strange one-off, or was it caused by hard reset?
Last edited:


Very Senior Member
Your USB drive is shot.


Occasional Visitor
Your USB drive is shot.

Seems to be the case. Disk check doesn’t return any errors, but it is an old random USB drive, that’s true.


Very Senior Member
Could be the latest update to Skynet with more mounting points for addons in gui, changed in 386.1 firmware so it could be a issue on older firmwares.
Not sure..


Senior Member
Try to uninstall / reinstall. If you still have problems, try a new USB drive. Get one much bigger than necessary. You can format it with less than the maximum space; modern drives will reallocate bad sectors to unallocated space. I think I left something like 50MB free on my current one. Might have been more than that.


Part of the Furniture
For the "hanging menu", invoke it with sh -x /jffs/scripts/firewall and see what the last few lines of output are on the screen (it will be a verbose dump of output, only the end really matters).


Occasional Visitor
Thanks for the tips everyone. I’ll try sh -x /jffs/scripts/firewall if I encounter the same issue again. So far it’s working well after few soft reboots and one hard one. I’ll still use good new USB drive for now and see if it improves things.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!