Slow Upload RT-AC86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

JeezusJuice

New Around Here
I'm having issues with all uploads using an RT-AC86U (R1) that I bought less than a month ago. I've read dozens of threads from people having this problem, and none of them have a resolution (including almost every suggested thread from my title, many of which aren't similar enough).

Operation Mode: Wireless router
Firmware Version: 3.0.0.4.386_40451-g30f1b6c
QoS: All off
AiProtection: All off
USB Application: All off (currently)
AiCloud2.0: Off
Smart Connect: Off
Wireless Mode: N/AC Mixed
Channel bandwidth:
- 5GHz: 20/40/80 MHz (currently)​
- 2.4GHz: 20/40 MHz (currently)​
Control Channel: Auto
Extension Channel: Auto
Protected Mgmt Frames: Disabled
WPS: Off
Jumbo Frames: Enabled
Firewall: On (currently)
DoS Protection: Off
USB Mode: 3.0 (currently)

In "Professional Settings," the only thing I did was turn off WMM APSD (I'm not sure that matters with QoS turned off, but I did it anyway).

Anything noted as "currently" above has been changed to every setting I could select for those options. None of them have any impact.

I've tested with three PCs (two Windows, one Fedora32), all of them exhibit the same problems.
  • I have Win1 connected via WiFi using an ASUS USB-AC68 adapter
    • I found an issue with the mount cable for the adapter. I was suddenly and inexplicably getting only 6Mbps down today, so I connected a USB 3.0 extension cable and that resolved the problem immediately. The new cable is much longer, so I also moved the adapter to a better position, and I'm now getting 400Mbps+ down.
  • I have Win2 connected with a 10GbE cable (Win1's NIC runs at 1000Mbps, and, of course, R1's ports are all 1Gbps).
  • I have F32 connected via WiFi using the onboard Intel 8265/8275 (Idk which one it is, `lshw` and `lspci` show both)
For both machines connected via WiFi, R1's UI consistently shows Tx values of 975Mbps+. Rx values are usually around 6Mbps, but I'm not moving much data, and it spikes up appropriately to 300-500Mbps when I'm trying to move data.

I first noticed the problem when trying to stream a movie that's about 16GB in size on Win2 from a file that lives on Win1. I think it's worth noting that prior to Comcast swapping my gateway, I could stream the exact same movie without issue. Comcast swapped my gateway for a newer device, and it wouldn't hand out DHCP leases.

Brief tangent: It was actually much stranger than that. It would accept a connection such that my computers would show they were connected to the network, but I could not connect to the Internet with any of them. I also wasn't getting an IP address assigned, and manually assigning an address didn't work. I wound up watching packets and seeing that the GW never sent a DHCP Offer after my computers sent a DHCP Request, nor did it respond to ARP requests. My friend had a similar issue that somehow resolved when she turned off MoCA, so I tried that, but the GW wouldn't allow me to turn it off (a Comcast "tech" tried to turn it off, and also could not: the switch would move, but it turned itself back on after applying the settings). After months of trying to get their crap to work (lots of phone calls, and no calls back from their "escalation" team), I finally got fed up and bought my own router, and put their stupid GW into bridge mode to make WiFi work again. That brings me to this new and almost equally irritating problem.

This 16GB movie was buffering too much to watch, so I tried to copy the file from Win1 to Win2. The transfer to Win2 would frequently drop to 0, and averaged around 400KB/s when it was working (it spiked as high as about 3Mbps at the start of the transfer).

I then connected a SanDisk Extreme USB 3.0 drive to R1's USB 3.0 port (running in USB 3.0 mode), and configured a Samba share. I tried uploading from Win1 to SMB, and I averaged 400KB/s upload speeds. The same held true for Win2 and F32. I tried to use the UPnP media share to rule out Samba weirdness, but I couldn't figure out how to upload anything to the drive using that (I could access the folder from Win1, but I could not paste the file to transfer it). I tried using FTP, and had the same problem: I could access the path, but couldn't paste anything in there (rwX perms for the user: I tried a standard user, and the super user account). WinSCP could not detect an SFTP server running. I turned on SSH and confirmed that vsftpd was running on the system. There's a pretty common issue with Linux machines displaying a banner as part of the SSH connection, and that breaks SFTP because it can't process anything during the connection. You can either remove the banner, or change the sftp server to sftp-internal, and that problem goes away. ASUS is using some proprietary OS over a Linux kernel, so I have no clue where to find the SSH config file, so this was as far as I could go.

I used WifiInfoView (I won't sign up for an account to use InSSIDer), and I see that I'm connecting at 1733 Mbps, 70MHz, 100 signal, and <10% channel utilization (it went into the low 20s for a while, which I don't think should cause any issues, and if it were to cause issues, I would expect symmetrical impact).

I checked up/down speeds on speedtest.net, and I'm getting 250-475Mbps down/6Mbps up from all systems. I ran a speed check from R1's UI, and I'm getting 750Mbps down/6.46 Mbps up. Since speedtests can be questionable, I also tried uploading a 70MB file to Google Drive, and I gave up about 5 minutes into it (it said I had 24 minutes remaining!). I have little reason to believe that my WAN upload speeds have anything to do with my Comcast connection since my LAN upload speeds are equally terrible. I figure my next step is to change firmware on the device, and I figured I'd move to Merlin WRT, but I've also seen a ton of posts detailing the same problem with multiple versions of the Merlin FW.

Does anyone have any suggestions before I take that step? I don't think there's room for the problem to be with anything except the router at this point, and I'm at a complete F'in loss on how to fix this.

EDIT: Added a couple of minor details about Tx/Rx values, and an attempted upload of a relatively small file to google drive.
 

L&LD

Part of the Furniture
You have changed many defaults that shouldn't have been changed in my experience. In addition to trying to use the router as a NAS.

Make a backup config file, and a backup of the JFFS partition too (both, from the GUI), and download the exact firmware you are currently running, and make sure to verify the download after extracting the files. Put all these files in a safe place.

I would then do a full reset to factory defaults and change the suggested settings as indicated below (use the appropriate settings for your model, as needed).

New M&M 2020

If the issues persist, try the following before repeating the above (or, do it now and once).

Fully Reset Router and Network

The following links may also give useful information for you in solving this issue.

L&LD | SmallNetBuilder Forums

 

JeezusJuice

New Around Here
Oh, whoops. I guess I forgot to say that I factory reset it after all my troubleshooting steps.

I made these changes after the factory reset:

Smart Connect: Off
I was having frequent disconnections when it was turned on during the first week of using the router, and turning it off resolved that, so I've left it off.

Wireless Mode: N/AC Mixed/N-Only for 5/2.4GHz bands respectively.
I don't have any devices so old that they're using 802.11g, so that change should have no impact. If that is affecting my connection on 802.11AC, that's a bug ASUS needs to address, but I don't think that's an issue since I've had the problem on Auto, as well.

Jumbo Frames: Enabled
If anything, I'd expect this to relieve potential queuing issues from too much fragmentation (or drops from exceeding mss).

WMM APSD (Professional Settings): Disabled
I don't think this did anything since QoS policies are all disabled, but I set it back to Enabled anyway because I noted no difference in speeds with it disabled.

I can factory reset it again, but I honestly don't see why that would help. If ASUS's OS is so bad that it can't handle multiple config file rewrites, that's a major problem, and it makes me want to return the device (but I doubt other vendors are any better for this level of gear, and I don't have the money to setup enterprise gear in my house). To be honest, it's concerning to me that you're recommending so many reboots. What the hell is wrong with these things that they can't accept connections without first being rebooted three times after a factory reset? It's ridiculous. I mean, I'd be out of a job if any of the services for which I'm accountable worked that way.

I also included only a subset of the steps I took. I looked through the third link, and I had done your standard steps before doing all that testing to see where the problem was. It seems to me that the steps I included pretty conclusively point the blame at the router, but there's no reason that it's throttling upload speeds. I'll go through your steps for flashing with new firmware and see how that works out for me.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top