1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Small issue with Voxel VPN + Kamoj Addon

Discussion in 'NETGEAR AC Wireless' started by Chris Purves, Aug 17, 2019.

  1. Chris Purves

    Chris Purves New Around Here

    Joined:
    Aug 17, 2019
    Messages:
    1
    Hi All,

    Just a quick one. I have successfully installed the Voxel firmware for my R9000 using expressVPN.
    Everything actually seems to be working VPN wise but I am getting an error on the router debug page.

    As far as I can tell I have done the absolute basic setup correctly.

    Anyone got anyideas what could be causing it?

    [​IMG]
    [​IMG]

    Chris
     
    Last edited: Aug 17, 2019
    kamoj likes this.
  2. kamoj

    kamoj Senior Member

    Joined:
    May 12, 2017
    Messages:
    371
    All is fine.

    The error indication is wrong.
    It is the effect of Voxel changing the vpn device name from tun0 to tun21.
    The add-on is not yet updated to reflect that.

    To patch this you can run this from the command prompt:
    Code:
    sed -i 's/tun0/tun21/g' /usr/bin/addon_info_update.sh
    Thank you for the debug print out and good error description.
     
    Last edited: Sep 2, 2019