Smart Connect - curious

deeker1

New Around Here
I have implemented Smart Connect on my RT-AX88U running Merlin 386.2_2

After a bit of minor tweaking to thresholds, it seems to work well. After a reboot devices eventually steer to the band I expect them to steer to based on capability and signal strength.

2 devices, both computers, appear to stay on 2.4 Ghz and not always steer to 5Gz

One is an older network card but with 802.11ac support. I wait hours for it to steer to 5Gz and then I disconnect and reconnect the wireless connection and it jumps right way to 5Gz.

The other is a new laptop with ax support. the signal strength and throughput numbers are very good but it will often not steer to 5GZ - I have circled this below.

Is this one of the quirky things with Smart Connect or have I configured something incorrectly?

1618497232995.png

1618497570803.png


1618497320914.png
 

bbunge

Part of the Furniture
You will get a lot of recommendations to not use Dual Band SmartConnect. But not from me! I have used this for over a year first on an AC86U and now on the AX86U with no apparent issues. I leave the SamartConnect settings at default and disable Roaming Assistant for both bands.
You did not show your WIFI settings but may I recommend for 2.4 GHz use 20 MHz on channel 1, 6 or 11. 5 GHz at 160 MHz on channel 36. Use WPA2/WPA3. With the 5 GHz set to channel 36 you will be able to use eight 20 MHz channels and devices that do not like DFS channels will still connect.
There are lots of reasons why clients will choose one band over another. One way to steer a client to the band you want is to use Wireless MAC Filter and reject the client from the band you do not want it to connect to. This, however, may cause unwanted disconnects. In time my clients do migrate to the better connection band.

For your AX laptop, if it has an Intel AX card check with Intel for a driver update.
 

deeker1

New Around Here
You will get a lot of recommendations to not use Dual Band SmartConnect. But not from me! I have used this for over a year first on an AC86U and now on the AX86U with no apparent issues. I leave the SamartConnect settings at default and disable Roaming Assistant for both bands.
You did not show your WIFI settings but may I recommend for 2.4 GHz use 20 MHz on channel 1, 6 or 11. 5 GHz at 160 MHz on channel 36. Use WPA2/WPA3. With the 5 GHz set to channel 36 you will be able to use eight 20 MHz channels and devices that do not like DFS channels will still connect.
There are lots of reasons why clients will choose one band over another. One way to steer a client to the band you want is to use Wireless MAC Filter and reject the client from the band you do not want it to connect to. This, however, may cause unwanted disconnects. In time my clients do migrate to the better connection band.

For your AX laptop, if it has an Intel AX card check with Intel for a driver update.
Thanks for the tips.
I disabled RA on both Bands.

I tried 160Mhz on the 5 GHz band (with channel 36)- NOTHING will connect on 5.0 and everything goes to 2.4


I will continue to experiment. For the most part Smart Connect does behave well for me.
 

Tech9

Part of the Furniture
I will continue to experiment.

Ask yourself a question - Is the router smarter than me? Yes - use SmartConnect, you'll get connected. No - take control over your network, go for best performance. Most folks on this forum don't use SmartConnect because they want performance. I don't like when someone provides partial information only. What @bbunge forgot to tell you is his ISP is up to 100Mpbs. He has to check where the devices connect because a common 2x2 client on 2.4GHz may reach the max ISP speed. In his case it doesn't matter when the clients switch or if they switch at all.
 

CaptnDanLKW

Senior Member
I am a SmartConnect believer, with the understanding that SmartConnect cannot fix stupid. Stupid clients, that is. All WIFI connections are initiated by the client, so if SC does it's magic and moved the client over to a different frequency, that client can be stubborn and move itself back. There's a lot of voodoo and assumptions on what's happening under the sheets but for the most part it just works. Many IoT devices excluded because of their crappy network stacks.

With the 386.x code and AI Mesh 2.0, I've come to the conclusion that Roaming Assist is unnecessary and really a bad fallback choice to the SC and AI Mesh features already in control. The main feature of SC and (if you use it, AI Mesh) is that they don't force a full client re-association at Layer 2. If a Layer 2 connection has to be re-established, then a layer 3 renegotiation would happen (dhcp release and renew) and we all know what happens when the network layer drops, even momentarily.
That's what the Roaming Assist setting does - like a bouncer, kicks the station off the network, no negotiation, no appeal. Sure, the station booted off *MIGHT* pick a better signal or node the next time but at the cost of tearing down and reestablishing the network connection, breaking most apps. Or it could be stubborn and go right back to the band and node it was booted from.

Pay attention to that 'Connected' time. You will start to see a pattern on which are your stupid clients. As a best practice, if you do have a misbehaving client, try to 'forget' the SSID from that device and reconnect with you WPA2 passphrase. There's anecdotal evidence that some OSes cache low level info about the AP and could be part of the stubbornness issues. @deeker1 For that new laptop, did you already have it joined before you enabled SC? Assuming its windows, make sure you
a) forget the network
b) check you 'known networks' list and delete anything with the same name or previous SSID names
c) check device Manager's Advanced settings and see if you can set a preferred band.

YMMV, Good luck.
 

Deldarius

Occasional Visitor
Flip the RSSI values for the STA Selection Policy (both the greater/less and the dBm values).

When the trigger conditions are met your current values are telling the devices to move to/stay on the 2.4ghz and not to "upgrade" to the 5ghz..

I wouldn't bother with playing with the PHY rates unless they are your criteria for frequency change. As far as the bandwidth utilization goes, I wouldn't bother either. You are choking out the 2.4ghz.

Here are my settings for reference.
Smart Connect settings.png
 

Brad331

New Around Here
Flip the RSSI values for the STA Selection Policy (both the greater/less and the dBm values).

When the trigger conditions are met your current values are telling the devices to move to/stay on the 2.4ghz and not to "upgrade" to the 5ghz..

I wouldn't bother with playing with the PHY rates unless they are your criteria for frequency change. As far as the bandwidth utilization goes, I wouldn't bother either. You are choking out the 2.4ghz.

Here are my settings for reference.
View attachment 39758
@Deldarius , what makes you believe the RSSI values should be switched between Steering Trigger Condition and STA Selection Policy? SNB's guide and Asus's documentation both seem to suggest they should be congruent instead.
 

JohnD5000

Senior Member
I am a SmartConnect believer, with the understanding that SmartConnect cannot fix stupid. Stupid clients, that is. All WIFI connections are initiated by the client, so if SC does it's magic and moved the client over to a different frequency, that client can be stubborn and move itself back. There's a lot of voodoo and assumptions on what's happening under the sheets but for the most part it just works. Many IoT devices excluded because of their crappy network stacks.

With the 386.x code and AI Mesh 2.0, I've come to the conclusion that Roaming Assist is unnecessary and really a bad fallback choice to the SC and AI Mesh features already in control. The main feature of SC and (if you use it, AI Mesh) is that they don't force a full client re-association at Layer 2. If a Layer 2 connection has to be re-established, then a layer 3 renegotiation would happen (dhcp release and renew) and we all know what happens when the network layer drops, even momentarily.
That's what the Roaming Assist setting does - like a bouncer, kicks the station off the network, no negotiation, no appeal. Sure, the station booted off *MIGHT* pick a better signal or node the next time but at the cost of tearing down and reestablishing the network connection, breaking most apps. Or it could be stubborn and go right back to the band and node it was booted from.

Pay attention to that 'Connected' time. You will start to see a pattern on which are your stupid clients. As a best practice, if you do have a misbehaving client, try to 'forget' the SSID from that device and reconnect with you WPA2 passphrase. There's anecdotal evidence that some OSes cache low level info about the AP and could be part of the stubbornness issues. @deeker1 For that new laptop, did you already have it joined before you enabled SC? Assuming its windows, make sure you
a) forget the network
b) check you 'known networks' list and delete anything with the same name or previous SSID names
c) check device Manager's Advanced settings and see if you can set a preferred band.

YMMV, Good luck.
So, where exactly is Roaming Assist and how do you shut it off? I've searched and cannot find it.
 

Morris

Very Senior Member
If you have a 5-Ghz capable client that tends to connect to 2.4-Ghz, go into Wireless and click the "Wireless MAC Filter" Tab. Set band to 2.4 GHz. Enable MAC Filter. Mac Filter Mode "Reject". Add the client(s) to the list. Fixed!

Have fun
 
Last edited:

Deldarius

Occasional Visitor
@Deldarius , what makes you believe the RSSI values should be switched between Steering Trigger Condition and STA Selection Policy? SNB's guide and Asus's documentation both seem to suggest they should be congruent instead.


Well Brad331,

I live in an 800sq ft apt, in a four tenant building, in a high population density neighborhood. The building is around 100 years old and has been rebuilt more than a few times.

This makes the wifi "acoustics" quite interesting, to say the least. My 5ghz strength goes to pot just inside my front door, but crazily enough, the 2.4 is much less congested outside the building, despite the insane number of other networks all around me.

I have 2 pc's, 3 printers, 3 laptops, 2 tablets, a pair of phones and a fire stick fueled by an RT-AC86U. Thankfully the pc's, printers and firestick are hardlined and the laptops when possible. The wireless gear is native AC or I have adapters for them.

With all the wifi noise, the devices upon going active would not switch over from the 2.4ghz to the 5ghz. The wireless devices needed to be told what frequency they should be on.

I had tried SNB's and Asus's docs with no success.

So I tried flipping the RSSI values and viola, it worked. Flipping the values dictated the action. The only other adjustments were needed for the bounce detection.

Now when a device goes live for the first time or moves afar, the triggers are invoked and depending on the signal strength, the device is pushed to the appropriate frequency. If the signal degrades (or improves enough) it will be pushed to the other band.

Currently I am Inside the apartment on the 5ghz, but if I walk out my front door, it will switch over to the 2.4ghz. Now the wife can be in the car, at the curb 10-20 feet away waiting for me and get a reasonable signal on the 2.4ghz. When we get back into the apartment, BINGO...5ghz baby!

Everyone's setup is different, unique even. But smartphones are anything but. Many times they act like petulant children and must be told what to do. I just figured out *my* secret sauce for getting my digital monkeys to perform in my hovel of a circus.

If it can work for others, then I have made the world a slightly happier place.
 

drinkingbird

Regular Contributor
If you have a 5-Ghz capable client that tends to connect to 2.4-Ghz, go into and click the "Wireless MAC Filter" Tab. Set band to 2.4 GHz. Enable MAC Filter. Mac Filter Mode "Reject". Add the client(s) to the list. Fixed!

Have fun

Except that client will still see the 2.4ghz and try to connect to it from time to time, have to time out, then connect back to 5Ghz, rinse, repeat. So you end up with flapping.
 

Morris

Very Senior Member
Except that client will still see the 2.4ghz and try to connect to it from time to time, have to time out, then connect back to 5Ghz, rinse, repeat. So you end up with flapping.

None of my clients flap. It works great for Windows and Android clients. I've been using this method for years and have never seen a drop. If a client has a solid connection there is no reason for it to try and roam
 

drinkingbird

Regular Contributor
None of my clients flap. It works great for Windows and Android clients. I've been using this method for years and have never seen a drop. If a client has a solid connection there is no reason for it to try and roam

It will work fine if a client seems to want to connect to 2.4 at first but then is happy to stay on 5 once pushed over there. When the client seems to want to keep going back to 2.4 as is the case with some, that's when you can run into issues. Like all the other features being discussed here, it is a tool that can help in some scenarios and hurt in others.
 

Morris

Very Senior Member
It will work fine if a client seems to want to connect to 2.4 at first but then is happy to stay on 5 once pushed over there. When the client seems to want to keep going back to 2.4 as is the case with some, that's when you can run into issues. Like all the other features being discussed here, it is a tool that can help in some scenarios and hurt in others.

I can see that as all of these solutions are kluges. It is the client's responsibility to chose the AP to connect to. The only guaranteed method is via unique SSIDs that don't give the client a choice.
 

Raphie

Senior Member
I’ve tried smartconnect so many times, as 1 ssid, tri-band bandwith all sound great.
but 5g devices end up on the 2.4g band, from the 2 5gh channels, clients always end up on the wonky channel. Devices lose connections Etc. IN THEORY it’s a smart ruling matrix, In practise default settings do not work and tweaking solving one problem then creates another. So here it stats off, 2 discrete bands with 2 ssids and none of these issues.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top