SMB/NFS freezing on Asus-Shield configuration

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

kofii12345

Occasional Visitor
There is some strange bug on ASUS routers that makes playing movies on Shield Pro 2019 by SMB over wifi freezing (HDD connected to router). I have noticed that on there is similar problem with NFS (movies dont even start when Shield is connected over wifi). I have tested recent Merlin firmware. More info here: http://www.snbforums.com/threads/ac-86u-and-shield-tv-pro-wifi-drops.73171/post-706148
Some people from Kodi forum says that it could be some new smb protocol problem and that it doesn't occur on other router brands.
Are there any chances to Merlin check the problem? I could deliver some logs.
 

ColinTaylor

Part of the Furniture
Some people from Kodi forum says that it could be some new smb protocol problem and that it doesn't occur on other router brands.
Are there any chances to Merlin check the problem? I could deliver some logs.
You'll have to provide specific information about what this alleged problem is before it can be investigated.

Most routers (including Asus IIRC) only provide SMBv1 support. Merlin's firmware adds options for SMBv2 and SMBv1+SMBv2. So there's more things for you to try. Additionally, using Merlin's custom scripts and configs any of the Samba settings can be changed if required.

EDIT: Just seen the response on the NVIDIA forum where they said "It looks like your issue is not related to smb despite the title as it also occurs with nfs and ftp". So not a Samba issue then.
 

kofii12345

Occasional Visitor
I use RT-AC86U and tried every configurations on router(SMBv1/SMBv2 and others). It is hard to say if that problem should be fixed by Nvidia Shield team or in Asus software but it is strange behaviour that it occurs on some specific devices.
This is problematic for me because I have gifted 2 Shields PRO as SMB players on my family which uses RT-AC86U and there is a problem on both. I use Shield 2017 and there is no problem.
 

ColinTaylor

Part of the Furniture
What error messages are being produced on the Shields?

Does the same problem occur if the Shield Pro's are connected by Ethernet instead of WiFi?
 

kofii12345

Occasional Visitor
Nothing specific in logs in kodi (" ERROR: Read - Error( -1, 103, Software caused connection abort )"). Just "cant played" style in GUI. There are no specific log in asus neither (I used log menu on router page only). It work like a charm using ethernet. Tried 2,4 and 5ghz.
 

john9527

Part of the Furniture
@kofii12345
If you have Protected Management Frames enabled/capable in the router wireless settings, try setting it to disabled.
 
Last edited:

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top