SSH and WebGui connections temporarily rejected (wrong key / wrong password) then accepted again

joomlafab

Occasional Visitor
Hi, I've got an Asus AX3000 (same firmware as AX58U), running the latest 386.3 Merlin.
I updated it to Merlin 386.3 from previous 386.2.6 about 2 weeks ago and it was running smooth so far.
But today, when I tried to ssh into it, my ssh key was refused. I tried to log into the webUI, and my password was also rejected.
I waited a minute wondering what was wrong, then I tried again, and I could log in, both into ssh with the same key and into the webUI with the same password (it's stored on my browser so I didn't type it, no typo error).

I've never had this problem before. Is it a bug, or could it be a sign of an intrusion or compromised router/network ?

Here are the relevant logs for SSH in syslog. I can't see anything else connected to that problem. I don't know where are the logs for the WebUI connection attempts, or even if there are some...

Aug 9 08:54:52 dropbear[11630]: Pubkey auth bad signature for '[USER]' with key sha1!! [KEY] from 192.168.0.24:54548
Aug 9 08:56:37 dropbear[11883]: Pubkey auth succeeded for '[USER]' with key sha1!! [SAME KEY AS ABOVE] from 192.168.0.24:60488
Aug 9 08:56:37 PTCSRV: [SSH] login succeeded from 192.168.0.24 after 1 attempts
 

eibgrad

Part of the Furniture
FWIW, I've seen this happen on a rare occasion on numerous router firmware, NOT just Merlin. But I don't know why. I suspect the problem is w/ the client (e.g., openssh, putty), NOT the server.
 

joomlafab

Occasional Visitor
Thanks for your feedback ! I was using putty, but isn't it weird that the authentication problem occured both for ssh and webUI connection ? I don't use an SSH key to connect to the WebUI, so it has nothing to do with my ssh client. The webUI said my password was wrong, and one minute later, it accepted the same password...
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top