1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

SSH out through router not working

Discussion in 'Asuswrt-Merlin' started by walttheboss, Nov 21, 2019.

Tags:
  1. walttheboss

    walttheboss Occasional Visitor

    Joined:
    Feb 9, 2017
    Messages:
    10
    I have an AC68U with 384.13. Love it.

    BUT I can no longer SSH out through the router. From my server I want to SSH into another server across the world. No go. IS there a setting I may have messed up.

    I have port forwarding setup and can ssh into my server from across the world fine.

    SUMMARY: SSH cannot pass from LAN to World. SSH is passing fine from World to LAN.
     
  2. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,875
    Do you have any scripts enabled? Have you rebooted the router to 'refresh' it and waited about 10 minutes or so?

    Do you have a USB drive connected with Entware and a swap file configured on an Ext4 file system with journaling enabled?

    What settings and features past default have you changed or enabled?
     
    walttheboss likes this.
  3. dosborne

    dosborne Senior Member

    Joined:
    May 11, 2019
    Messages:
    317
    Location:
    /dev/null
    Should be pretty straight forward for outbound connections.

    First place I'd look would be your port forwarding to ensure you aren't trapping both onbound and outbound.

    Disable the port forwarding temporarily and see if you can connect to the remote server.
     
    walttheboss likes this.
  4. walttheboss

    walttheboss Occasional Visitor

    Joined:
    Feb 9, 2017
    Messages:
    10
    THANKS for the help.

    Nothing changed besides port forwarding. No scripts. Have rebooted but not for that long. Will try. No USB. No Swap

    Network Details: We have modem/router supplied by ISP(some Huawei something) that forwards to my Asus router. The Asus forwards to the server. So the SSH out has to pass through two routers. BUT it always worked till two days ago.
     
  5. walttheboss

    walttheboss Occasional Visitor

    Joined:
    Feb 9, 2017
    Messages:
    10
    Thanks for the help.

    I turned off Port Forwarding. then Rebooted. Same result.

    ssh -v [email protected]
    OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n 7 Dec 2017
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: Applying options for *
    debug1: Connecting to msgvte.msgeducation.com [183.182.101.108] port 22.
    debug1: connect to address 183.182.101.108 port 22: Connection timed out
    ssh: connect to host msgvte.msgeducation.com port 22: Connection timed out
     
  6. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,875
    Long shot; unplug all network equipment (power and Ethernet cables). Wait at least 10 minutes (an hour is better).

    Power on the modem and wait for it to settle make sure to connect the power and the input cable.

    Connect the Ethernet cable from the modem to the router and then power on the router.

    Wait at least 10 minutes for the router to settle before you connect any other Ethernet cables.

    Power on and connect all remaining Wired devices.

    Test to see if fully resetting the ISP connection doing the above fixes (or changes) the issue.
     
    walttheboss likes this.
  7. walttheboss

    walttheboss Occasional Visitor

    Joined:
    Feb 9, 2017
    Messages:
    10
    Thanks for all the help. It was the ISP. After a few calls they understood the issue and reset something. All working fine.

    Sorry for the wasted time but I appreciated what I learned in the process.