Starting OpenVPN Client generates no buffer space available in syslog

silentthinkr

New Around Here
Having an issue with my VPN on the router. If I leave the VPN off, wireless and wired clients work just fine. Syslog seems to generate normal logging. Upon enabling my OpenVPN client manually configured for ExpressVPN, syslog will start scrolling errors like noted below. I will then begin to have issues with wired and wireless clients losing access to the internet. I also notice that wireless clients can no longer establish a wireless connection upon returning to the network ie. my iphone when I return home.

Running 386.7_2 on a RT-AC5300. Only way to correct the issue is a reboot of the router leaving the VPN off.

Appreciate any help - thanks!

Sep 8 08:37:10 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:11 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:11 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:11 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:12 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.253:48175): sendto: No buffer space available
Sep 8 08:37:12 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:13 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:18 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:19 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:23 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:24 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:24 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:25 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:27 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:28 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.245:47689): sendto: No buffer space available
Sep 8 08:37:28 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:28 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:29 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.202:43984): sendto: No buffer space available
Sep 8 08:37:29 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:33 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:34 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.253:48175): sendto: No buffer space available
Sep 8 08:37:34 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:37 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.245:47689): sendto: No buffer space available
Sep 8 08:37:37 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:37 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:37 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:37 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:38 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:39 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.202:43984): sendto: No buffer space available
Sep 8 08:37:39 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:40 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:43 miniupnpd[26047]: try_sendto(sock=5, len=441, dest=192.168.1.253:48175): sendto: No buffer space available
Sep 8 08:37:43 miniupnpd[26047]: try_sendto failed to send 1 packets
Sep 8 08:37:45 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:46 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:50 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:51 dnsmasq[26241]: failed to send packet: No buffer space available
Sep 8 08:37:51 dnsmasq[26241]: failed to send packet: No buffer space available
 

silentthinkr

New Around Here
SOLVED

I was able to fix this by increasing the dnsmasq cache from 1500 to 15000. I tired 4000 from another post I"d seen but, that did not work. Bumped to 15000, rebooted and started the VPN all was good. Upon addressing this, the syslog began to flood with "kernel: neighbor overflow". This too I was able to fix by increasing the gc_thresh values. The scripts were placed under /jffs/scripts/dnsmasq.postconf and init-start with a chmod 777 on both files. One final time of rebooting the router, starting the VPN and several hours later, syslog is clean and my clients are no longer losing their network connections.

dnsmasq.postconf
#!/bin/sh
source /usr/sbin/helper.sh
#
pc_replace "cache-size=1500" "cache-size=15000" "/etc/dnsmasq.conf"


init-start
#!/bin/sh
# Workaround IPv4 neighbour overflow
echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
#
#May as well do it for IPv6 just in case
echo 512 > /proc/sys/net/ipv6/neigh/default/gc_thresh1
echo 2048 > /proc/sys/net/ipv6/neigh/default/gc_thresh2
echo 4096 > /proc/sys/net/ipv6/neigh/default/gc_thresh3
 

sfx2000

Part of the Furniture
gc_thresh is the arp cache...

the defaults are usually pretty good out of the box...

any chance that IMGP snooping is enabled on the wireless interfaces?

Another tip..

Don't need to echo statements, just write them and then reload them with sysctl -p

sysctl -w net.ipv4.neigh.default.gc_thresh3=4096
sysctl -w net.ipv4.neigh.default.gc_thresh2=2048
sysctl -w net.ipv4.neigh.default.gc_thresh1=512
sysctl -p

you can also just add them to /etc/sysctl.conf
 

silentthinkr

New Around Here
gc_thresh is the arp cache...

the defaults are usually pretty good out of the box...

any chance that IMGP snooping is enabled on the wireless interfaces?

Another tip..

Don't need to echo statements, just write them and then reload them with sysctl -p

sysctl -w net.ipv4.neigh.default.gc_thresh3=4096
sysctl -w net.ipv4.neigh.default.gc_thresh2=2048
sysctl -w net.ipv4.neigh.default.gc_thresh1=512
sysctl -p

you can also just add them to /etc/sysctl.conf
 

silentthinkr

New Around Here
If they won't get overwritten in /etc/sysctl.conf, that would work too. Just wasn't sure?

I do see IMGP snooping on the wireless bands. You think that had something to do with my issues?
 

sfx2000

Part of the Furniture
If they won't get overwritten in /etc/sysctl.conf, that would work too. Just wasn't sure?

I do see IMGP snooping on the wireless bands. You think that had something to do with my issues?

as noted above - AsusWRT doesn't have sysctl built, so disregard...
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top