Static IP not working

macster2075

Very Senior Member
I have 3 POE cameras and I have manually assigned specific IPs in the LAN DHCP service section, but ever since the last update the router will not assign static IP address.
Every time the router reboots it will not apply the static ip addresses.

Any suggestions?
 

ColinTaylor

Part of the Furniture
So you mean reserved IP (Manually Assigned IP around the DHCP list) rather than static IP.

Have you rebooted the cameras?
 

macster2075

Very Senior Member
Yes, I have the cameras reboot every Sunday morning...which is today and this is when I noticed the cameras were offline. When I checked the IP address, I noticed it had changed to a random one.
 

ColinTaylor

Part of the Furniture
Look at the DHCP messages in the router's syslog when the cameras are powered on.
 

macster2075

Very Senior Member
I cleared the log and manually rebooted the camera and the only message that came through was this...

"Feb 13 12:00:35 kernel: nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead."
 

ColinTaylor

Part of the Furniture
Do you get messages from other DHCP clients when they connect or are you suppressing or redirecting them somewhere else?
 

macster2075

Very Senior Member
Not that I am aware of. To be honest, I am not sure what I am looking for.
 

ColinTaylor

Part of the Furniture
Normal messages would be something like this:
Code:
Feb 12 22:20:25 dnsmasq-dhcp[3197]: DHCPDISCOVER(br0) ec:1f:72:f8:4a:21
Feb 12 22:20:25 dnsmasq-dhcp[3197]: DHCPOFFER(br0) 192.168.1.186 ec:1f:72:f8:4a:21
Feb 12 22:20:25 dnsmasq-dhcp[3197]: DHCPREQUEST(br0) 192.168.1.186 ec:1f:72:f8:4a:21
Feb 12 22:20:25 dnsmasq-dhcp[3197]: DHCPACK(br0) 192.168.1.186 ec:1f:72:f8:4a:21 Galaxy-S6
 

Tech9

Part of the Furniture
There is a setting in LAN, DHCP Server to show/hide DHCP messages. @macster2075 has it disabled, perhaps.
 

bbunge

Part of the Furniture
For your cams assign a real static IP address at each cam. Leave a pool of IP addresses at the beginning of the DHCP pool for those addresses assigned at the client. I start the DHCP list at 192.168.50.11 which leaves me 192.168.50.2 thru .10 to assign to clients.
There have been issues with dnsmasq in 386.4. You may want to go back to 386.3 or Asus firmware.
 

macster2075

Very Senior Member
Yeah, I had to manually assign a static ip on each of the cameras using their own GUI.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top