Subnet refused to connect

Loukios

New Around Here
I'm having a problem accessing my modem interface on 192.168.1.1. My Asus router is on 192.168.0.1 uses PPPoE to connect to the internet through the modem. Everything works great except the fact I can't access the modem interface. This issue only started when I moved from Asuswrt to Merlin. I have RT-AX86U. Any clue on how to solve this? When I do tracert to 192.168.1.1 it doesn't access the local modem but instead it goes through my ISP local network if that makes any sense? Image below
 

ColinTaylor

Part of the Furniture
That's a bit odd for a PPPoE connection. Can you post a screenshot of what you see at "System Log - Routing Table".

If you then enable SSH LAN access (Administration - System) to your router, log in and enter this command do you now have access to the modem?
Code:
ifconfig $(nvram get wan0_ifname):0 192.168.1.2 netmask 255.255.255.0

If that works you can make it permanent by creating a user script.
 
Last edited:

Loukios

New Around Here
The 192.168.10.1 is a 4G USB dongle.
1663155957495.png


The command you send me fixed the problem. Is there a reason this is happening?
 

ColinTaylor

Part of the Furniture
The command you send me fixed the problem. Is there a reason this is happening?
You can see from the routing table that there is no explicit route to the 192.168.1.x subnet therefore such traffic will be sent out of the normal PPPoE interface (into oblivion).

I don't know how this worked before with stock firmware. But then I don't have a PPPoE connection. Maybe it's the Dual WAN setup that has changed the routing in some way.

To make the fix permanent you'd need to "Enable JFFS custom scripts and configs" and create a user script called /jffs/scripts/wan-event as follows:
Code:
#!/bin/sh

if [ "$1" = "0" ] && [ "$2" = "connected" ]; then
   logger -t "$(basename $0)" "Adding interface"
   ifconfig $(nvram get wan0_ifname):0 192.168.1.2 netmask 255.255.255.0     # This assumes USB is the *secondary* WAN
elif [ "$1" = "0" ] && [ "$2" = "stopping" ]; then
   logger -t "$(basename $0)" "Deleting interface"
   ifconfig $(nvram get wan0_ifname):0 down
fi

Remember to make the script executable: chmod 755 /jffs/scripts/wan-event
 

Loukios

New Around Here
You can see from the routing table that there is no explicit route to the 192.168.1.x subnet therefore such traffic will be sent out of the normal PPPoE interface (into oblivion).

I don't know how this worked before with stock firmware. But then I don't have a PPPoE connection. Maybe it's the Dual WAN setup that has changed the routing in some way.

To make the fix permanent you'd need to "Enable JFFS custom scripts and configs" and create a user script called /jffs/scripts/wan-event as follows:
Code:
#!/bin/sh

if [ "$1" = "0" ] && [ "$2" = "connected" ]; then
   logger -t "$(basename $0)" "Adding interface"
   ifconfig $(nvram get wan0_ifname):0 192.168.1.2 netmask 255.255.255.0     # This assumes USB is the *secondary* WAN
elif [ "$1" = "0" ] && [ "$2" = "stopping" ]; then
   logger -t "$(basename $0)" "Deleting interface"
   ifconfig $(nvram get wan0_ifname):0 down
fi

Remember to make the script executable: chmod 755 /jffs/scripts/wan-event
Perfect. Thanks a lot.
 

Loukios

New Around Here
You can see from the routing table that there is no explicit route to the 192.168.1.x subnet therefore such traffic will be sent out of the normal PPPoE interface (into oblivion).

I don't know how this worked before with stock firmware. But then I don't have a PPPoE connection. Maybe it's the Dual WAN setup that has changed the routing in some way.

To make the fix permanent you'd need to "Enable JFFS custom scripts and configs" and create a user script called /jffs/scripts/wan-event as follows:
Code:
#!/bin/sh

if [ "$1" = "0" ] && [ "$2" = "connected" ]; then
   logger -t "$(basename $0)" "Adding interface"
   ifconfig $(nvram get wan0_ifname):0 192.168.1.2 netmask 255.255.255.0     # This assumes USB is the *secondary* WAN
elif [ "$1" = "0" ] && [ "$2" = "stopping" ]; then
   logger -t "$(basename $0)" "Deleting interface"
   ifconfig $(nvram get wan0_ifname):0 down
fi

Remember to make the script executable: chmod 755 /jffs/scripts/wan-event
I've got a problem. When there's no internet but and the modem is plugged, I can't access the interface.
 

ColinTaylor

Part of the Furniture
I'm not that familiar with PPPoE setups. Try removing the "down" section and seeing if that helps. So the script would now look like this:
Code:
#!/bin/sh

if [ "$1" = "0" ] && [ "$2" = "connected" ]; then
   logger -t "$(basename $0)" "Adding interface"
   ifconfig $(nvram get wan0_ifname):0 192.168.1.2 netmask 255.255.255.0     # This assumes USB is the *secondary* WAN
fi
 

Dedel66

Regular Contributor
I've got a problem. When there's no internet but and the modem is plugged, I can't access the interface.
Did you check the IP of the machine that wants to access the modem? Sometimes it's the little things...
 

Crimliar

Senior Member
Excuse me for being stupid but you normally don't need to do all this!

With my modem at 192.168.131.1 making the following setting in WAN> Internet connection
wan1.png


Should produce:
wan2.png


*1 The gateway shown serves thousands of connection
*2 Note that the connection to the modem is "MAN" and making the setting on the WAN page is not often necessary.
 

Loukios

New Around Here
Excuse me for being stupid but you normally don't need to do all this!

With my modem at 192.168.131.1 making the following setting in WAN> Internet connection
View attachment 44231

Should produce:
View attachment 44232

*1 The gateway shown serves thousands of connection
*2 Note that the connection to the modem is "MAN" and making the setting on the WAN page is not often necessary.
That actually did the trick. I changed "Get the WAN IP automatically" from Yes to No and from this
1663350397038.png

To this
1663350414782.png

And it started working correctly.
 

ColinTaylor

Part of the Furniture
@Loukios That's good news. Like I said, I'm not that familiar with PPPoE setups.

For future reference can you SSH into your router and post the output of the route -n command. I'm guessing you have changed the 169.254 address to 192.168.1.2.
 

ColinTaylor

Part of the Furniture
Thanks, that confirms my suspicion. I've learnt something new about PPPoE today. :)
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top