Tearing my hair out, all i want it an access point. converting BT home hub 5 openwrt to an access point

Platforminc

Occasional Visitor
Hi,

I have a main wired network all around the house, however the wifi int he house doesnt extend to my outbuilding office but I have cabled cat 6 connection from my outbuilding to the main house, sow hat I did was to connect that to an unused router and concerted it to an access point, that router appears to have packed up, just wouldn't work. I then realised that I have got an open WRT BT home hub router at home originally bought for a VPN project but was too complicated to setup for NordVPN.

Anyway, what I want to do is configure it as my access point. It just cannot get it to work, its on open wrt 19.07. I have followed the instructions found online, disable the wireless, connect the cable to the main home wifi, disable DHCP, set the IP to 192.168.1.2 for example. It just wouldn't work. I watched the video
step by step and its really upsetting me. Can someone please tell me what I am doing incorrectly, in my case the cable is connected to the main home network via port 1 and port 2 connects to my laptop which is where i am configuring the router.

Thanks in advance.
 

L&LD

Part of the Furniture
Why did you turn off the radios? Isn't wireless what you want at that location?

Also, you are plugging in the Ethernet cable to the WAN port, correct?
 

Tech Junky

Very Senior Member
Well, you need to make sure you're matching your home subnet not just using 192.168.1.2 when you're running 192.168.12.1. Go to a PC on the network and verify the IP information before following the tutorial. Now, if you do indeed want WIFI in the outbuilding turn it on otherwise you'll need to cable up to the OWRT device. Now for the reuse of the ISP HH there might be an issue if you haven't default it using the paperclip to clear the config prior to trying to setup OWRT. Reflash OWRT to it and try again. It's also possible your IP scheme is already using 1.2 for an IP on something depending on how you have your IP range setup. If you do an arp on the PC while checking the IP info you can see the IP's in use.

Code:
C:\Windows\system32>arp -a

Interface: 192.168.0.170 --- 0x12
  Internet Address      Physical Address      Type
  192.168.0.1           5a-ea-69-a9-d9-fb     dynamic
  192.168.0.2           5a-ea-69-a9-d9-fb     dynamic
  192.168.0.50          5a-ea-69-a9-d9-fb     dynamic
  192.168.0.65          bc-cf-4f-d7-5f-20     dynamic
  192.168.0.102         00-18-dd-0a-24-7a     dynamic
  192.168.0.104         00-22-6c-04-11-61     dynamic
  192.168.0.105         00-bb-c1-9a-fe-2c     dynamic
  192.168.0.110         10-2c-6b-7d-11-50     dynamic
 

Platforminc

Occasional Visitor
Why did you turn off the radios? Isn't wireless what you want at that location?

Also, you are plugging in the Ethernet cable to the WAN port, correct?
I didn't turn off the radios. Guessing you mean WiFi here ?I didn't plug into WAN port, just one of the 4 lan ports.
 

Platforminc

Occasional Visitor
Well, you need to make sure you're matching your home subnet not just using 192.168.1.2 when you're running 192.168.12.1. Go to a PC on the network and verify the IP information before following the tutorial. Now, if you do indeed want WIFI in the outbuilding turn it on otherwise you'll need to cable up to the OWRT device. Now for the reuse of the ISP HH there might be an issue if you haven't default it using the paperclip to clear the config prior to trying to setup OWRT. Reflash OWRT to it and try again. It's also possible your IP scheme is already using 1.2 for an IP on something depending on how you have your IP range setup. If you do an arp on the PC while checking the IP info you can see the IP's in use.

Code:
C:\Windows\system32>arp -a

Interface: 192.168.0.170 --- 0x12
  Internet Address      Physical Address      Type
  192.168.0.1           5a-ea-69-a9-d9-fb     dynamic
  192.168.0.2           5a-ea-69-a9-d9-fb     dynamic
  192.168.0.50          5a-ea-69-a9-d9-fb     dynamic
  192.168.0.65          bc-cf-4f-d7-5f-20     dynamic
  192.168.0.102         00-18-dd-0a-24-7a     dynamic
  192.168.0.104         00-22-6c-04-11-61     dynamic
  192.168.0.105         00-bb-c1-9a-fe-2c     dynamic
  192.168.0.110         10-2c-6b-7d-11-50     dynamic
Can you please explain what I need to do.

The way I had this configured on Nother router us as follows.


Home network
192.168.1.x
Gateway 192.168.1.254

New AP router.
Set the router IP to 192.168.1.2
Disable DHCP as the main house router will dish out DHCP ip.
Disable firewall on openwrt

Is anything else required ?
 

Tech9

Part of the Furniture
There's one of the issues.

Just the opposite, if the router doesn’t have AP mode. LAN port is the right connection. DHCP off, IP inside main router’s DHCP range.
 

Platforminc

Occasional Visitor
The shocking thing is that I have configured the router the way I described it. I cannot ping the home router when connected to the AP router via a cabled connection, this is despite a cabled connection to home LAN on port 2 on rhe access point. I expected it to work like a wireless hub aka access point.
 

Platforminc

Occasional Visitor
Nothing unusual. Most ISP provided devices can’t be configured as AP.
Despite the fact that its openwrt which is supposed to open up opportunities. The issue I have now is that if I connect to the wifi, because DHCP is disabled and therefore it cannot get an IP, it doesnt appear to be getting directives from the main house router.
 

Tech9

Part of the Furniture
What OpenWRT is running on this router?
 

Tech9

Part of the Furniture
Can you bridge LAN and WLAN?
 

Tech9

Part of the Furniture
I don't know what works and what doesn't in OpenWRT with this device. Bridging LAN to WLAN has to happen automatically, if there is access point mode available, but I know nothing about this BT Home Hub and I don't know what interfaces are recognized in OpenWRT. This is a non-standard carrier specific combo router and this fact makes things a bit more messy. I found something that may help you though:

 

sfx2000

Part of the Furniture
Anyway, what I want to do is configure it as my access point. It just cannot get it to work, its on open wrt 19.07. I have followed the instructions found online, disable the wireless, connect the cable to the main home wifi, disable DHCP, set the IP to 192.168.1.2 for example

Go here....


The main site is still relevant
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top