1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Tenda MW6 Mesh Issues when Connecting a 4th Unit

Discussion in 'General Wireless Discussion' started by thingsfallapart, Feb 11, 2019.

  1. thingsfallapart

    thingsfallapart New Around Here

    Feb 11, 2019
    Hi All,

    First day here so please be gentle!

    I've got a Tenda MW6 4-node configuration

    Router -> Master Node (Living Room) via WAN port
    2x MW6's in the Dining room and bedroom - wireless.

    The problems have arisen when trying to connect the 4th MW6. (MW6-4)

    If I connect via wireless to the other nodes - it works fine.

    The problem is that I want to use Ethernet (as it's to be placed in a garden room, which is hard wired and it's too far to get a good wifi signal.)

    Apparently, the MW6 supports ethernet backhaul.

    1. Connect MW6-4 to Master via LAN cable (direct) works
    2. Connect MW6-4 to switch or any of the rest of the home network and it fails to operate ethernet backhaul and takes everything down with it!

    If I connect the Master node to the switch it also creates an issue. Do you think there's a DHCP conflict here and there's something going with IP addresses?

    Also, I can't update the firmware to V1.0.0.16 on the MW6-4 - the app keeps failing. I'm getting pretty sick of this buggy experience. It should be plugged into ethernet and we're done!

    Any ideas on this?
  2. Internet Man

    Internet Man Senior Member

    Sep 1, 2017
    Do you mean Modem -> Master Node via WAN port? I assume that you don't have some other router involved.

    This would seem to be an important first step. All nodes should be on the same, most recent, version. Can you first configure MW6-4 using wireless backhaul while it's within range and get the firmware updated that way? Can you start over with MW6-4 as the Master Node so that it can get updated then shift the other updated nodes around?

    From Tenda's FAQ:
    MW6-one node cannot connect to other two nodes,what should i do?
    MW6-How to add a new nova in a mesh network?
    thingsfallapart likes this.
  3. thingsfallapart

    thingsfallapart New Around Here

    Feb 11, 2019
    Thanks Internet man!

    The master node is connected to a BT Smart Hub 2 via ethernet port ont he back of the hub and via the WAN port on the MW6.

    The hub is one of these:


    Everything works fine with it wirelessly and I can manage all the IP addresses of connected devices in here.

    I've put the MW6-4 literally on top of the master node and tried to update the firmware and it just won't work. Tried resetting, restarting, re-adding to network too. No joy!

    FAQ wise - I've done those things fine. I can get a connection to the MW6 - just when I connect via ethernet the whole thing goes down.

    Maybe I need to start all over again, perhgaps in bridge mode?

    Maybe start with MW6-4 as the master node and update the firmware that way?
  4. C Chu

    C Chu New Around Here

    Mar 27, 2019
    I too have a similar problem. I have 4x MW6's, of which currently only 3 units are in use due to this issue. All have the latest firmware. My config is as follows: WAN->Linksys 6350 (Router) ->#1 MW6 (Bridge Mode) ->Elecom WRC-733 (Switch Mode)->#1 Ethernet Backhaul->Netgear Switch->#2 MW6. It works fine in this config, but if I connect #3 MW6 to the Ethernet Backhaul (i.e. WRC-733->#2 Ethernet Backhaul->Linksys 6400 (Switch Mode)->#3 MW6) then the whole thing goes down. The only way to connect #3 MW6 is to use wireless connection, which is not what I wanted as my house is already fully wired & have 500m fibre connection. Any suggestions to solve this problem?
    Another finding - if i use Routing Mode for the #1 MW6 then the data thruput is very low when using speedtest (100-200m), but in Bridge Mode the thruput is back to normal level for my connection (i.e. around 480-490m).
  5. Special

    Special Occasional Visitor

    Mar 24, 2019
    I had similar issues with mine in the beginning but don't remember how I went about getting it to work, mine were setup for wired backhaul and worked good for awhile. Once a month or so I would find 1 or 2 with red lights and have to unplug and let them sit for about 30 minutes, power them up and they would reconnect. The last time it happened the lights stayed red, I reset them back to default, put them on eBay and started using AiMesh. Sorry I can't be of much help because I deleted all my bookmarks for MW6 that gave tips for getting them working properly.
  6. thingsfallapart

    thingsfallapart New Around Here

    Feb 11, 2019
    I've also just thrown all mine on eBay - can't be bothered with the hassle of it all. The Tenda app is so flaky and basic, tech support non-existent and the lack of configuration options is laughable. Why put an ethernet port on if it doesn't work!
    I tried loads of stuff, disabling DHCP on main router, disabling wireless on main router to stop Double NAT.
    It's made for a price and you can really tell.