The jffs partition is full and I cannot remove any files nor format the partition

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


Occasional Visitor

I've finally gotten around to restoring my AC-RT86U to factory defaults (since upgrading to Merlin) and i'm now attempting to clear the jffs partition, but i'm having trouble. I've tried the GUI option of "Format JFFS partition at next boot" several times, but it is not working. I've tried manually deleting or moving files away from the jffs partition with no luck. I've tried doing "cat /dev/null > <filename>" to wipe some files, but nothing is working (see below - i get the "No space left on device" error). Any ideas on how i can clean up the jffs partition? I would have thought the WebUI option would have done the trick, but it's not working. Any help is appreciated.

[email protected]:/jffs/usericon# ls -lhtr
-rw-rw-rw- 1 admin root 168.3M May 1 11:16 04a15123ca84.ico

[email protected]:/jffs/usericon# cat /dev/null > 04a15123ca84.ico
-sh: can't create 04a15123ca84.ico: No space left on device

Many thanks!


Occasional Visitor
The WebUI option finally worked... after several retries. Not sure why it didn't work the first few times. Anyway, things are looking good now. The jffs partition is now only 3% in use.

/dev/mtdblock8 48.0M 1.3M 46.7M 3% /jffs



Occasional Visitor
Yeah, and i have no idea where this "usericon" file came from?? Pretty useless to have a 168MB icon file in the jffs partition. Anyway, thankfully the WebUI format utility finally worked. :)

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!