Transmission Hanging On

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

gjf

Senior Member
It looks like there is a simple way to hang up the router using Transmission: just give it not magnet URI, but URL to something huge (in my case it was https://cdimage.ubuntu.com/kubuntu/releases/20.04.1/release/kubuntu-20.04.1-desktop-amd64.iso).
After that Transmission web interface becomes non-responsible and the whole router becomes veeeerrryyyy slllloooooowwww...
Reboot solves the problem.

Can anybody check and confirm it? As for me - I am using RT-AC68U with Merlin 384.19 with Transmission 3.00 (bb6b5a062e).

If so - it's a pity Transmission does not check the link before proceeding.
 

L&LD

Part of the Furniture
So, if used as designed it works but breaks otherwise? :)
 

gjf

Senior Member
So, if used as designed it works but breaks otherwise? :)
There is a term called "human factor". So I am trying to report the human factor is absent in Transmission.
Proper peace of code should report "incorrect link" or whatever else - but does not hang on the whole system.
And I'd bet PC-based Transmission does not hang. So I think it's Entware-based version issue.
 

L&LD

Part of the Furniture
I agree wholeheartedly.

It is just easier to use it as it expects though. I can't imagine this is high on anyone's list of 'fixing' it.
 

gjf

Senior Member
Let me ask you does anyone expects one will try to connect \\.\globalroot\device\condrv\kernelconnect in Chrome? I don't think so. Anyway it was reported as an issue to fix.
Does anyone expects one will try to execute cd c:\:$i30:$bitmap? I really cannot imagine it - however it was reported as vulnerability to fix.
I am reporting more or less the same - but probability for the user to meet it is higher. And if you want to say somethnig important - just test it and reply does it reproduce or not.
Otherwise it looks like pure nonsense chat and trolling - and I see no use to reply further.
 

L&LD

Part of the Furniture
Your opinion of what my input is worth doesn't concern me. I'm trying to help, take away what you will.

As I said, I agree with your intent. Doesn't seem like a solution in the meantime to me though.

If you want to report this as an issue to be fixed, you should report this to Asus directly. Not on a public forum and of a fork of Asus' either.

Sure, everything should be fixed, but I appreciate the tradeoffs being made as to why this hasn't, yet.
 

gjf

Senior Member
If you want to report this as an issue to be fixed, you should report this to Asus directly. Not on a public forum and of a fork of Asus' either.
So you recommend me to report about problem of third-party torrent downloader installed on non-official firmware to Asus directly?
Well done, keep it going, pal.
 

L&LD

Part of the Furniture
Okay, you got me. I don't use torrent downloaders, third-party or otherwise.

Who is the author here? Maybe contact them instead then.

I've never heard of them on these forums in the last decade I've been reading.

Again, it isn't a problem if used as intended. The issue is elsewhere.
 

RMerlin

Asuswrt-Merlin dev
So you recommend me to report about problem of third-party torrent downloader installed on non-official firmware to Asus directly?
Well done, keep it going, pal.

No, report it to whoever published that third party torrent downloader.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top