What's new

Unable to add RT-AC68U to mesh - what can this be?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
This is just weird. I have an RT-AC88U as the main router in my AI Mesh (in access point mode, because my Windows Server takes care of all DHCP, DNS and so on), and I have a couple of the same router as nodes. I was trying to add an RT-AC68U to the mesh because I need one that can fit into a small, waterproof cabinet on the outside. But it just won't play ball! I first tried with Merlin and cable. No dice. So I flashed both the mesh router and the one I wanted to have as a node with the standard Asus firmware and tried again. First cabled, then over wireless. Still nothing. I replaced the network cable in case there was somethign wrong with it, and that didn't change anything either.

Finally I tried to add a spare RT-AC88U (I love those routers for stability, the 8 LAN ports and range, so I have spares that will last me a lifetime!) and that worked without a hitch. Does anybody have an idea what this can be?
Standard recommendation is to use Asus firmware on the node, connect router LAN port to node WAN port with a good Ethernet cable. Should also work with an AP vs. a router. May have to enable WPS if it is disabled.

At times I have had to try several times to add my AC66U_B1 as a mesh node. (AC66U_B1 has the same hardware as AC68U)
OK, thanks! So I'm doing it the right way, maybe just not enough times... Did you reset the node between tries or just fire up the search again?
With AIMESH WiFi connection, the MAX distance of 3m between Router - Node. Po połączeniu umieść węzeł w miejscu docelowym.
I think I'll give it up. I have had it running while working at my home office, and every time it comes to 90 %, counts the last ten in a few seconds and fails. At least 20 attempts now, every other time wired and wireless. There has to be something weird about this device.
I've had similar issues adding (re-adding) some 68U's as nodes. I've been running AiMesh with several 68U's for many years, so I'm familiar with setting them up. But recently, after a firmware upgrade to most recent ASUS firmware and factory reset, I just couldn't get it to be found. Tried everything including wired. No go. My old, last ditch trick finally did it. On the node (only) I fell back to old firmware (I happened to have Merlin 384.19 handy) and it paired first time I tried. Since this is a frequently mentioned problem with the RT-AC68U, I suspect there is some inherent incompatibility in newer firmware with these routers and AiMesh setup.
@Ronald Schwerer Thank you very much! That worked! I found that version on the Merlin site and it was in on my first attempt!

Edit: Upgrading to the latest firmware after pairing seems to work without a hitch, so it is only the pairing itself that is messed up. I'll just try to remember that and keep the old firmware on my disk for when I need to do that!
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!