Unable to get port-forwarding to work

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

R.Julian

New Around Here
Hello...

I recently purchased the RT-AX88U, to replace my old Linksys router.
After getting everything else working easily, I went to set up port-forwarding,
as I had easily done on my Liinksys Router. But I cannot seem to get it to work
on this new router.

Any help at all, would be greatly appreciated. I need the port-forwarding ability
for work.

I have read other threads here, so will answer the first expected questions...

- I have already tried a factory reset.
- I updated the Firmware, and now have version 3.0.0.4.384_9579.
- I have tried accessing my router config using multiple different browsers,
but tend to use Chrome.
- Under Lan->DHCP Server, I have reserved the local IP address for the computer
to which I am attempting to forward a port
- Under WAN->Virtual Server/Port Forwarding...
- I have turned ON "Enable Port Forwarding"
- I have added a profile, specifying the service name (my own application),
- Set the Protocol to BOTH (I only need TCP, but tried TCP, and then tried Both)
- Set the External Port (the port that my external application specifies)
- Set the Internal Port (currently set as the same as External Port...this is the port my local web server is listening on
- Set the Internal IP Address as the computer for which I reserved the IP address on the DHCP page
- Made sure the Source IP is blank.

I have not made any other changes, but am wondering if this router requires something else
turned on to make it work.
When I use the Open Port Check Tool (https://www.yougetsignal.com/tools/open-ports/) mentioned
elsewhere in this forum, it tells me the port is closed.

I also sometimes use RealVNC, which has a built-in port-checker....that also reports that the
port is closed.

I do not have a static IP address, but I use DynAlias to obtain the equivalent of a static IP.
I have used this successfully for over a decade, and yes...I did verify that the current IP
is up-to-date.

When I read the documentation on this, it appeared as though it was going to be just as simple
to set up as my last router. But I am obviously missing something (hopefully simple).

Thank you in advance to any responses....

Julian
 

ColinTaylor

Part of the Furniture
It sounds like you've done everything correctly. Do you see your rule under System Log - Port Forwarding?

Does the IP address shown by yougetsignal match that shown on the router at Network Map > Internet status > WAN IP ?
 

R.Julian

New Around Here
Hello, Colin.

Thanks for the reply!

Yes, if I go to the Port Forwarding tab of the System Log, I can see 2 entries for each profile (TCP, and UDP). The details appear correct there.

And yes, the WAN IP appears to match throughout....on the Network Map page, on my DynAlias utility, and on the yougetsignal page.

Strange that it is not working, right?
 

ColinTaylor

Part of the Furniture
Very strange indeed.

There was a similar post here. But that was for a completely different router model and firmware release, and the OP wasn't prepared to diagnose the problem. He said he got it working by turning off port forwarding but I suspect the actual problem was elsewhere.

Is it just a problem with that web server (maybe an ACL)? Can you forward a port to another device (another web server, SSH, FTP, printer, etc.) and see if you can reach that?
 

R.Julian

New Around Here
I don't think so, as it has been working for a couple of years....but well worth trying. I will check that out later today.
 

R.Julian

New Around Here
Alright....I do not understand this at all.

As per your wise suggestion, Colin, I tried setting everything up on a different computer,
then deleted my port forwarding entries, and re-entered them to point to the new computer.
This time it worked. I was not expecting that.

So, I went back and changed the settings to point back to my original computer,
and they are also now working.

I really cannot explain...but simply happy it is now working.

Thank you for your responses, Colin.
Perhaps it was your implicit blessing that solved my problem...lol.

Cheers!
 

ColinTaylor

Part of the Furniture
Glad to hear you got it working. Strange indeed.
 

jmpr

Occasional Visitor
Are you behind a CG-NAT proxy? Perhaps your isp has enabled it, so port forwarding is not possible. Mine uses CG-NAT but you can ask for disabling it for free.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top