Unable to login as admin to my router after flsashing to Merlin latest release (RT-AX86U)

Cyberghost77

Occasional Visitor
Hi,

I just flashed my router (RT-AX86U) to the latest merlin release for it (RT_AX86U_386) and now I am unable to login to my router as admin.

What can I do and why has this happened?
 

Cyberghost77

Occasional Visitor
Had to reset the router to factory settings, not impressed with the Merlin firmware considering it was the stable release. Does anyone know why did it do this?
 

bbunge

Part of the Furniture
You would have had to reset to factory after flashing Merlin anyway. So, why complain?
 

L&LD

Part of the Furniture
Resetting after flashing to RMerlin from stock firmware (or vice-versa) has always been highly recommended if you want to see the router/network perform at its highest and with great stability.

Never having to do it before only means you were lucky with your settings, hardware, client devices, and specific firmware versions at that time.

It also always helps to note the version you were on and the version you upgraded to (specifically, in detail).

There are multiple stickies referring to these basic requirements. It is usually also noted in the changelog itself too.
 

Cyberghost77

Occasional Visitor
I actually did not know this, things must have changed in the last year (was on an Asus router then a netgear router for a year before now I went back to Asus again). Yeah in the past (2019) when I had my Asus router I never did a reset after a Merlin flash, it worked strait away after the flash with same login details. Fair enough, I stand corrected and thank you for clarifying. Although I still think a reset is a drastic thing to do, in my case I had to a to do a hard reset just now cause the soft reset did not work, so I’m back to original manufacture settings which it should not have happened with a stable release unless my router is faulty. Thanks for clarifying though, appreciate it.
 

L&LD

Part of the Furniture

ColinTaylor

Part of the Furniture
Thanks, I actually didn’t know this until now, L&LD just explained it, thanks!
You normally don't need to do a factory reset after installing Merlin's firmware (although it is generally recommended for the first install). It actually says this in the installation instructions. However, depending on the specific firmware that was installed before it might be necessary. This should be stated in the release notes. If the old firmware was from before about April 2020 then the way the password is stored has changed, which does necessitate a reset.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top