What's new

unbound with IPv6?

anonimo

Occasional Visitor
With unbound installed I see my IPv4 address under "DNS Address" using ipleak.net, as expected, but see my Internet Provider IPv6 address too. I would have thought my IPv6 would be shown with my IPv4 address, but I’m no longer certain. In the firmware I have set “Connect to DNS Server automatically” to “Disable” using IPv6 Cloudflare addresses, just as with IPv4 using IPv4 Cloudflare addresses per an L&LD post, and tried it with “Enable” too, but get the same result. I understand Martineau is unable to test IPv6. Is seeing my ISP IPv6 using ipleak.net normal behavior?

I use 384.15 (thank you, RMerlin!), Skynet (thank you, Adamm!), and Diversion (thank you, thelonelycoder!) along with unbound (thank you, Martineau!) on a RT-AC5300 router. I installed 384.15 without a hitch and have re-installed all the rest during troubleshooting and still see my ISP IPv6 address.
 
Last edited:

dave14305

Part of the Furniture
With unbound installed I see my IPv4 address under "DNS Address" using ipleak.net, as expected, but see my Internet Provider IPv6 address too. I would have thought my IPv6 would be shown with my IPv4 address, but I’m no longer certain. In the firmware I have set “Connect to DNS Server automatically” to “Disable” using IPv6 Cloudflare addresses, just as with IPv4 using IPv4 Cloudflare addresses per an L&LD post, and tried it with “Enable” too, but get the same result. I understand Martineau is unable to test IPv6. Is seeing my ISP IPv6 using ipleak.net normal behavior?
I don't have IPv6 enabled to confirm this myself, but I believe changing the IPv6 DNS servers only impacts dnsmasq resolvers, which Unbound will "undo" when it is active (via dnsmasq.postconf script). So you should not expect to see the Cloudflare IPv6 addresses in a leak test.
 

Treadler

Very Senior Member
With unbound installed I see my IPv4 address under "DNS Address" using ipleak.net, as expected, but see my Internet Provider IPv6 address too. I would have thought my IPv6 would be shown with my IPv4 address, but I’m no longer certain. In the firmware I have set “Connect to DNS Server automatically” to “Disable” using IPv6 Cloudflare addresses, just as with IPv4 using IPv4 Cloudflare addresses per an L&LD post, and tried it with “Enable” too, but get the same result. I understand Martineau is unable to test IPv6. Is seeing my ISP IPv6 using ipleak.net normal behavior?

I use 384.15 (thank you, RMerlin!), Skynet (thank you, Adamm!), and Diversion (thank you, thelonelycoder!) along with unbound (thank you, Martineau!) on a RT-AC5300 router. I installed 384.15 without a hitch and have re-installed all the rest during troubleshooting and still see my ISP IPv6 address.

I see my WAN IPv4 & IPv6 addresses using ipleak + Unbound.
You are not confusing ‘your IPv6 server’ with that of your ISP?
 

anonimo

Occasional Visitor
I see my WAN IPv4 & IPv6 addresses using ipleak + Unbound.
You are not confusing ‘your IPv6 server’ with that of your ISP?
Thank you for your response! Yes, I see my ISP IPv6 address using ipleak.net and not my IPv6 address. I see my IPv4 address using ipleak + unbound, as expected. How did you setup IPv6?
 

Treadler

Very Senior Member
Thank you for your response! Yes, I see my ISP IPv6 address using ipleak.net and not my IPv6 address. I see my IPv4 address using ipleak + unbound, as expected. How did you setup IPv6?
“Native”, & the Merlin defaults.
Manually input Cloudflare dns servers.
Nothing special, installed Unbound, it just works.

(LAN - dns filter, I have set to “enabled” + global filter mode =“router”.)
 

anonimo

Occasional Visitor
“Native”, & the Merlin defaults.
Manually input Cloudflare dns servers.
Nothing special, installed Unbound, it just works.

(LAN - dns filter, I have set to “enabled” + global filter mode =“router”.)
Thank you again. Yes, I have the same setup; nothing special, installed unbound and it just works. No idea why my IPv6 address isn't shown using ipleak + unbound as you see (and I would expect to see).

When I run "nslookup ipv6.google.com" it does show my IPv6 address as the DNS server, and not the ISP IPv6 address, so it does appear to be working correctly regardless of the ipleak.net display.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top