What's new

Solved Updating to 386.9 broke DDNS and port forwarding. AC68U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
After I have recently updated my AC-68U to 386.9 (from 386.7-ish) I noticed that DDNS provider setting are reset to ASUS.COM and all port forwarding records are gone. Trying to add port forwarding records does nothing — newly added disappear once I refresh the page. And DDNS provider settings does the same. The only thing which works at DDNS page is the ability to upload certificate, but nothing else. The syslog is obviously full of errors from DDNS service because of the empty hostname for ASUS.COM service.
I am trying to understand what happened (rebooted multiple times, no IPv6) or at least how to troubleshoot this problem further.


Very Senior Member
If you haven't seen the earlier thread (found via subforum search), it has a suggestion. Disable IPv6 DDNS support.
DDNS update not working after update to 386.9
DIsable IPv6 DDNS support, as reported in your log it looks like your WAN interface isn't getting an IPv6.
Apparently some are having DDNS issues with 388.1 as well. Similar suggestion. Disable IPv6 DDNS support.
DDNS update not working on 388.1
As noted above, the easiest fix is to set IPv6 Update set to Off


Very Senior Member
Do you think ports forwarding also related to IPv6?
Unknown. But standard troubleshooting suggestions apply (if you haven't tried them already) when issues crop up after updating to newer firmware. Start with rebooting the router. If issue remains try the following:
  1. Disconnect any attached USB drives.
  2. Do a hard factory reset.
  3. Manually configure the router. Do not load a previously saved router cfg file.
  4. Once router is operating normally after reset connect USB drive if using one.
  5. Check if issue persists.


Occasional Visitor
Noticed that NVRAM was -619 bytes free. Cleaned it up and all of the sudden all settings become saveable.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!