URGENT HELP NEEDED- Got new job @ Home need to fix wifi-calling on Asus RT-AX58U asap. Should i go merlin?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dovedescent7

New Around Here
Can you guys help?

I just landed a job where ill be on the phone all day long remote from home and i need to fix my terrible wifi-calling on my brand new (2mo old) Asus AX58U running latest (updated today) stock FW. Due to some issues i cant do voip phone right now, wifi calling only current option. Was considering T-Mobile Cellspot V2 but see so many mixed reviews.
i have spectrum cable internet with 200/10 direct connected to the ASUS. I have a Brand new, Samsung Galaxy S10E with proper wifi-calling settings-its not the phone.. My wife's identical phone has same issues.

1. Is the consensus that i need AsusMerlin for best wifi-call success? I've ran merlin in the past on other asus routers but never dealt with advanced settings to optimize wifi calling

2. Is there a guide here that'll point out best/most success settings for the Asus router for best wifi calling? I Came here because of this Post on this forum which appears to have good settings of this. Or no?

3. Any suggestions short of getting another router, to get the absolute BEST wifi-calling in my home with the RT-AX58U?

Mod note: Link removed because it was an email address.
 
Last edited by a moderator:

Vexira

Part of the Furniture
id switch to merlin then look into the flex qos script, if you ar running adaptive.
 

CaptainSTX

Part of the Furniture
If you live in an area with many WiFi SSIDs visible I would recommend that you go with the cell spot instead of trying WiFI calling. I used a cell spot from T-Mobil for seven years and it worked very well however it was probably V1 cell spot. WiFi calling did not work well for me even using a TM-AC68 router supposedly optimized for WiFi calling. When using WiFi calling you need to remember to switch WiFi calling off when leaving home or your phone will try and link up with every crappy free public WiFi when trying to make or receive calls and if you have to accept the terms it won't connect.

WiFi calling can work OK but to maximize your success you need minimum interference from your neighbor's WiFi, locate your phone so it is near the router, try to avoid walking around the house when talking on the phone and depending on the bandwidth you have you may want to look into using QOS. QOS is useful if other individuals will be home when you are working and will stream video or make other heavy bandwidth demands.
 

Piggie

Regular Contributor
If your carrier supports wifi calling and you have it enabled on your phone, I turn off mobile data. If I leave mobile data in, my phone tries to connect to crappy LTE. If I turn data off, all calls go over wifi.

Sometimes if there are problems, turning the phone on and off works.

You can also use Google voice. It's free. You can have your cell phone route to Google voice and then you can take calls from your computer or tablet.
 

heysoundude

Very Senior Member
'sFunny - the one Android phone that connects to my network also has issues with wifi calling. The iPhones don't.

{ @Piggie 's implication that the issue is with the threshold of switching between the LTE connection and the wifi is an interesting one that I'll have to investigate with my Android user - we're literally 200m LoS from our provider's neatest cell site - so if that turns out to be the case, it strengthens my desire to expand/harden the wifi bubble here. It makes sense that the LTE signal is stronger in places (as well as over all) than my wifi, but damn, what is it doing to us, that radiation?}

I disagree with the FlexQoS suggestion - for the ISP speeds here, cakeQoS included w Merlin will be plenty good - KISS method works
 

cdlight

Occasional Visitor
id switch to merlin then look into the flex qos script, if you ar running adaptive.

This would be my thought as well. I use both Ooma VOIP and wi-fi calling (Pixel 4a) over our RT-AC86U running Merlin 386.3 with FlexQoS. We also use Spectrum 200/10 cable and although I mostly use the Ooma for voice calls, Merlin + FlexQoS proved the most reliable with the least latency for both VOIP and wi-fi calling. After some speed tests, this is what my QoS tab looks like:

1633035463173.png


While it doesn't apply to the OP, I also added a few AppDB Redirection Rules to FlexQoS to set my Ooma and MS Remote Desktop connections to the "Work-from-Home" class.

OP, the latest Merlin builds include CakeQoS which makes it easy for you to test this, too. I found that Cake closely matched FlexQoS but that the latter was slightly more reliable. For me, both FlexQoS and Cake outperform QoS in the stock ROM by a wide margin. Hope this helps.
 

RocketJSquirrel

Senior Member
Simplest thing would be for your employer to provide you a dedicated land line.
 

zaxcom

Regular Contributor
Also you need two turn on IPSec PassThrough in your router. When off it blocks wifi calling.
 

Attachments

  • Screen Shot 2021-10-01 at 7.28.42 AM.png
    Screen Shot 2021-10-01 at 7.28.42 AM.png
    74.7 KB · Views: 60

geobernd

Occasional Visitor
i need to fix my terrible wifi-calling
Can you explain in more detail what is happening?

I know AT&T prioritizes Mobile Network over WiFi - even if the Mobile connection is borderline - this may be the same with T-Mobile but I am not sure. I suggest you try: Put phone in Airplane mode, Turn on Wifi (only Wifi - don't take it out of Airplane mode) -> see how the call works then. If it works fine it's not the router or network... If not it will be really helpful to explain the symptoms you are experiencing...
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top