USB drive unmounts every few months, I/O error, part table locked

ahab

Occasional Visitor
ASUS RT-AX86U Running Merlin 386.5

Every few months my USB drive unmounts, which kills my swap file and takes out Diversion and Skynet, among other things. I've used a few different manufacturer's drives, including Kingston, Memorex, generic, USB2.0, USB3.0, etc. I format the drive in AMTM, etx4 with journaling on, and then create a 2 gig swap file for Entware et al. Runs great for a few months and then the first thing I usually notice is an abundance of ads in my browsers. The log file is riddled with errors pertaining to no swap file and the like and sure enough, running fd in AMTM reports problems with the drive and will not repartition it.

The strange part is that the drive is rendered unusable. I've tried to wipe off the partition, reformat the drive, change file formats, etc but I get a device I/O error and "partition table locked" error no matter what software/OS I try to use. Sometimes it disappears from the router's GUI frontpage, other times it's there but unmountable. The GUI pretends to reformat the drive but doesn't, nothing else even pretends to and I get those errors. Stranger still, I can clone the failed drive to a new drive with Acronis in Windows and when I reboot the router it's as if never happened. I could understand a physical problem and a flat out drive failure but none of the drives ever have read problems or report bad sectors afterwards, and the failure is always identical. Maybe four times now over the last year and a half??

Any ideas? TIA.
 

L&LD

Part of the Furniture
How are you implementing the new drives when the old one dies? Is it a fresh install on the USB drive, or, are you using backed-up files from the previous installs?

Are you formatting the JFFS partition (and hitting 'Apply' at the bottom of the page, then rebooting 3 times in the next 15 minutes) before you put in a new USB drive?

When was the last time you fully reset your router?

All the above are possible fixes, but the best suggestion is to stop using cheap USB drives that weren't meant for this type of use and use an SSD in a good external enclosure instead.
 

ahab

Occasional Visitor
I've done a mix of implementations, from a complete rebuild and reinstall of the router software to a restore of JFFS from a backup and a clone of the "dead" USB drive. I have reformatted JFFS although it's a stretch to claim I rebooted 3X before setting up the new USB. I've definitely reset back to factory defaults at least once since I got the router. It sounds like a proper SSD is the best way forward since the failures are consistent and thumbdrives the one common denominator. Multiple read/writes and continual disk activity could certainly put a hurt on these things. Thanks for the suggestion. Are these failures common?
 

L&LD

Part of the Furniture
Yes, they seem to be common for a lot of people here. When an SSD is used, no further issues have been reported (as far as I can remember).
 

Matthew Patrick

Senior Member
Is it connected on the USB 3 port? Do Asus Routers use UASP to connect to the particular flashdisk? Since i do remember some USB needing quirks when using UASP on raspberry pi etc . Mine has been running for more than a year nonstop and it's good. Just used a USB to micro SD adapter. And used the 32gb SanDisk max endurance. 170TBW++ AFAIK
 

ahab

Occasional Visitor
Both ports are USB 3.0 on the RT-AX86U, so, yes. I'm using what are apparently crappy old thumb drives however, which could certainly account for the unreliability. I do have UHS micro SD cards here, it may be worth trying one of those in the interim while I pull together an external SSD.
 

ColinTaylor

Part of the Furniture
Do Asus Routers use UASP to connect to the particular flashdisk?
Probably depends on the model of router. My RT-AX86U appears to support it if the device also does.
Rich (BB code):
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 5000M
    |__ Port 1: Dev 2, If 0, Class=, Driver=usb-storage, 5000M
    |__ Port 2: Dev 3, If 0, Class=, Driver=uas, 5000M
 

alchemy

Occasional Visitor
Haven't encountered these issues again since switching a year ago to a Samsung Pro Endurance Mirco SD Card 32G + USB 3.0 5Gbps Mirco SD Card Reader.
A SSD just for your router seems like a waste of a SSD (unless it's old or has too little storage).
 

mcse

Occasional Visitor
Tried multiple USB drives, various sizes, various vendors. None lasted more than a few months.

Switched to an old ata drive using a USB interface; haven't had a problem since.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top