Using 2.4 gHz devices with Asus Mesh routers

pgershon

Occasional Visitor
I have lots of Ring products and Kasa wifi light switches in my house. I have a ASUS mesh network with 3 RT-AX92U routers in my house. My 2.4 network has a unique SSID from the 5 gHz so these devices dont try to attach to wrong network. Many of the devices periodically lose connectivity because they keep switching connection between my various MESH nodes. The devices and routers never move. But I can see on the ASUS router management page that the devices keep switching the MESH node they connect to. Is there a way to control this? It is particularly bad for my ring chime unit, which keeps going offline and needing to be reconnected to the network a few times a week.
 

bbunge

Part of the Furniture
In the AiMesh Client List there is a Bind "button" with which you can choose the router/node the client connects to.

Edit: If you have dual band clients, even a few of them, it is better to use Dual Band SmartConnect. Let the clients choose what band to use. I find it best to change as few of the default WiFi settings as possible. I also use a 2.4 GHz "Guest" for my IoT devices. Sounds counter productive but if the 5 GHz gets RADAR bounced the clients can switch to the 2.4 GHz band and keep working. Even my smart TV sometimes uses the 2.4 GHz and works very well.
 
Last edited:

OzarkEdge

Part of the Furniture
I have lots of Ring products and Kasa wifi light switches in my house. I have a ASUS mesh network with 3 RT-AX92U routers in my house. My 2.4 network has a unique SSID from the 5 gHz so these devices dont try to attach to wrong network. Many of the devices periodically lose connectivity because they keep switching connection between my various MESH nodes. The devices and routers never move. But I can see on the ASUS router management page that the devices keep switching the MESH node they connect to. Is there a way to control this? It is particularly bad for my ring chime unit, which keeps going offline and needing to be reconnected to the network a few times a week.

Maybe your clients have too many strong signals to choose from for the area sq ft being covered... you could reduce the number of nodes or spread them farther apart or reduce the 2.4 Tx power (I have not tried this one) or disable 2.4 Roaming Assistant (let clients decide node steering/roaming).

OE
 
Last edited:

pgershon

Occasional Visitor
If I disable Roaming Assistant, how does the client know which node to join, since SSID's are the same?
 

OzarkEdge

Part of the Furniture
If I disable Roaming Assistant, how does the client know which node to join, since SSID's are the same?

As I understand it... the client decides to roam when it sees a better signal. Node-to-node distance and radio path/obstacles, node signal power/coverage/overlap, and Roaming Assistant band RSSI threshold can influence this decision. You should first optimize node placement... not too near (~40ft?), not too far (~80ft?), not too many, and not one-over-the-other. Ideally, you want to give the client one obvious signal choice when it physically roams away from its node connection and into another node coverage area. Then use RA band RSSI threshold to nudge the client to disconnect and roam (reconnect to a better/stronger signal)... where the client roams to is up to the client. When testing the RA RSSI threshold with stationary wireless clients, you may need to reboot them to see when they decide to reconnect to the near node/better signal. First step is node placement.

OE
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top