Using Alcatel Linkzone 2 in USB mode with Asus Router

bennor

Senior Member
Family member borrowed a Alcatel Linkzone 2 (T-Mobile apparently) from their local library to see if it provides better broadband than their DSL service. They've tested the Linkzone 2's USB-C port direct to their computer's USB port and can access broadband. Windows 10 shows it connected as "Remote NDIS based Internet Sharing Device ". Connecting the computer to the Linkzone 2's WiFi hotspot also works for accessing broadband. However they attempt to connect the Linkzone 2's USB to their RT-AC68U running latest firmware they are unable to get the Asus router to properly use the device for broadband access. When Linkzone 2 connected the Asus interface indicates "alcatel mobilebroadband" as a USB device. They are unclear what settings they should use on the 3G/4G USB modem page or Dual WAN page.

They've done trial and error with various settings to no effect. Only thing that has worked for them is to put the router into Repeater Mode and connect using WiFi.

Any suggestions on what they should try to get USB mode working? Anyone ever use a Alcatel Linkzone 2 with an Asus router? Searching SNBforums doesn't turn up much of anything on using this specific device with Asus routers.
 

bennor

Senior Member
Update: Eventually the Alcatel Linkzone 2 was able to work after much trial and error. One way to get it working was hard reset the Asus router, connect the Alcatel Linkzone 2 USB-C to the router's USB port (USB 2 or 3) then launch the Asus router configuration wizard and the wizard recognized the Alcatel as a USB Modem and would properly use it once the router was setup.

For what ever reason the Asus router, when already configured for a WAN connection, would have trouble properly recognizing the Alcatel when connected to the router via USB as the secondary WAN. Eventually was able to get it to work by making sure to enable Dual WAN, initially to Fail Over mode. Configured (and saved) USB Modem/USB Tethering with the following settings:
WAN Type: USB
Enable USB Mode: On
Select USB Device: USB Modem
APN Configuration: Auto
Telecommunications Standards: WCDMA (UMTS) / LTE
APN Service(optional) - NO FIELD
Dial Number - NO FIELD
Username - NO FIELD
Password - NO FIELD
Authentication: None
PIN Code: blank
USB Adapter: Auto
USB MTU: blank

If the network status for the Secondary WAN connection still indicates Cold Standby, what worked for me was to turn off the Internet Connection for the Secondary WAN, wait a few minutes, then re-enable it. That kicked it to Hot Standby and populated the status fields (WAN IP, etc). From there the Secondary WAN would go active when the primary WAN was disconnected from the router. Changing Dual WAN Mode to Load Balance does allow both WAN connections to be used. But the usual, often complained about Dual WAN Load Balance, issues of occasional page load stalling or hanging up and other issues may be present. Some screen captures follow.

Example of the Wizard Mode recognizing the USB Modem:
ASUSWizardInternetUSBModem.png

Example USB Modem/USB Tethering settings for the Alcatel Linkzone 2:
ASUSUSBModemUSBTethering.png

Network Map indicating Cold Standby for the Alcatel Linkzone 2:
ASUSSecondaryWANColdStandby.png

Network Map indicating Connected for the Alcatel Linkzone 2:
ASUSSecondaryWANConnected.png

Dual WAN page with Fail Over selected:
ASUSDualWANFailOver.png
 

GreenDragonFarm

New Around Here
I've been running into the same issue. Thanks for the run thru and screen shots. This is the farthest I've been able to get so far. Now I'm getting the message "Your ISP's DHCP does not function properly"

any suggestions on how to fix this? After some research, I've come cross 2 possible solutions that suggest updating the DHCP frequency from normal to aggressive and/or cloning the MAC address but I can find where to do that in the Asus interface.

any ideas?
 

bennor

Senior Member
any suggestions on how to fix this? After some research, I've come cross 2 possible solutions that suggest updating the DHCP frequency from normal to aggressive and/or cloning the MAC address but I can find where to do that in the Asus interface.
One can clone the MAC Address and set the DHCP query frequency in the Asus Router's GUI on the; WAN > Internet Connection > Special Requirement from ISP section. Your router may or may not support the DHCP query frequency option.

Asus has a FAQ entry on cloning the MAC address: [Wireless] How do I set up MAC Clone on an ASUS wireless router?

Never really could get Dual Wan to work 100% on that family member's Asus router (RT-AC68U). Sometimes it would work (only when the Primary WAN's ethernet cable was physically disconnected) , sometimes not. If the Alcatel Linkzone 2 will be the only WAN connection then try doing a hard reset on the router and configure it from scratch with the Linkzone 2 as the Primary WAN. If your ISP has any special settings or login requirements when using the Linkzone 2 make sure to use those settings or login information. It is also possible one may have to check the Linkzone 2's admin configuration page to see if any settings there are incorrectly set and causing problems with the Asus router.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top