Very slow WiFi - Yuck

#TY

Senior Member
Hi guys,

Today I installed a Fiber 1000/300 connection at home but my state of art Asus Routers can't seem to get past 150-200 download speeds.

I did a complete reset of both an Asus AX-88U (main) and an Asus AC5300 (Wired AiMesh). If I connect to the ISP router, my WiFi speeds are between 700-900 download and around 200-250 up. As soon as I connect to my Asus Wifi, my downloads drop to 150-200 but interestingly enough, my upload speeds are unaffected.

I separated my 2.4 and 5GHz bands and am only connected to the 5Ghz.

Any ideas? This is very frustrating :(

PS. None of the AI Protection or QoS features are on even though I don't think they should be affecting performance.
 

#TY

Senior Member
Could the AiMesh be impacting the WiFi performance so badly?
 

#TY

Senior Member
Agree to test only on main router. Try toggling NAT hardware acceleration.
Where do you see that option? I don't see it on my Asus RT-AX88U.
 

bbunge

Part of the Furniture
What firmware versions are you using? What does the speed test from the router show you? Are you removing the ISP router?
 

Justinh

Regular Contributor
Where do you see that option?
On my router interface: LAN page -> Switch Control tab. What ever NAT acceleration is set to, change it to the opposite. I say this because I've seen on this forum where this setting can throttle external bandwidth but I don't remember what value does it.
 

#TY

Senior Member
On my router interface: LAN page -> Switch Control tab. What ever NAT acceleration is set to, change it to the opposite. I say this because I've seen on this forum where this setting can throttle external bandwidth but I don't remember what value does it.
 

Attachments

  • Screen Shot 2021-12-05 at 7.43.01 AM.png
    Screen Shot 2021-12-05 at 7.43.01 AM.png
    23.9 KB · Views: 48

#TY

Senior Member
I've literally just spent 4 hours mixing and matching with every possible setting combination on this router and while I was able to double the performance from 1-200mbps to around 450mbps, the ASUS RT-AX88U doesn't seem to stack up against the ISP router that consistently hits between 8-900mbps. Is this some sort of hardware limitation in the Asus hardware? If so, it's very disappointing considering how much they cost and I may have to consider moving to another brand of routers.
 

leerees

Senior Member
You need to set your Asus router up to use 160mhz wide channels. That will give you 900mb/s over WiFi

Reset your router to its default settings and just enable 160mhz channels. That will fix it.

If it doesn't work then you need to start changing the control channel until you see clients connect at 160mhz. You can check by looking at the wireless logs.
 

sfx2000

Part of the Furniture
I've literally just spent 4 hours mixing and matching with every possible setting combination on this router and while I was able to double the performance from 1-200mbps to around 450mbps, the ASUS RT-AX88U doesn't seem to stack up against the ISP router that consistently hits between 8-900mbps. Is this some sort of hardware limitation in the Asus hardware? If so, it's very disappointing considering how much they cost and I may have to consider moving to another brand of routers.

Running any kind of QoS or rate limiters?

Happened to me - upgraded my connection and spent hours before realizing that I didn't update my QoS bandwidth settings...
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top