Voip delay cutting time

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Damit1

Regular Contributor
Hi

So I am using voip, and recently moved from one company to another.
In both companies, once the adaptors were behind NAT -outbound call delayed in about 10 sec.
Port forwarded to 5060.

Once you DMZed the adaptors it got faster to about 5 sec, but if I compare it to using app in the smartphone, still slower.
Any idea why is it happen?
What can I do to shorten the delay time ?

Thank you
 

Adooni

Senior Member
did you try Advanced Settings > WAN > NAT Passthrough

RTSP Passthrough - Disable.
SIP Passthrough - Disable.

not sure if this will have any effect
 
Last edited:

geobernd

Occasional Visitor
The 5 sec delay probably has nothing to do with your internet connection but with the dial string used.
Since you are not using VoIP phones but an adapter there is no 'dial' or 'send' button so the adapter figures out when you are done dialing and when to start the call...

If this is a managed VoIP adapter talk to the folks that manage it and see if they can setup a faster dial string for countries with fixed length phone numbers (like NANP)
If it's your own adapter try to find a forum for it and look for instructions on how to optimize the dial string.

The longer delay on NAT is strange but maybe related in a way that the provider expects a SIP proxy or STUN settings and those are not configured correctly and they somehow have a fallback method to figure out how to get you connected and it just takes time to kick in...
 

Damit1

Regular Contributor
did you try Advanced Settings > WAN > NAT Passthrough

RTSP Passthrough - Disable.
SIP Passthrough - Disable.

not sure if this will have any effect

It is actually the opposite, RTSP passthrough and SIP passthrough are enabled plus NAT Helper
Why should I disable them? sounds like the opposite result to happen.

The 5 sec delay probably has nothing to do with your internet connection but with the dial string used.
Since you are not using VoIP phones but an adapter there is no 'dial' or 'send' button so the adapter figures out when you are done dialing and when to start the call...

If this is a managed VoIP adapter talk to the folks that manage it and see if they can setup a faster dial string for countries with fixed length phone numbers (like NANP)
If it's your own adapter try to find a forum for it and look for instructions on how to optimize the dial string.

The longer delay on NAT is strange but maybe related in a way that the provider expects a SIP proxy or STUN settings and those are not configured correctly and they somehow have a fallback method to figure out how to get you connected and it just takes time to kick in...

Did some changes to the NAT settings in my adaptor, that cut the times to 5 sec.
Changed to NAT UPNP and cut it to half.
It is might be correct and it is abut the dial plan that makes it longer time to 5 sec.

Thanks!
 

zaxcom

Regular Contributor
For sure turn those off. They interfere with SIP being setup on VoIP. I have been on VoIP for 15 years and anytime the ALG's are on it messes it up. It also matters how you have your adapter setup to discover your public IP. I am on a Lynksys adapter and it has 8 different settings that can be changed to discover the IP with or without using a STUN server. Here is a shot of mine.


Screen Shot 2021-09-04 at 12.21.47 PM.png




You can also set up your dial plan to eliminate the need to dial local area codes or prefix numbers. My calls go thru in less than a second.
 
Last edited:

Damit1

Regular Contributor
For sure turn those off. They interfere with SIP being setup on VoIP. I have been on VoIP for 15 years and anytime the ALG's are on it messes it up. It also matters how you have your adapter setup to discover your public IP. I am on a Lynksys adapter and it has 8 different settings that can be changed to discover the IP with or without using a STUN server. Here is a shot of mine.


View attachment 36131



You can also set up your dial plan to eliminate the need to dial local area codes or prefix numbers. My calls go thru in less than a second.

Disabled SIP and RTSP.
How do I make a dian plan in grandstream?
Looking for such thing existing and not finding anything
Got a headache already
 

Damit1

Regular Contributor
So I see nothing on router side, only Adaptor?

BTW
SIP ALG disabled just longer the delay to 13 sec and nothing else.
Enabled back and everything is OK.
So thanks for the time being
 

zaxcom

Regular Contributor
This is the wrong place to ask about your adapter. Use the grandstream forums to get expert help there. People there can help you with the best settings.
 

Vexira

Part of the Furniture
Disabled SIP and RTSP.
How do I make a dian plan in grandstream?
Looking for such thing existing and not finding anything
Got a headache already
Have you tried using the providers dial plan?
 
Similar threads
Thread starter Title Forum Replies Date
svrakas ASUS RT AC86U Merlin Ping Delay Asuswrt-Merlin 1

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top