1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

VPN Client Failing to connect

Discussion in 'Asuswrt-Merlin' started by Andrew Benson, Aug 25, 2019.

  1. Andrew Benson

    Andrew Benson New Around Here

    Joined:
    Aug 25, 2019
    Messages:
    3
    For months now (several different versions) I cannot get 3 of the 5 VPN Clients to connect. I continually receive the following error: You must define CA file (--ca) or CA path (--capath). I am using ExpressVPN and have two connections going fine. I have confirmed all the settings are the same and I am using the OpenVPN file provided by them (as I did with the other two). I have attempted to clear the settings on these three clients using the Default button multiple times, but still no luck.

    Any advice you have would be appreciated.
     
  2. CaptainSTX

    CaptainSTX Very Senior Member

    Joined:
    May 2, 2012
    Messages:
    1,989
    Are you setting up the clients on separate ports?

    Are the ports you are trying to use supported by ExpressVPN?

    Beware that some VPN providers only support a single port to keep it simple.

    I am surprised you got two running if you are not using different port numbers.
     
  3. Jack Yaz

    Jack Yaz Part of the Furniture

    Joined:
    Apr 20, 2017
    Messages:
    2,422
    The error is fairly self explanatory - have you filled in the ca certificate field?
     
  4. Andrew Benson

    Andrew Benson New Around Here

    Joined:
    Aug 25, 2019
    Messages:
    3
    Although I haven't required this for the other two locations, I have copied the ca data provided from proxy service; but it doesn't save. When I go back into certificates again, they are all blank again.
     
  5. Andrew Benson

    Andrew Benson New Around Here

    Joined:
    Aug 25, 2019
    Messages:
    3
    This is my settings, and when I attempt to turn the Service State to ON it goes through the process and when it reaches 100% comes back to OFF

    upload_2019-8-27_7-40-42.png upload_2019-8-27_7-41-15.png

    Custom Configuration:

    fast-io
    remote-random
    pull
    tls-client
    verify-x509-name Server name-prefix
    ns-cert-type server
    route-method exe
    route-delay 2
    tun-mtu 1500
    fragment 1300
    mssfix 1200
    keysize 256
    sndbuf 524288
    rcvbuf 524288