Solved VPN Client keeps disconnecting

macster2075

Very Senior Member
Anyone else having issues with constant disconnects on the VPN client?
I have tried different servers and they all keep disconnecting several times a day.

This all started after the last firmware update.
 

macster2075

Very Senior Member
Another thing I notice is.. .the router says Disconnected, but I still have internet...Also, the VPN is not connecting automatically on reboot. I have to always enable it.

WAN.jpg


auto.jpg
 
Last edited:

Rajjco

Occasional Visitor
Had the same issue. Did a Factory reset and configured from scratch fixed the issue.
Try setting the router from scratch and don't use the previous saved settings since it might have issues.
 

macster2075

Very Senior Member
I've also tried restoring to factory and starting from scratch.. still, the VPN keeps disabling itself. Should I try the previous Merlin version?
 

macster2075

Very Senior Member
I also recently set my ISP modem in bride mode. Could that be causing this issue?
 

Kal1975

Regular Contributor
It looks like you may have more than one issue.

Your first issue may be the internet status showing disconnected. That can't be a good thing. There may be some kind of issue with your ISP. I used to have occasional issues like this also. Setting up ChkWan fixed that for me. It may still occur, but with the script, it reconnects. There is another thread on how to set up ChkWan.

The second issue may be related to the first. But in any case, you have a PPPoE VPN client defined. I have mine set up as an OpenVPN client. Perhaps if you try to set an OpenVPN client up, the issue won't occur. I believe OpenVPN settings/config can be configured to always reconnect. What VPN provider are you using?
 

macster2075

Very Senior Member
I am using NordVpn. The main issue I am having is the VPN client keeps disconnecting very often. I have already cleared to factory settings twice and even started from scratch.
I understand may be having issue, but that would have any effect on why theh VPN client would disable itself right?
 

Kal1975

Regular Contributor
I'm pretty sure NordVPN supports OpenVPN. Try setting up an OpenVPN client and see if it disconnects also.

I believe they have VPN configuration files that you can download to set it up quite easily. They probably have tutorial videos and if not them, Youtube would have them as NordVPN is a large VPN provider.
 

Kal1975

Regular Contributor
Ooops. I misread the image or didn't look closely. I was thinking it was PPP setup but I see that that was the WAN connection type. Ooops.

What do the logs say. Any errors? Does this always happen? On a regular time period?

You mentioned that even though the GUI shows disconnected you still had an internet connection? Perhaps they are related. I would keep an eye on the VPN stopping and see if the WAN connection always shows "disconnected" when that happens. When my internet connection showed disconnected, my VPN would not work. After I restarted my internet connection and it showed connected, the VPN would then automatically reconnect.
 

Viktor Jaep

Very Senior Member
That's what Im using.. I sue OpenVpn with Nord configuration.

This is exactly one of the reasons why I developed VPNMON-R2... to help with disconnects, and making sure it reconnects each and every time! I use Nord as well... highly recommend using it if you value VPN connection stability. Check out the thread... drop me a line if you need any help!

 

macster2075

Very Senior Member
Did a few resets to factory, removed the vpn…still getting disconnects.

Removed bridged mode and went back to default….issue gone!
I guess this modem doesn’t work well in bridge mode.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top