VPN Director Killswitch

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

kiomisu

New Around Here
Firstly hi, new user here and total newbie to VPN Director

I'm running 386.3 on a RT-AC68u

I have a QNAP on my lan which I want to run through VPN client 1 and have Killswitch enable to block all traffic should the VPN go down. This will be the only device on that client

I have Nord up and running on Client one. Used their config and only changed Username/Pass , Accept DNS Config = Exclusive and Redirect internet traffic through tunnel = VPN Director (policy rules) Killswitch - Block routed clients if tunnel goes down = Yes

Set the Default gateway DNS on the Qnap to the router IP. Enabled Client 1 and all good. Checked the Qnap's Wan ip and it's the VPN's public ip. Tested it and it's routing all traffic through the VPN.

No here's where I have a issue.

Added Rule to VPN Director. Descriiption = Qnap Local IP = Qnap's LAN IP Iface = OVPN

If I stop VPN client 1 the Qnap's Current wan IP reverts back to the Router's wan IP.

The killswitch doesn't Kill the connection

What am I missing here? Any help greatly appreciated.
Dave
 

ColinTaylor

Part of the Furniture
If I stop VPN client 1 the Qnap's Current wan IP reverts back to the Router's wan IP.

The killswitch doesn't Kill the connection
That's intended behaviour. By manually turning off the VPN client you are saying "I don't want to use this client". That is not the same as the the tunnel failing while the VPN client is enabled, which is what will trigger the killswitch.

 
Last edited:

kiomisu

New Around Here
Thank you very much that clarifies it. Now to stretch the friendship a touch, is there a way I can test it?
 

kiomisu

New Around Here
That's intended behaviour. By manually turning off the VPN client you are saying "I don't want to use this client". That is not the same as the the tunnel failing while the VPN client is enabled, which is what will trigger the killswitch.

Thanks for your help. SSH in and run the command. Works great
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top