VPN Director rule is ignored

Toby the Cat

New Around Here
I setup a OpenVPN client on my AC86U (386.5) for all my devices (ovpn1) which works perfect. Via the VPN Director I added a rule for my computer to go directly to the WAN if needed, this also works like it should. (ticking or un-ticking the rule)

However I would like my TV to connect to another country, so I setup another OpenVPN client (ovpn2)

And now the problem, when I enable the rule in VPN Director for my TV to use ovpn2, it doesn't use ovpn2 but instead uses the rule for ovpn1

1.jpg


When I look at the VPN status both clients are connected and the IP's are indeed correct

2.jpg


I rebooted the router, the TV, made sure it's internal IP is correct, made sure I have the correct device, the MAC is correct

I'm flabbergasted and don't know what to do :rolleyes:

Any help is greatly appreciated to get this working, feel free to ask me more details, I'm not always online but will try to answer ASAP

Thanks

Fred
 

dave14305

Part of the Furniture
Try putting the rule for 192.168.1.0/24 after the TV rule.
 

eibgrad

Part of the Furniture
The various OpenVPN client's are prioritized, w/ #1 having the highest and #5 the lowest. Therefore, it comes as no surprise that you can't create a rule like 192.168.1.0/24 for OVPN1 that doesn't supercede 192.168.1.151 for OVPN2. In order to get what you want, you have to place 192.168.1.151 in OVPN1, and the rest in OVPN2.

P.S. Conveniently, the rules as listed in VPN Director always reflect their priority.
 

Toby the Cat

New Around Here
It works !!!! :p

Thanks for the tips, the rule for all the traffic which was ovpn1 is now ovpn5, that leaves me with room for a few more tweaks.
 

Toby the Cat

New Around Here
Update:

I have iptables to open a port, I had to change these rules for them to work with the changed openvpn port

My iptables rule was for tun11 and I had to change that to tun15
 

Sean Rhodes

Regular Contributor
I believe there's still a problem with the firmware though since I am also having only the first entry in the policy table picked up and additionally when enabled leaking DNS.

I will try to add a separate thread first though
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top