What's new

VPN help with ipv6

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
I have look for days, but can't find a post that is the same as my problem. So I'm going to ask for help. This may sound dumb, but I'm at a loss on it.

I have a VPN server up & running. Using the ipv4 address i can connect just fine to it. But if i try using my ipv6 address it just times out when outside the network. Inside the network it connects. I know what my WAN ipv6 is & what my ipv6 block assigned to me by my isp is. But neather address will connect remotely. What is the ipv6 address i use? What am I missing that is preventing the connection?

On a sperate question, i have a 4g hotspot. According to the provider the ipv4 is private, but it supports ipv6 & they clam the ipv6 is public. I can belive it becouse when the xbox is connected to it & using ipv6 it shows a open NAT & no firewalls. Now my Asus rt3200 can use this hotspot as a usb modem. But i have to run the ipv6 on the Asus in passthrough mode. Is there a way to run a VPN, or any remote network access, by using the ipv6 on the hotspot. The hotspot has a setting to allow incoming ipv6 connections.

Thanks for any help any one can provide. Im normally good with networking, but I'm at a loss on my ipv6 issues .
So i guess no one can help me.

I've been looking, but i still can't find what i need. It's like the firewall is blocking the incoming connection to the VPN when using a ipv6 address. I've tried adjustments to the ipv6 firewall & even turning it completely off. Still no response.
I have run into the IPv6 firewall problem. The logic in the enable/disable seems to be 1/2 backwards. This causes the required rules to be skipped. ssh into the box and "ip6tables -S " and "ip6tables -S -t mangle" to see what the current set of rules are. I also had an issue with the VPN, RT-N66U <-> RT-N66U (running same version of s/w) where OpenVPN was being called with the WAN IPv6 interface address on the client machine. One would think this is the correct procedure, but NO. My client ISP provides IPv6-PD over PPPoE but give the ppp interface (wan) a private IPv6 address. The OpenVPN server was receiving the connection initiation request, but couldn't reply to the private IPv6 address.
Sorry it took so long to respond, never got the notification of a reply.

Yes, turns out the firewall was doing the blocking. Seems the ipv6 firewall settings page is useless. I did ssh into my router & running a command to open all ports on ipv6 allowed the connection, but made different issues.

The phone connected still could not see internal network addresses, & kept disconnecting & reconnecting.

I also need to find out how to do this on a router using a usb hotspot as its WAN connection, when ipv6 only works right in passthrough mode. Also need adjust the code to open only the port i need, only for the usb WAN, & set it to run at boot.

ip6tables -I INPUT -i ppp0 -p tcp --dport XXXX -j ACCEPT

That redone to use WAN on usb, then put into a script & on the jffs, while getting a ipv6 to the router in passthrough mode.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!