WAN IP Double NAT Issues

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

hisXLNC

New Around Here
i apologize if this is in the wrong forum.

my network situation is this:

i have a modem/router from my ISP which i use to connect to the internet. It has a dynamic ip and is different after every restart (huawei).

i have an asus ax 11000.

I have set the isp modem/router device to bridge mode.

The issue is the ip address on the modem is for example 33.33.33.33
the asus will show a wan ip of 10.10.10.10
.

sometimes i will get lucky and the asus will show the same external ip address as the modem (33.33.33.33), when this happens, everything works smooth (apps like plex etc..)

sometimes the isp modem restarts and the wan ip changes and then i go back to the issues of different ip addresses that causes things like plex to not work (double nat issues).

How do i fix this?
 

SoCalReviews

Very Senior Member
It is my experience that ISPs will log and store a list of your connected devices (MAC address) such as your Asus router on their server side (or in the ISP provided modem/router). This is more problematic if you are provided multiple dynamic IPs from your ISP service which is more common for business services. This is just a guess and I can't say this is the problem but it could be that your Asus router's MAC address is stored multiple times with different IP addresses. The other possibility is that your ISP provided modem/router is simply causing errors and acting like a DHCP server some of the time despite you having set it up in bridge mode. You could also be having an issue related to the ISP's implementation of IPv6 if that is what they are using.

First thing I would suggest trying is disconnecting your router from your modem and disconnecting the modem from it's incoming cable and power both devices off for ten minutes. Then power up the ISP modem and wait five minutes and then power up the Asus router with no devices connected to it. Then reconnect your Ethernet LAN devices, etc.. See if that resets or flushes the IP addresses that are associated with MAC address that are stored in the ISP modem or on their servers.

The next thing you can do is contact your ISP technical support. Explain what is happening and see if they can help since this is likely a issue with their modem or with their servers. They should also be able to reset their modem remotely if that is needed. You might need to configure the modem for bridge mode afterwards. It's unlikely this is an issue with your Asus router so there isn't much else that I am aware of that can be done with the Asus router settings.
 
Last edited:

eibgrad

Very Senior Member
If the modem is in bridge modem, then you *never* are double NAT'd, by definition. Your router's WAN always has the IP assigned by the ISP. Ideally that's a *public* IP. If you sometimes end up w/ a *private* IP (which includes CGNAT), that can become a problem for some apps, esp.. those that need remote access into your network, because remote access is NOT possible w/ a private IP.
 

SoCalReviews

Very Senior Member
If the modem is in bridge modem, then you *never* are double NAT'd, by definition. Your router's WAN always has the IP assigned by the ISP. Ideally that's a *public* IP. If you sometimes end up w/ a *private* IP (which includes CGNAT), that can become a problem for some apps, esp.. those that need remote access into your network, because remote access is NOT possible w/ a private IP.
Yes, regardless of the title the OPs explanation isn't entirely clear about this nor are the real IP addresses given in the examples (which is understandable for privacy). Despite the modem being supposedly set for bridge mode we don't know how that bridge mode is being implemented. Some equipment (such as with many AT&T Uverse modems) doesn't have a true bridge mode but a psuedo bridge type mode.
 

hisXLNC

New Around Here
its hauawei 5G cpe pro modem (H112-372) the ip it has 188.xxx.247.xx. every time i restart it i get a new IP from the ISP. these range from starting 41.xxx or 37.xxx

the asus router shows IP 10.237.xxx.xxx. if i restart both devices multiple times i can eventually get the asus to pick up the ip from the huawei. when it doesnt pick up the ip from the huawei modem it always shows an ip starting from 10.xxx

the huawei is in its bridge mode option.
 

ColinTaylor

Part of the Furniture
TBH this doesn't sound like it's a problem with the router. It's more likely a limitation of the mobile phone network you're connecting to and whether it's assigning public or private IP addresses at that moment in time. In any event you probably need to be directing these questions to your mobile ISP.
 

SoCalReviews

Very Senior Member
its hauawei 5G cpe pro modem (H112-372) the ip it has 188.xxx.247.xx. every time i restart it i get a new IP from the ISP. these range from starting 41.xxx or 37.xxx

the asus router shows IP 10.237.xxx.xxx. if i restart both devices multiple times i can eventually get the asus to pick up the ip from the huawei. when it doesnt pick up the ip from the huawei modem it always shows an ip starting from 10.xxx

the huawei is in its bridge mode option.
Despite using the bridge mode setting the 10.xxx IP WAN addresses are likely coming from the Huawie modem... not the Asus router. For reference go to time 17:20 of this YouTube VIDEO showing the Huawie 5G CPE Pro router/modem settings and notice the similar 10.xxx WAN IP. This does seem to be an issue related to the Huawie router/modem and not the Asus router.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top