1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

WAN link state changes to 100 mbps (Asus TM-AC1900/AC-68U)

Discussion in 'ASUS Wireless' started by cusideabelincoln, Nov 9, 2018.

  1. cusideabelincoln

    cusideabelincoln New Around Here

    Joined:
    Nov 9, 2018
    Messages:
    3
    I've been having throttled download speeds with this router. The problem is it will limit my download speeds over both a wired and wireless connection to 30-40 mbps. I have tested this router at two locations, one has 100 mbps Internet and the other 400 mbps, and at both locations a secondary router was able to provide full transfer speeds.

    At first I thought it was the firmware of the TM-AC1900 so I changed it (painstakingly) to an AC-68U. Right after upgrading the firmware I tested the download speeds over the Internet and I was getting full speed and my WAN link state was at 1 Gbps. However I noticed after leaving the router idle for some time, the WAN link state reverted to 100 Mbps and my Internet speeds were throttled to 30.

    The router in question is an Asus TM-AC1900.

    This problem was originally happening with the latest stock firmware of the TM-AC1900.

    I have since upgraded this router to the AC-68U stock firmware and have tried the Merlin variants, and the issue remains. Currently the router has Merlin 380.69, but I have tried 384.72. I have also tried stock Asus 382 firmware.

    This issue was also present with two different cable modems (Motorola SB6121 and Arris TM1602) and different ethernet cables.

    I have also tried enabling the dual WAN option and plugging one cable from my modem into the secondary WAN link, and leaving the primary WAN port on the router empty, and the problem also happens.

    Is this just a hardware issue of the router or is there a way I can force the link state to 1Gbps?
     
    Last edited: Nov 9, 2018
  2. Ronald Schwerer

    Ronald Schwerer Senior Member

    Joined:
    Jan 8, 2017
    Messages:
    231
    When you connect the router to the modem, did you power cycle or reboot the modem?

    Last week I noticed I was only getting ~35 mbps download (normally I get around 115). I ran that way for a couple days thinking it might be related to a service disruption (road work down the block cut the underground cable). But I finally power cycled the modem and it came back to full speed. So somehow it got in some odd state.
     
    OzarkEdge likes this.
  3. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    260
    Location:
    Apex, NC
    Okay, I have read another post of yours as well for the same issue. First and foremost, forget about all the other issues you describe and let's focus on the connection between the router and the cable modem. Regardless of your subscribed speed with your ISP provider, you should have a 1Gbps connection to the cable modem.

    You mention multiple routers and cable modems. Pick the most current of these and the ones you want to ultimately choose for your operation.
    • When you connect an Ethernet cable between the modem and the router, what color are the LEDs on the physical port for each device?
    • Please advise as to which cable modem and router you are using.
     
  4. cusideabelincoln

    cusideabelincoln New Around Here

    Joined:
    Nov 9, 2018
    Messages:
    3
    I've found someone with basically the same issue in this thread, hoping to combine our knowledge:

    https://www.snbforums.com/threads/rt-ac68u-slowing-down-wired-connection.49260/

    The situation was first noticed at my friend's house. This is my friend's router and he asked me to look at it. He upgraded from 100 mbps to 400 mbps Internet through Spectrum. They replaced the cable modem, and when he went to test his new speeds he was only getting 30 mbps. He connected his laptop directly to the modem and he was then getting his 400 mbps. I went over there and reset everything and couldn't solve the issue; he had a spare Asus NT-66U router that we used and it was working perfectly fine. He had bought brand new Cat 6 cables at the same time the modem was upgraded. He's not the most tech savy so it is possible this issue was happening before he even upgraded his Internet, as he probably did not run a speedtest prior to the upgrade for a baseline.

    I took the problematic home with me and have it connected to my network. The setup is as follows. I have a SB6121 cable modem. That is connected to a TP-Link Archer C7 gigabit router. I then connected his TM-AC1900 to my Archer C7 router. I have my laptop and secondary desktop connected via ethernet cable to the TM-AC1900. My primary desktop is connected directly to the Archer C7, so that I can verify my Internet speeds are running normally. I know this is not an ideal setup but I feel it is irrelevant to the root of the issue I have described. I've reset his router several times using several methods. I've used several versions of firmware, from the stock T-Mobile to the stock Asus to Merlin variants. I have gotten the router to temporarily download, from the Internet, at full speeds.
     
  5. cusideabelincoln

    cusideabelincoln New Around Here

    Joined:
    Nov 9, 2018
    Messages:
    3
    Well I plugged more ethernet cables into the LAN port and for some reason that forces the WAN port to stay at 1 Gbps. However now those LAN ports are at 100 Mbps. Wireless speeds of both 2.4 GHz and 5 GHz are also below 100 Mbps.

    I've reset the router various times and tried Merlin firmware as old as 380.64.

    Currently I have the router with the latest Merlin firmware of 384.72. I cleared the nvram via SSH using "mtd-erase2 nvram", power cycled the router, and then reset it via the WPS-button method. The slowed speeds were still present, although I found another oddity. The one device that was connected with an ethernet cable and had a link state of 1 Gbps was able to achieve full speeds. The other devices that were stuck on 100 mbps link state did not. Wireless speeds are hit and miss depending on what device I use and what frequency I choose with each device - speeds are all over the place and inconsistent from test to test.

    My buddy has since gone out and bought a new router (Nighthawk AC2400), so fixing this one isn't a priority. It is a matter of curiosity, though. He's been going through customer support trying to get a refund or replacement for it since he bought it only 7 months ago, and got the extended warranty since it is a refurbished product.