WiFi 160MHz

dlukanidin

Occasional Visitor
The RT-AX88U itself switches Wifi to 80MHz from 160MHz.
Can't find a reason.

Test stand:
Master AiMesh router - RT_AX88U (160 MHz - on, channel - 48, width - 20/40/80/160)
Node - RT-AC86U ( 5 meters from master)
No meteo or other radars.

Experiment:
1. >service restart_wireless /on master/ All clients switch to node, master swith to 160MHz
2. waiting for a few minutes: WiFi scanner show width is 160MHz
3. >service restart_wireless /on node/ All clients switch to master, master swith to 80MHz, Log - only shows messages like: wlceventd: wlceventd_proc_event(540): eth7: ReAssoc C0:A6… and wlceventd: wlceventd_proc_event(494): eth7: Deauth_ind C0:A6…

Please help me to understand why master router switch channel width to 80Mhz after clients connect to it?
 

heysoundude

Part of the Furniture
AiMesh is designed to provide consistent wifi, right? Here's what I would suggest might be happening:
the AC86 maxes out at 80MHz on 5GHz band; mixing and matching AX and AC routers like that, the AX will "slow itself down" so the AC "keeps up"
for a 160MHz 5Ghz wifi mesh consistently, you'll need to retire the ac86 and replace it with a...ax58 maybe
(aren't the master and node awfully close to each other @ 5m? wireless or Ethernet backhaul?)
you could also relocate the AX88 to a more central location in your home, deactivate the AC86/mesh and see if the router defaults to 160MHz.
If not, look up ChannelHog in the Addons subforum - that was built to help, iirc.
 

dlukanidin

Occasional Visitor
you'll need to retire the ac86 and replace it with a...ax58 maybe
I turned off the AC86 router and got exactly the same result after restart_wireless.
Log fragment:
Снимок экрана 2022-09-27 в 18.42.50.png


ChannelHog - will does not work in my situation. It will restart WiFi in loop and block it as a result.
 

heysoundude

Part of the Furniture
I turned off the AC86 router and got exactly the same result after restart_wireless.

ChannelHog - will does not work in my situation. It will restart WiFi in loop and block it as a result.
have you checked out what the airwaves around you are like with Wifi Radar?
 

drinkingbird

Very Senior Member
The RT-AX88U itself switches Wifi to 80MHz from 160MHz.
Can't find a reason.

Test stand:
Master AiMesh router - RT_AX88U (160 MHz - on, channel - 48, width - 20/40/80/160)
Node - RT-AC86U ( 5 meters from master)
No meteo or other radars.

Experiment:
1. >service restart_wireless /on master/ All clients switch to node, master swith to 160MHz
2. waiting for a few minutes: WiFi scanner show width is 160MHz
3. >service restart_wireless /on node/ All clients switch to master, master swith to 80MHz, Log - only shows messages like: wlceventd: wlceventd_proc_event(540): eth7: ReAssoc C0:A6… and wlceventd: wlceventd_proc_event(494): eth7: Deauth_ind C0:A6…

Please help me to understand why master router switch channel width to 80Mhz after clients connect to it?

160mhz requires 8 sequential channels which is almost guaranteed to have at least a couple with congestion or noise causing it to fail back. There is an 80+80 mode that will use the first 4 and last 4 channels (skipping DFS bands) but even then, you're using up most of the available spectrum and asking for interference. Not sure if Asus supports the 80+80 mode or not.

Similar to 40mhz 2.4ghz, sometimes you're just asking for too much.
 

dlukanidin

Occasional Visitor
have you checked out what the airwaves around you are like with Wifi Radar?
Code:
>wl -i $(nvram get "wl1_ifname") radar_status
NO RADAR DETECTED

>wl -i $(nvram get "wl1_ifname") dfs_status
state IDLE time elapsed 0ms radar channel cleared by dfs none

use only 160, not auto 20/40/80/160
It works. I test it now. But what means 20/40/80/160 if 160 only works the same?
 

RAH-66

Senior Member
@dlukanidin,
better width 160 and primary channel from popular 36-48

For example, not all clients "can" 149-165. And recently, they began to cut out 100-128 in some regions.
 

dlukanidin

Occasional Visitor
Thank you all and especially RAH-66. I will be glad also to see another opinions.
 

OzarkEdge

Part of the Furniture
Thank you all and especially RAH-66. I will be glad also to see another opinions.

Consider the router's bandwidth setting to be the max permitted bandwidth for client connections. And know that clients should connect at their max capable bandwidth, 20, 40, 80, or 160, subject to the router's current max bandwidth.

If you fix the router's max bandwidth setting, it won't change except to fall back from 160 to 80MHz to avoid RADAR per DFS by law.

If you allow the router to vary its max bandwidth setting by setting 20/40/80/160MHz, then the router may fall back to a lower max bandwidth to avoid interference, restricting client connections accordingly. Consider this 'Auto' max bandwidth, similar to Auto control channel to avoid interference.

Opinions are cheap; mine could be wrong. :)

OE
 

dlukanidin

Occasional Visitor
If you allow the router to vary its max bandwidth setting by setting 20/40/80/160MHz, then the router may fall back to a lower max bandwidth to avoid interference, restricting client connections accordingly. Consider this 'Auto' max bandwidth, similar to Auto control channel to avoid interference.
Thanks, it's more clear. The algorithm itself, I think, in the Broadcom proprietary code.
 

heysoundude

Part of the Furniture
Code:
>wl -i $(nvram get "wl1_ifname") radar_status
NO RADAR DETECTED

>wl -i $(nvram get "wl1_ifname") dfs_status
state IDLE time elapsed 0ms radar channel cleared by dfs none


It works. I test it now. But what means 20/40/80/160 if 160 only works the same?
No, do a wifi site survey of what may be interfering:
1664390533857.png

I may be under the mistaken understanding that it's part of all supported router's firmware. This is on my AC86 and it has helped me find space in the airwaves among my neighbours and their wireless footprints
 

dlukanidin

Occasional Visitor
No, do a wifi site survey of what may be interfering:
I don’t have any other networks nearby at all. Only two my networks: first for clients - AiMesh on AX88 and AC86 (fixed channel 48), and second for transport to remote building - on two Ubiquiti Nano Station (fixed channel 149/40 MHz (Upper)). So no interfering from other networks. I use WiFi Explorer to check, not only at the location of the main router, but also 100m around.
 

bigpcjunky

New Around Here
I'm having the same problem with a RT-AX86U. I checked my logs and it isn't radar detection causing the switch from 160MHz to 80MHz. For me It looks like firmware after 186.5_2 and equivalent ASUS firmware causes the switch from 160MHz to 80MHz after Windows does a reboot/boot after shutdown or wake after sleep.

I don't think it's the Intel bluetooth wifi drivers not correctly saving/restoring the state as downgrading to Merlin 186.5_2 solved this problem for me.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top