WiFi Adapter Keeps Disabling Itself

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

hadesflames

New Around Here
I'm unsure if this forum is correct for help with my adapter but here's hoping.

I have an Asus mobo with a built in intel AX200 wifi adapter. The specific motherboard for reference is an Asus ROG Crosshair VIII Formula.

For a long while now I've been having an issue where my wifi just randomly disables itself and I go offline. Running automatic troubleshooting typically brings it back up by restarting it, but that never fixes the problem. It will still eventually turn itself off again. It happens maybe once or twice a week. I would like to fix the issue so that it doesn't just disable itself anymore. I'm definitely running the very latest drivers but it's been happening for multiple driver versions at this point.
 
Last edited:

L&LD

Part of the Furniture
Are you leaving the computer on? Or shutting it down?

If you aren't holding down Shift while clicking the shutdown button, you are not doing a full shutdown.

Look at task manager to see the uptime after you turn the computer on. If it is showing more than a couple of minutes, it is effectively hibernating and not doing a clean boot up.
 

bbunge

Part of the Furniture
I'm unsure if this forum is correct for help with my adapter but here's hoping.

I have an Asus mobo with a built in intel AX200 wifi adapter. The specific motherboard for reference is an Asus ROG Crosshair VIII Formula.

For a long while now I've been having an issue where my wifi just randomly disables itself and I go offline. Running automatic troubleshooting typically brings it back up by restarting it, but that never fixes the problem. It will still eventually turn itself off again. It happens maybe once or twice a week. I would like to fix the issue so that it doesn't just disable itself anymore. I'm definitely running the very latest drivers but it's been happening for multiple driver versions at this point.
Most recent Intel drivers for the AX200 is version 22.30.0 (https://ark.intel.com/content/www/us/en/ark/products/189347/intel-wi-fi-6-ax200-gig.html)

However, the issue may not be the adapter especially if your router is using DFS channels. One way to see if it could be the router resetting the 5 GHz due to RADAR detection is to set the router 5 GHz to 80 MHZ bandwidth on channel 36 or 149. These channels should give you a more stable signal for testing. You should also check for neighborhood WIFI interference.

BTW - what router are you using?
 

hadesflames

New Around Here
Are you leaving the computer on? Or shutting it down?

If you aren't holding down Shift while clicking the shutdown button, you are not doing a full shutdown.

Look at task manager to see the uptime after you turn the computer on. If it is showing more than a couple of minutes, it is effectively hibernating and not doing a clean boot up.
I pretty much never turn off my PC other than for necessary reboots. However my other PC downstairs is also always on 24/7 and never has this issue. It has an expansion slot wifi adapter but I believe it's also an AX200.
Edit: I also have the hibernate instead of shutdown setting disabled.

That's not right, I have 22.40.0.7 installed.

However, the issue may not be the adapter especially if your router is using DFS channels. One way to see if it could be the router resetting the 5 GHz due to RADAR detection is to set the router 5 GHz to 80 MHZ bandwidth on channel 36 or 149. These channels should give you a more stable signal for testing. You should also check for neighborhood WIFI interference.
I don't see how the router would have anything to do with my adapter getting disabled. As mentioned above, there are many devices on my network and none of them experience this issue.

BTW - what router are you using?
Asus RT-AC86U, but again I can't see how the router or any of its settings would be causing my adapter to randomly disable itself. Just to clarify, by disable I don't mean I'm getting drops. I mean the device is literally getting disabled. The same as if you were to go into Control Panel -> Network and Internet -> Network Connections and then right clicked on your wifi adapter and then clicked disable.
 

L&LD

Part of the Furniture
If Hibernate is still enabled on your system, hitting 'shutdown' still effectively hibernates. Did you manually turn Hibernate off with the following code at an elevated command prompt?

Code:
powercfg /h off

As I said, you can check if the system is actually turning off by checking the Task Manager (Performance tab) by shutting down as you normally do, and then after turning the system back on, see if the 'up time' is in seconds/minutes instead of longer.
 

hadesflames

New Around Here
If Hibernate is still enabled on your system, hitting 'shutdown' still effectively hibernates. Did you manually turn Hibernate off with the following code at an elevated command prompt?

Code:
powercfg /h off

As I said, you can check if the system is actually turning off by checking the Task Manager (Performance tab) by shutting down as you normally do, and then after turning the system back on, see if the 'up time' is in seconds/minutes instead of longer.
It's irrelevant because as I said, I only ever reboot my PC for updates and such. I never turn it off.
 

L&LD

Part of the Furniture
That's the point. If you don't reboot, it could be an issue with the drivers/Windows going crazy after extended uptime.

You need to reboot some computers/drivers daily or at least every second day (the hint is it happens once or twice a week).
 

Tech9

Very Senior Member
I pretty much never turn off my PC other than for necessary reboots.

I reboot my Windows 10 computers only on major updates. Check in wireless drivers, Power Management. Remove "Allow the computer to turn off this device to save power". On the router in Wireless, Professional disable WMM APSD. Some adapters don't like this setting. Also disable Airtime Fairness in Professional and Protected Management Frames in General. Test again and see what happens. Roll back wireless adapter drivers - the ones you have may have an issue. I had to do this once with Intel drivers. My WI-Fi was turning off after number of unsuccessful attempts to connect. This is a software problem and you don't have to reboot your computer to keep it going.

You need to reboot some computers/drivers daily or at least every second day

No.
 

hadesflames

New Around Here
"Allow the computer to turn off this device to save power"
Interesting I remember having done this a few weeks back but when I went to double check it was back on. I've disabled the setting. Fingers crossed.

I'll try the router options only if the problem persists.

Roll back wireless adapter drivers
I've had this issue for multiple driver updates. At least 3 updates if memory serves. I doubt it's a driver issue.

My WI-Fi was turning off after number of unsuccessful attempts to connect.
For me it happens while connected. This is a desktop pc, it doesn't move and the wifi network I connect to never changes. It's always connected unless the router drops or the adapter gets disabled. There's never any unsuccessful connection attempts to the network.
 

Tech9

Very Senior Member
I've had this issue for multiple driver updates. At least 3 updates if memory serves. I doubt it's a driver issue.

You can try to uninstall the driver with remove files and let W10 find the new hardware and install WHQL driver, if available. May be older, but should be tested working. Issues like that are usually driver or power management related. Read what folks in other forums say, any similar issues, any found solutions, etc. See if Asus provided a driver in motherboard support downloads. Dell/HP were providing their own drivers in the past; drivers downloaded from hardware manufacturer were not working well. To isolate eventual AX connection factor you can downgrade temporary the adapter to AC only and test again. There are options to resolve the issue. Rebooting your W10 computer daily is not one of them.
 

John Fitzgerald

Senior Member
Interesting I remember having done this a few weeks back but when I went to double check it was back on. I've disabled the setting. Fingers crossed.

I'll try the router options only if the problem persists.


I've had this issue for multiple driver updates. At least 3 updates if memory serves. I doubt it's a driver issue.


For me it happens while connected. This is a desktop pc, it doesn't move and the wifi network I connect to never changes. It's always connected unless the router drops or the adapter gets disabled. There's never any unsuccessful connection attempts to the network.

Have you tried this:
 

hadesflames

New Around Here
You can try to uninstall the driver with remove files and let W10 find the new hardware and install WHQL driver, if available. May be older, but should be tested working. Issues like that are usually driver or power management related. Read what folks in other forums say, any similar issues, any found solutions, etc. See if Asus provided a driver in motherboard support downloads. Dell/HP were providing their own drivers in the past; drivers downloaded from hardware manufacturer were not working well. To isolate eventual AX connection factor you can downgrade temporary the adapter to AC only and test again. There are options to resolve the issue. Rebooting your W10 computer daily is not one of them.
Asus provides standard intel drivers. Nothing custom for this board (specifically on the wifi adapter) I can try that as well if the power setting doesn't resolve the issue. Definitely agree that I should not need to power off or reboot my PC for my wifi adapter to work as expected.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top