What's new

WiFi disconnects with RT-AC86U Asuswrt-Merlin 384.17

csalsa

New Around Here
I have been running Asuswrt-Merlin 384.17 for a few weeks on an Asus RT-AC86U router and I have been getting WiFi disconnects. The wired connections work fine but WiFi drops out when a device starts using the connection. The devices connect fine but then when starting to use the WiFi connection, it drops out.

It has affected the worst iOS and Android devices. My phone is an Android 10 and I noticed it most when opening an App or when using the Google App Store (where it appears a newly installed App calls home and starts using the connection). From the Android devices, the WiFi connection automatically re-establishes - until the WiFi connection is used again. Though repeatable, not every WiFi access causes the crash. I have two laptops running Windows 10 and using Intel WiFi chipsets that also have a problem but not a bad as the mobile devices.

I have downgraded back to 384.16 and all the WiFi connections appears stable. I looked in the system log could not make sense of it. I am happy to make it available for review.

It should not be an relevant but I also only use the 2.5GHz band and turn-off the 5GHz band (as I have no need for it). Prior to 384.17, I have not had issues with the WiFi.
 

CaptnDanLKW

Regular Contributor
1) 2.4Ghz set to 20Mhz 5Ghz you can leave ay 20/40/80 or set to 80 (if you ever chose to use)
2) Fixed Channels - Avoid DFS channels (5GHz only)
3) Advanced - Disable Universal Beamforming, Airtime Fairness and TX Bursting

Noticed the AMPDU is enabled - that's not the default.
Not sure why you have AP Isolated set - I assume you chose that for a specific reason as it's not the default.

You may want to try a M&M reconfigure as as test.
 

MarkyPancake

Senior Member
I like to keep my wireless setup as simple as possible, so this is mine currently:

  • 2.4 GHz band set to Auto Wireless Mode, 20 MHz Bandwidth and the Control Channel as either 1, 6, or 11, I use the least congested.
  • 5 GHz set to N/AC mixed, 80 MHz, channel 36 or 40, I use the least congested.
  • For both bands, the only professional settings I have enabled are AMPDU RTS and Enable WMM, then Modulation Scheme set to match the capabilities of the band without TurboQAM, so MCS 7 (802.11n) on 2.4 GHz and MCS 9 (802.11ac) on 5 GHz.

Only takes a few minutes to make these changes, so not much lost if it doesn't improve your setup.
 

csalsa

New Around Here
1) 2.4Ghz set to 20Mhz 5Ghz you can leave ay 20/40/80 or set to 80 (if you ever chose to use)
2) Fixed Channels - Avoid DFS channels (5GHz only)
3) Advanced - Disable Universal Beamforming, Airtime Fairness and TX Bursting

Noticed the AMPDU is enabled - that's not the default.
Not sure why you have AP Isolated set - I assume you chose that for a specific reason as it's not the default.

You may want to try a M&M reconfigure as as test.
Thanks for your input @CaptnDanLKW. I will try the settings.

"AP Isolation" is my security paranoia and it prevents devices (phones, laptops, TVs etc) from communicating with each other on the same LAN. I have no need for devices to communicate with each other as I do not have a NAS or networked printer and I do not do media streaming. But I do have work devices on my LAN and I do sometimes have friends who make use of my WiFi (though I usually put them on the guest network).
 

csalsa

New Around Here
From the replies above, no one has called out issues with build 384.17.

During the last 2 days I rolled back from 384.17, from observation, not logs, I find build 384.16 more stable than 384.17. I have also made changes to settings as suggested above and so the comparison is just build vs build.

I have found the past Asuswrt-merlin builds really stable - even the betas. But I think I will skip the 384.17 build and go to 384.18 build when it comes out.
 

SheikhSheikha

Regular Contributor
I think some more settings should be adjusted for your 2.4 WiFi. I send you a screen capture of my settings. After you have done this on your Apple Devices: reset network settings. (Apple does some black magic when it first connects to a wifi and that does not catch up really well when you change settings on your router).

2020-05-30_09-54-05.jpg
 

KGB7

Very Senior Member
@KGB7
Settings attached as images. Is this ok?
I have not changed these settings since I last did a factory reset of the router some six months ago (may be longer).

Bellow you will find screenshots of settings that I use on my Asus AC68U router, firmware 384.16

Just to be clear. I live in an apartment complex and i'm surrounded by wifi routers from my neighbors.
The settings bellow work perfectly for me with out any issues. Most of my devices are Apple products that connect to 5Ghz band and one Windows laptop that connects on 2.4Ghz band(laptop has no 5G capabilities).

Apple deices do work flawlessly on 2.4G band. Only reason my devices are connected to 5G, is to get the most speed out of my ISP.

My settings are set up for speed. Since i'm the only person connected to my AC68 router, I dont have to share bandwidth or WiFi with anyone else. So if you have other people in your home, you will have to adjust settings in the Professional Tab, if multiple devices are streaming or using internet at the same time. Especially, if anyone plays video games online, uses FaceTime or Zoom video conference. But i havent had any issues yet, while downloading large files on a laptop, while playing PS4. But if you must have that 0.5 sec response in a game, few changes will have to be made.

Having that said.
My settings do work well for me..(could be a little better, I dont use QOS), even while im torrenting on a laptop, and at the same time surfing the web on the iPhone or iPad, or listening to music from Spotify or from my local radio station.

There are few tweaks you can do in Professional Tab, but thats a discussion for later time. In the mean time, test my settings for few days and let us know, and we will try to improve on them if needed.

Edit;

Im also including links to larger images.

https://i.imgur.com/u4SYE3u.png
https://i.imgur.com/b1DT8cM.png
https://i.imgur.com/WOPaN5v.png
https://i.imgur.com/U7yNFWc.png
 

Attachments

Last edited:

bbunge

Very Senior Member
From the replies above, no one has called out issues with build 384.17.

During the last 2 days I rolled back from 384.17, from observation, not logs, I find build 384.16 more stable than 384.17. I have also made changes to settings as suggested above and so the comparison is just build vs build.

I have found the past Asuswrt-merlin builds really stable - even the betas. But I think I will skip the 384.17 build and go to 384.18 build when it comes out.
I advocate the Asus factory firmware for the AC86U. For various reasons I switched from 384.17 about a month ago with few regrets.

See: https://www.snbforums.com/threads/rt-ac86u-firmware-and-settings.64433/

And I would recommend leaving both WIFI bands active.
 

Svenskmat

Regular Contributor
I have an RT-AC5300 with Merlin .17 I was having issues with one of the two 5 Ghz dropping and also losing internet or very low speeds. Both issues were not at all Merlin related. The 5 Gig issue is known across multiple routers and can be fixed by turning off auto channel select My intermittent internet issues were caused by a bad attenuator attached to my cable modem. It took me too long to figure this out including purchasing a new RT-AC5300 and painfully refiguring all my clients.... when all along all I had to do was remove the attenuator and choose a channel for 5 gig (I returned the 2nd RT-AC5300)

I would suggust you go back to Stock firmware and troubleshoot the issue on stock firmware
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top