1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

WIFI (internet) drops on AC66U_B1

Discussion in 'Asuswrt-Merlin' started by Rockel83, Jan 10, 2019.

  1. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    I'm using a AC66U_B1 for about 2 years now I guess, and I was verry pleased with this router so far.
    I tried Merlin firmware in the beginning, but it seemed that I had little more wifi reach in and outside my house when using the stock Asus firmware. So I flashed back to the orriginal firmware.

    Lately I was beginning to get some annoying connection drops on my WIFI with the orriginal (up-to-date) firmware. Instead of going back to factory settings. I wanted to give AsusWRT-Merlin another shot.
    So I reverted back to factory settings using the "initialize" option. And loaded the latest AsusWRT-Merlin firmware (the AC68U version as reccomended) after that. Which seemed to work quite well in the beginning (still having less WIFI reach than with the orriginal firmware?) But I'm actually like the diversaty of this firmware to be able to change tables and input, so far! Something which was quite anoying in the orriginal firmware.

    I configured the router manually after loading Merlin, so didn't load anny settings of the orriginal firmware. Only configured standard settings at that point, like: passwords/ guest network/ manually assigned IP adresses and set up MAC filtering for accepting incomming connections, to keep things as simple and clear in the beginning, which should make it easier looking for the problem.

    It seemed it worked the first day, being able to listen radio from my echo dot for example without too manny interruptions.
    But now, a few days later the internet connection keeps dropping on the wireless connected devices. Like on the mentioned echo dots (interupting interradio constantly) but also being not able to surf on the internet with my mobile phones (pages stop loading halfway). It seemes the internet connection drops almost every 30/60 seconds, which is really annoying.
    This while the WIFI connection itself keeps displaying full strength of it's connection, and not seem to be falling away or disconnecting.

    The wired connected devices like my laptop, NAS and Steam Link doesn't seem to have this problem! So it doesn't seem to be connection drops from my modem/ISP, as far as I can figure out from now it's only concerning the wireless connected devices! So I guess it should have something to do with wireless interfereces, wireless radio or wireless settings?

    I've tried restarting the router a couple of times, but the problems still returns.
     
  2. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    429
    Location:
    Apex, NC
    The key is that non-WiFi devices don't have any issues. It is quite possible that additional WiFi networks are interfering with yours. Please obtain some type of WiFi app (I use WiFi Explorer on my MacBook) that will provide information on other WiFi networks. My neighbor upstairs was using the same 2.4 channel as my router which drove my thermostat to drop connection to my network. I changed my 2.4 channel and it has been rock solid since.

    Another issue I had was when I used separate SSID. For whatever reason, I logged my iPhone into the ISP router's WiFi for whatever reason. Apple shares WiFi network information between devices, cool idea. However, periodically my other devices would flip between WiFi networks causing what appeared to be internet loss issues. I told my Apple devices to forget the ISP WiFi and also disabled the ISP WiFi and haven't an issue since.

    Here are the WiFi signals near me. Note that my WiFi is highlighted:

    Screen Shot 2019-01-10 at 12.39.39 PM.jpg
     
    Rockel83 likes this.
  3. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    Thanks for your input there! :)

    I was also thinking the same this afternoon. So tried changing the WIFI channel to see if it helps solving it already.
    It was set on "auto" and was using "channel 8" which was not verry occupied in my environment. But turned of "auto"and set is manually to "channel 13", curious how it's holdig up there.
    I'ts seems to keep up better, but still not perfect. Still having some drops as it seems.

    [​IMG]

    I was thinking/hoping that it could be some interference because the WIFI strength keeps up and wired connections won't suffer the same issues.

    I've turned my ISP router into "bridge mode". So the wireless network of that one isn't active and only configured my wireless devices to my AC66U in this enironment.

    I recently started playing around with smart plugs (Blitzwolf) and flashed them with Tasmota firmware. It seems that these devices connect to the network constantly for status updates? Not sure if this could interfere with the wireless connection somehow?
     
    Last edited: Jan 10, 2019
  4. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    1,224
    Location:
    USA
    Did you reset the router after loading Merlin firmware?

    OE
     
    Rockel83 likes this.
  5. ApexRon

    ApexRon Senior Member

    Joined:
    Jun 17, 2018
    Messages:
    429
    Location:
    Apex, NC
    Whatever it takes to disable the ISP router's WiFi, as long bridge mode does not cause other challenges.

    For purposes of testing, can you unplug the Blitzwolf devices temporarily? I have a weather station whose poor engineering design turns off the WiFi every 5 minutes for about a minute or two. Oh it does not interfere with anything yet but when the WiFi is enabled it attempts to phone home too quickly and flashes, annoyingly, a message that it can't connect.
     
    Rockel83 likes this.
  6. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    Yes I did :)

    I double checked it by logging in to the ISP router. There the configuration says that it's WIFI is indeed disabled.

    I disconnected all the smart plugs already, except one, which is really hard to reach at the moment (behind an electric fireplace). So I'm thinking of just cutting off the power of that part temporarily will be easier. I should be able to give it a try!

    Edit: Well I was thinking, more and more devices making use of wireless connections. Especially when playing around with home automation. The AC66U has the great option of creating multiple guest networks. Maybe I should make a seperate network for all these home automation things. It should clear out my network a bit I guess. And I could turn it off/block all together this way.
     
    Last edited: Jan 10, 2019
  7. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    It seems to be that the router (AC66U_B1) is quite vulnerable to (connected) WIFI deveices nearby. Seems somehow to interfere with the router.
    I've repositioned some devices and the problem seems to be gone (well it seems to hold up much better like this)!
     
  8. bbunge

    bbunge Very Senior Member

    Joined:
    Aug 11, 2014
    Messages:
    866
    Location:
    Pennsylvania USA
    I am currently running my AC66U_B1 on Merlin 384.9 beta 1 with Stubby/Entware added on a USB stick. The wifi in my neighborhood is not as crowded as yours and I do not have any iot devices. Just a couple if phones, tablets, iPods and wifi connected PC's.
    I have John's fork running on a couple of AC68U routers in a heavy wifi environment. Have also run that version on my AC66U_B1 with great success. I feel his older drivers are a bit more stable for wifi.
    You may want to give it a try to improve your wifi connections.

    Sent from my SM-T380 using Tapatalk
     
    Rockel83 likes this.
  9. route

    route Occasional Visitor

    Joined:
    Dec 18, 2018
    Messages:
    19
    Do you have different names for the 2.4ghz and 5ghz bands? I had problems when I named them the same.
     
  10. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,710
    Hi, I think you should change from ch. 5 to ch. 6 as 1 and 5 are overlapping a bit and can create huge problems (I had them) solved by changing to 1-6-11 channel map.

    In theory 1-5-9-13 should work fine with only g/n devices, but what I learned the used filters are broader to cover b-mode too, so they interfere even if you only use g/n mode as they are the same unchanged for all modes.
    Thats different in 5G, as there never been a b-mode with broader spectrum and filters match better.
     
  11. meangene

    meangene New Around Here

    Joined:
    Oct 23, 2018
    Messages:
    7
    Disable the 5 ghz wifi, that worked for me. No problems since then.
     
  12. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,710
    Really funny to read such suggestions :p
    Connecting by LAN solved all my Wifi problems :D

    Same way Boeing could solve their problems with 737 MAX 8, dont let them lift off, just drive them like a car from one side of the runway to the other or build streets between the cities where they could drive!
     
    Last edited: Apr 5, 2019
    JemTheWire and Rockel83 like this.
  13. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    Thanks all for the provided ideas and feedback! Appreciate it!

    I always used MAC-filtering on my routers. Also on my current router AC66U_b1, which worked before.
    But it seems this was causing the connection drops. Just having a stable connection now it's turned off.

    Hope it's just an update issue, and that it will be resolved in the near future.
     
  14. martinr

    martinr Very Senior Member

    Joined:
    Nov 27, 2014
    Messages:
    1,787
    Location:
    United Kingdom
    I doubt it’s something that will be “fixed” by an update because I’ve not seen any other mention of MAC filtering giving any problems. I’ve used it on my RT-AC68U for years.

    Perhaps you could try MAC filtering again, first just with one wireless device and see what happens. If ok, then add another one and so on. If you have problems when the first device is initially added, try a different device as the first one. See if there’s any pattern.
     
  15. Rockel83

    Rockel83 New Around Here

    Joined:
    Jan 10, 2019
    Messages:
    6
    I've configured my router a few times with diffrent firmware already, the stock and the Merlin version. Just added the MAC-adresses of all my wireless devices in the MAC-filtering section. But when MAC-filtering is turned on, the connection is dropping constantly, even can't stream music without constant interuptions.
    When I only switch off MAC-filtering, so the rest of the configurations and the connected devices stay as they are, the issues are gone.
    So maybe it's an connected device which is causing this issues in combination with MAC-filtering but all of the connected devices have a normall connection to the router and the internet when MAC-filtering is turned off. So that makes not much sense to me.
     
  16. martinr

    martinr Very Senior Member

    Joined:
    Nov 27, 2014
    Messages:
    1,787
    Location:
    United Kingdom
    Did you try it with only one device connected and MAC Filtering turned on?

    I'd even try removing all the MAC Filtering entries except for a single device and see if it still happens with just one entry.

    Have you looked in syslog at the time you turned MAC Filtering on to see if anything stands out?
     
    Last edited: Apr 23, 2019