1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

WiFi Latency Spikes Caused By Powersaving - How to disable?

Discussion in 'General Wireless Discussion' started by ryannathans, Jun 23, 2019.

  1. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    Hi all

    I've spent a week tracking down a VERY annoying problem. Every few seconds, my WiFi (any band/channel) on my desktop computer encounters packet loss or high latency. Here is a screenshot pinging my default gateway:

    upload_2019-6-24_11-4-20.png

    I used to get 1-2 ms all day long, but, recently this has started happening. Even during downloads or latency-critical applications. Sometimes it spontaneously fixes itself for a few minutes/hours but it keeps occurring.

    But I found the culprit, finally.

    upload_2019-6-24_11-6-10.png

    The powersaving flag comes on VERY BRIEFLY for a second or so during each ping spike.

    How the heck do I fix it? I'm on a desktop PC running Windows 10 Pro 64bit 1809 (17763.557). All the power saving settings I can find are set to maximum performance. E.g.

    upload_2019-6-24_11-10-57.png

    Please help :)
     
  2. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    Check in Computer -> Manage -> Device Manager -> Nertwork Adapters -> "Your Adapter" -> Properties -> Power Management -> Allow the computer to turn off this device to save power
     
  3. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    upload_2019-6-24_11-41-54.png

    It seems this tab doesn't exist anymore? In fact, this tab doesn't seem to exist on any device in device manager anymore
     
  4. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    If this is the only PC on your network with the issue, then check the power management on that PC. I would start checking BIOS settings first, then move to OS settings. Do you see Computer -> ACPI x64-based PC in your Device Manager? Does it say "This device is working properly" in Properties? Try to re-install the drivers by removing the devices and "Scan for hardware changes". Sometimes helps.
     
  5. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    I have reinstalled the driver for my network adapter, tried a different version of driver and also confirmed ACPI x64 based PC is working correctly I device manager. The problem persists on all tested drivers.

    Interestingly, the same problem occurs on another desktop computer in the house (but not on my laptop). Both running the same version of Windows, but this is the only similarity. All hardware is different. The same problem also occurs with the on board wifi adaptor in my desktop PC, as well as the PCIe one pictured above.
     
  6. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    Any power saving features enabled on the router? Any changes in Wireless -> Professional section?
     
  7. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    I have the ASUS RT-AC5300 running merlin 384.12. Yesterday I performed a full reset (reset NVRAM, JFFS, initialized defaults). I have not modified the professional section and I am not aware of any power saving features that I can modify on the router
     
  8. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    I would try to change two things on the router in Wireless -> Professional:

    - lower the DTIM Interval to 1 (ASUS default is 3) and test again
    This tells the devices when to wake up and receive the data

    - disable WMM APSD (ASUS default is Enabled) and test again
    This has to stop the devices to go to power save mode altogether

    Mobile devices will drain the battery faster though after the change.

    Post a screenshot of your settings in Professional.
     
    Last edited: Jun 24, 2019
  9. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    I've had some success, approx. 20 minutes ago I did a "network reset" in Windows

    upload_2019-6-24_20-59-3.png

    I haven't seen any spikes in latency since - eg.

    upload_2019-6-24_20-59-26.png

    I've seen this problem resolve itself and reappear just hours later previously (when swapping wireless adapters for example). If/when this occurs again I will try your suggested changes.

    Settings for your scrutiny
    upload_2019-6-24_21-1-29.png
    upload_2019-6-24_21-1-3.png
    upload_2019-6-24_21-1-54.png
     
  10. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    8,847
    Location:
    UK
    I've experienced very similar problems in the past with WiFi adapters that installed a "utility" that sits in the Windows notification area (system tray). Uninstalling that utility solved the problem.
     
  11. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    Thankfully ASUS have not made a utility for this network card - PCE-AC88 :D
     
  12. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    I would disable also:

    - TX Bursting -> does not apply for N/AC networks, only B/G and with 1-5 devices
    - MU-MIMO -> may reduce the throughput on some 2-stream N/AC devices
    - Beamforming -> may cause compatibility issues in some devices and doesn't help much to improve the throughput
    - NitroQAM -> Broadcom non-standard 1024-QAM support, not part of standard N/AC specifications

    Your ASUS PCE-AC88 adapter is very fast. No need to push things to the limit. Other devices on your network may have issues.
     
  13. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,590
    After a very quick look at your settings, I would suggest disabling Universal Beamforming on all radios/bands and setting the 2.4GHz Preamble Type to Short. :)

    (I'm assuming all the others are defaults). ;)
     
  14. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    Preamble Type Long is the Default setting and is recommended for better compatibility with older devices and in areas with high interference and low signal. We don't know how many WiFi networks transmit around ryannathans. Why to change it? It doesn't make a big difference in performance anyway.
     
  15. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,590
    Long Preamble type is for older devices, yes. From around 1997 to 1999. :)

    Time to move on. ;)

    I have not worked on any network with current devices today that benefits from Long Preamble set. :)
     
  16. Val D.

    Val D. Regular Contributor

    Joined:
    Jun 16, 2019
    Messages:
    80
    Location:
    Canada
    True, but even now most routers and access points come pre-configured with Preamble Type Long or Auto. Also, this setting has nothing to do with the issue ryannathans has.
     
  17. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,590
    That's why I suggest it be changed. :)

    Never said it had anything to do with the issue here. ;)
     
  18. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    When I turned my PC on this morning the issue came back :(

    I have adjusted the settings as suggested. Even with DTIM 1 and automatic power saving turned off (WMM APSD) the power saving latency issue still occurs on my desktop. Interestingly, with APSD turned off, all the phones still show P flag for power saving.
     
  19. ryannathans

    ryannathans Occasional Visitor

    Joined:
    Nov 25, 2016
    Messages:
    44
    The Windows "network reset" fixed it again... for how long...

    Maybe I will write a script to do a network reset every reboot :mad:
     
  20. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    8,847
    Location:
    UK
    It sounds like you need to investigate the Windows side some more. Try running the task manager side by side with your ping window.