Wifi users not getting IP from Windows DHCP on RT-AC88U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Manorexia

Occasional Visitor
I have two RT-AC88U routers. Router A is running Merlin 386_3.2, and Router B is running stock (3.0.0.4.386) in AP mode. Everything seems to be set up identically except for the firmware, the mode (wireless router mode on Router A, AP mode on the other), and the VPN settings (Router A is running as an OpenVPN server).

Any device plugged into the network runs fine. Any wireless device that connects to Router B is fine, as well... Router A, however is the issue... 90% of time, devices will connect, and self-assign the IP address. Sometimes, a device will just suddenly get an IP address a few hours later if left on the wireless, it seems... and then not have any issue (until it disconnects from the wifi). My theory right now is that the VPN is causing the issue (since it has a small DHCP address pool of its own), but it's really just a guess. Anyone have any ideas? This one's leaving me scratching my head.
 

dosborne

Very Senior Member
Have you looked in the log to see if the router is getting the DHCP requests and what it is doing with them? Have you tried disabling the VPN options to see if there is any actual correlation to the DHCP issue? If the DHCP server is setup correctly, and there is nothing definitive in the logs, when was the last time you reset to factory defaults and reconfigured from scratch? I'd also try turning off the AP router and see what happens.
 

Tech9

Very Senior Member
Any wireless device that connects to Router B is fine, as well... Router A, however is the issue... 90% of time

Router B is the AP. Router A is the Router. Router A DHCP is assigning IPs for the whole network. How come devices on Router B have no issues? Sounds like Wi-Fi radio issues in Router A to me, not DHCP related. What's connected to this VPN server? What is Windows DHCP in thread title?
 

Manorexia

Occasional Visitor
Router B is the AP. Router A is the Router. Router A DHCP is assigning IPs for the whole network. How come devices on Router B have no issues? Sounds like Wi-Fi radio issues in Router A to me, not DHCP related. What's connected to this VPN server? What is Windows DHCP in thread title?
Just to be clear: the DHCP server is a Windows 2008 R2 server. The VPN server on the router has its own DHCP service, it seems.
 

Manorexia

Occasional Visitor
I have two RT-AC88U routers. Router A is running Merlin 386_3.2, and Router B is running stock (3.0.0.4.386) in AP mode. Everything seems to be set up identically except for the firmware, the mode (wireless router mode on Router A, AP mode on the other), and the VPN settings (Router A is running as an OpenVPN server).

Any device plugged into the network runs fine. Any wireless device that connects to Router B is fine, as well... Router A, however is the issue... 90% of time, devices will connect, and self-assign the IP address. Sometimes, a device will just suddenly get an IP address a few hours later if left on the wireless, it seems... and then not have any issue (until it disconnects from the wifi). My theory right now is that the VPN is causing the issue (since it has a small DHCP address pool of its own), but it's really just a guess. Anyone have any ideas? This one's leaving me scratching my head.
OMG, I'M AN IDIOT!

I already FIXED THIS! It was my very first post in this forum!!!!!! :rolleyes:

Sorry, everyone. Some time ago, I had to reset the router, and I never turned the custom jffs back on. I needed to use dnsmasq --dhcp-relay in the custom config. Going to go do that now. UGH! Getting old is THE WORST.
 

Manorexia

Occasional Visitor
In the past, the DHCP relay fixed everything... but for some reason, it's still intermittent (I might have something set wrong, but I just don't have the time to look into it), and I finally said enough's enough and talked my boss into buying a device that can actually do the job without jumping through hoops. So long, and thanks for all the fish!
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top